Recent Topics

1 Aug 30, 2007 06:10    

My b2evolution Version: 1.10.x

I've tried to install gallery plugin and create a new blog. I set file permissions to 777, 775 and 755 but I always receive a error message:

Warning: mkdir() [function.mkdir]: Unable to access /usr/home/myblog com/web/blog/media/gallery_plugin/

When I create a new blog I can't upload media because a receive a error message telling that media directory could not be written

How can I solve this problem, any idea?

3 Aug 30, 2007 13:39

mving this -- it doesnt belong here

5 Aug 31, 2007 00:56

How sure are you that that script works fine, as I just tried it on my blog, and got 777 permissions for the media dir, but 755 permissions for the subdirs, but plugins or whatever can still read/write fine to the subdirs...

Current script owner (irrelevant): balupton
Process user:nobody

Effective perms are highlighted/bold.
Green user and groupnames can write.
Brown user and groupnames can read.
Red user and groupnames cannot read/write.

    * /path_to_b2evo/b2evolution/media/:
      777 / balupton/bhuk
          o /path_to_b2evo/b2evolution/media/avatars_plugin/:
            755 / nobody/nobody
                + /path_to_b2evo/b2evolution/media/avatars_plugin/_temp/:
                  755 / nobody/nobody
                + /path_to_b2evo/b2evolution/media/avatars_plugin/default/:
                  755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/avatars_plugin/default/user/:
                        755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/avatars_plugin/default/post/:
                        755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/avatars_plugin/default/blog/:
                        755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/avatars_plugin/default/category/:
                        755 / nobody/nobody
          o /path_to_b2evo/b2evolution/media/gallery_plugin/:
            755 / nobody/nobody
                + /path_to_b2evo/b2evolution/media/gallery_plugin/images/:
                  755 / nobody/nobody
                + /path_to_b2evo/b2evolution/media/gallery_plugin/213344152603766/:
                  755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/gallery_plugin/213344152603766/large/:
                        755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/gallery_plugin/213344152603766/small/:
                        755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/gallery_plugin/213344152603766/medium/:
                        755 / nobody/nobody
                + /path_to_b2evo/b2evolution/media/gallery_plugin/025219256416823/:
                  755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/gallery_plugin/025219256416823/large/:
                        755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/gallery_plugin/025219256416823/small/:
                        755 / nobody/nobody
                      # /path_to_b2evo/b2evolution/media/gallery_plugin/025219256416823/medium/:
                        755 / nobody/nobody
          o /path_to_b2evo/b2evolution/media/music/:
            755 / balupton/bhuk
                + /path_to_b2evo/b2evolution/media/music/Jet Set/:
                  755 / balupton/bhuk

6 Aug 31, 2007 10:55

This is what I get when I try to install galery plugin

Warning: mkdir() [function.mkdir]: Unable to access /usr/home/ in /usr/home/ on line 221
ERROR: Please make sure that your media directory has 777 permissions.

The problem is that my Media directory has 777 permissions and blog and users subdirectories too.

Any Idea?

7 Sep 02, 2007 20:51

mar1985, so this problem is only with the gallery_plugin?
Please try the script..!

balupton, what do you mean? 755 should work if the (plugin) scripts get executed as the owner of the dir.
Is the "ERROR: Please make sure that your media directory has 777 permissions." from your plugin? I hope so, because 777 is _not_ recommended. It should rather say that the directory must be writable.

9 Sep 02, 2007 21:45

balupton wrote:

The manual says differently

chmod 777 /blogs/media in order to upload images and other media from b2evo's backoffice.

Argh! The manual says so, because it's too difficult for people to understand IIRC. Here's another page in the manual about it:

The problem appears to be crappy PHP setups, where all scripts are executed as e.g. "www-data".

balupton wrote:

And how would I know (or make) the owner be the one executing.

"chown" and "ls" are your friends (on a UNIX system).
Then, you need to setup the webserver to execute all .php scripts in a given document root as a given user (e.g. by using (fast)cgi, suexec or suphp)

But this is really not the point here!

Apparently the permissions appear to be 777, but it fails nonetheless.

10 Sep 02, 2007 21:54

Yeah so you're saying I should try and use/set 755 and if that fails then try 777, as I don't think any user would bother correcting the file ownerships.

11 Sep 03, 2007 22:17

Yeah what do you mean? You cannot chmod a file which is 755 and you're not the owner.
Yeah I still think that mar1985 should report back, what the permission debug script reports for him.

12 Sep 04, 2007 10:56

Yeah, but what my script does atm, is if it is not writeable it tries chmoding 777, then continues. And if that fails I tell users to chmod 777 manually. So you are saying that we should try 755 first then 777?

13 Sep 04, 2007 20:20

Only the owner of a file can change file permissions..! (surprising??)

This implies that 755 is already fine, _if_ you are the owner.

You should read and if you have a unix system at hands, try "man chmod".

14 Sep 05, 2007 15:28

Sorry for my late answer! I purposed this topic and I didn't thank you all for your answers. But I've veen out of town so... Sorry!

My problem with mkdir function is not only focused on gallery plugin. When I try to create a new blog this is the message I receive:

The blog's media directory «media/blogs/new/» could not be created, because the parent directory is not writable or does not exist.

I set 777, 775,755 file permissions but nothing changed

Could it be a problem from my host? Because recently I moved to a new one. I've tried to re-install b2evolution but function mkdir doesn't work... there is no way!

If this is a problem with my host, what should I ask them?

THANKS :) :) :) [/code]

15 Sep 05, 2007 23:00

mar1985, please post the output of the mentioned debug script...

I guess you've either set the permissions on the wrong directory, e.g. not on "blogs" or it has not worked out.
Maybe mkdir is disabled on your host, too.

But, please, upload the script and paste the output here!

Form is loading...