Recent Topics
Started by on Feb 11, 2008 – Contents updated: Feb 11, 2008

1 Feb 11, 2008 03:54    

My b2evolution Version: 1.10.x

My RSS feed is not validating because of a blank first line.

I've tried Atom, RSS and RSS2 and the problem occurs with them all.

The feed is http://hypno.co.nz/blogs/index.php?tempskin=_rss.

Any idea where I start to look for the issue?

Thanks.

2 Feb 11, 2008 15:43

Hi mikerm,

Welcome to the forums.

The error lies in the files /skins/_rss, /skins/_atom and /skins/_rss2. Those are the skins that generate the RSS feeds.
One possible cause of the problem is the way you upload the files to the server. This should be done in 'Ascii' format and not in 'binary' format. Usually you can set your FTP program to autodetect the upload mode.
So I advise you to upload the named folders to the server again.

Good luck

3 Feb 11, 2008 22:49

Thanks for the suggestion, but it wasn't that - I tried it, no difference.

4 Feb 11, 2008 23:56

check for whitespace in conf/_basic_config.php

¥

5 Feb 12, 2008 00:32

Thanks, Yabba - couldn't see any there either. I did modify /conf/_advanced.php to rename the htmlsrv directory to "comments/" yesterday, as recommended in the antispam thread - I can't see any whitespace there either, but could that have caused the problem?

6 Feb 12, 2008 00:37

Yes,
You are looking for a file that starts or ends with a blank line. That means white space *before* the first <?php or *after* the closing ?>.
You say you have edited _advanced.php so recheck that file. You may have edited _basic_config.php so check that one also.

Good luck

7 Feb 12, 2008 01:13

That was it, Afwas, thanks - there was a blank line at the end of _advanced.php. Problem solved.


Form is loading...

Run your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.