Recent Topics

[Solved][1.10.x] Login failed after installation

Started by on Feb 12, 2008 – Contents updated: Feb 12, 2008

1 Feb 12, 2008 01:08    

My b2evolution Version: 1.10.x

Hello, extreme newbie here. I installed b2evolution (1.10.3). I uploaded them via FTP to my server. I changed the permissions on the files as per the installation manual. I installed b2evo sucessfully and received my automatic login. :D

When I clicked on the login link I got: :'(

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@aite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
--------------------------------------------------------------------------------

Apache/1.3.39 Server at *site*.com Port 80

Can anyone help me? Thanks!

2 Feb 12, 2008 01:24

Hi airnj,

Welcome to the forums.
You probably entered a wrong $baseurl. Do check the file /conf/_basic_config.php. There you find around line 89:

$baseurl = 'http://localhost/b2evolution/blogs/';


This variable must match the site of your blog. If your blog is in a blogs folder, do add the /blogs/, if it is not, then simply leave it out. Do close the URL with the slash.

Please report back to this topic if it worked or not.
Good luck

3 Feb 12, 2008 01:53

Sorry, it did not work. :( What else can I check? Thanks

4 Feb 12, 2008 02:04

Can we get a link to your installation?

5 Feb 12, 2008 02:06

sure...tell me what you need

7 Feb 12, 2008 02:22

I'm sorry, I don't know how to do that. If I give you the URL, you will need the username and password to view it, or is there a trick to making it external. I could cut and paste it here.

* This is b2evolution's basic config file.
 *
 * You need to edit this file to your settings before attempting to install the database!
 * Last significant changes to this file: version 1.6
 *
 *
 * Reminder: every line starting with # or // is a comment, multiline comments are
 *           surrounded by '/*' and '* /' (without space).
 *
 * IMPORTANT: Take special care not to erase quotes (') around text parameters
 * and semicolums (;) at the end of the lines. Otherwise you'll get some
 * "unexpected T_STRING" parse errors!
 *
 * Contributors: you should override this file by creating a file named _config_TEST.php
 * (see end of this file).
 *
 * @package conf
 */
if( !defined('EVO_CONFIG_LOADED') ) die( 'Please, do not access this page directly.' );


/**
 * Maintenance mode. Set this to 1 in order to temporarily disable access to the application.
 *
 * Note: it is still possible to access the install script during maintenance mode.
 */
$maintenance_mode = 0;


// Below is an alternative hardcore version of maintenance mode.
// This one will bloc the install script too.
// Remove /* and */ to activate.
/*
header('HTTP/1.0 503 Service Unavailable');
echo '<h1>503 Service Unavailable</h1>';
die( 'The site is temporarily down for maintenance.' );
*/


/**
 * MySQL DB settings.
 * Fill in your database details (check carefully or nothing will work!)
 */
$db_config = array(
	'user'     => 'XXXX',     // your MySQL username
	'password' => 'XXXX',     // ...and password
	'name'     => 'airnj_b2evolution',  // the name of the database
	'host'     => 'localhost',    // MySQL Server (typically 'localhost')
);


/**
 * the tables prefix (gets placed before each b2evo table name),
 * use this to have multiple installations in one DB.
 *
 * @global string $tableprefix
 */
$tableprefix = 'evo_';


/**
 * If you want to be able to reset your existing b2evolution tables and start anew
 * you must set $allow_evodb_reset to 1.
 *
 * NEVER LEAVE THIS SETTING ON ANYTHING ELSE THAN 0 (ZERO) ON A PRODUCTION SERVER.
 * IF THIS IS ON (1) AND YOU FORGET TO DELETE THE INSTALL FOLDER, ANYONE WOULD BE ABLE TO
 * ERASE YOUR B2EVOLUTION TABLES AND DATA BY A SINGLE CLICK!
 */
$allow_evodb_reset = 0;	// Set to 1 to enable. Do not leave this on 1 on production servers


/**
 * $baseurl is where your blogs reside by default. CHECK THIS CAREFULLY or nothing will work.
 * It should be set to the URL where you can find the blog templates and/or the blog stub files,
 * that means index.php, blog_b.php, etc.
 * Note: Blogs can be in subdirectories of the baseurl. However, no blog should be outside
 * of there, or some tricky things may fail (e-g: pingback)
 *
 * IMPORTANT: If you want to test b2evolution on your local machine, do NOT use that machine's
 * name in the $baseurl!
 * For example, if you machine is called HOMER, do not use http://homer/b2evolution/blogs/ !
 * Use http://localhost/b2evolution/blogs/ instead. And log in on localhost too, not homer!
 * If you don't, login cookies will not hold.
 *
 * @global string $baseurl
 */
$baseurl = 'http://hobbitslife.com/blogs/';


/**
 * Your email. Will be used in severe error messages so that users can contact you.
 * You will also receive notifications for new user registrations there.
 */
$admin_email = 'airnj@hotmail.com';


/**
 * Once you have edited this file to your settings, set the following to 1 (one):
 */
$config_is_done = 1;


# IMPORTANT: you will find more parameters in the other files of the /conf folder.
# IT IS RECOMMENDED YOU DO NOT TOUCH THOSE SETTINGS
# UNTIL YOU ARE FAMILIAR WITH THE DEFAULT INSTALLATION.
#
# It is however strongly recommended you browse through these files as soon as you've
# got your basic installation working. They'll let you customize a lot of things!
?>

8 Feb 12, 2008 02:35

Hi airnj,

You have a 500 error (internal server error), which means something is not set up correct with your server. Last time I encountered one was when the permissions to the main folder were set to 777.
In your case it may bee that the server is not set up to process php files or it does not automatically detect index.php as first file, although the /install/ folder is there and works as expected.
Does anybody here have valuable suggestions other than the 'contact your host about this' advise that I can give you?

Good luck

9 Feb 12, 2008 03:43

Well, thanks for all your help but believe it or not, I fixed it! :D :D

I searched your forums for 500 Internal Server Error and found a post that said "in cpanel, view the apache logs". I found the apache error logs and saw that there were numerous errors of:

SoftException in Application.cpp:246: Directory "/home/airnj/public_html/blogs" is writeable by group

Then, i re-read Afwas comment of "seeing this when the main folder permission was set to 777".

I changed the permission to the blog directory to 745. I had to remove the write and execute permission from Group. And remove the write permission from World. No more ERROR! Now I am able to enter b2evolution and start working.

Of course, I MAY be back in the future with other questions and issues.... :>>

10 Feb 12, 2008 11:11

Well done. I hope you enjoy B2evolution.

Good luck


Form is loading...

Free CMS – This forum is powered by b2evolution CMS, a complete engine for your website.