Recent Topics

[1.10.x] 2.4.1 error 500 page when clicking on edit butt wit

Started by on Mar 17, 2008 – Contents updated: Mar 17, 2008

Mar 17, 2008 19:40    

My b2evolution Version: 1.10.x

Hi there,
New to b2evolution, I have sorted a few problems out by trial and error but cannot sort the below problem which has been happening since installation and is not due to any edits I have made.

Although editing posts via the backoffice works fine, I get a 500 error page when I try to edit a post directly from the 'edit' button in the post itself.

The same thing happened when I was running 2.40

Please could you help me sort out this annoying problem.
I'm not sure which details you may need but here are a few I can think of.

URL: http://www.barnesnet.co.uk
Version 2.40 or 2.41
PHP version 5.2.5
MySQL version 5.0.45-community

Thanks in advance

Mar 23, 2008 10:06

Please could someone help me with this? I have done a clean install and chosen a different skin but still get the same problem.

Both the edit and delete icons in the posts result in an error 500 page

The links are like so:

http://www.barnesnet.co.uk/admin.php?ctrl=items&action=edit&p=26&redirect_to=http%3A%2F%2Fwww.barnesnet.co.uk%2F%3Fblog%3D1

http://www.barnesnet.co.uk/admin.php?ctrl=comments&action=delete&comment_ID=1&redirect_to=http%3A%2F%2Fwww.barnesnet.co.uk%2Findex.php%2Fhome%2F2008%2F03%2F22%2Ffirst-post%3Fblog%3D1%26title%3Dfirst-post%26disp%3Dsingle%26more%3D1%26c%3D1%26tb%3D1%26pb%3D1

Please help, its so annoying, to make a quick edit or delete I need to go into the backoffice and find the post from there.

Mar 23, 2008 10:57

Hi sims,

Most often that I encountered a 500 error in a B2evo blog something was wrong with the file permissions. It happens if they are set too loose e.g. 777 for a file.
Do check the files in the root of the blog and see if this is the case. Did you change any permissions manually?

There may be other things happening. Do try a Google search on Apache 500 error.

Good luck

Mar 23, 2008 11:15

Thanks for your reply, I did have a permissions thing in the back of my mind but actually forgot about it.
Do we know what the permissions are supposed to be or does it vary from server to server?
I haven't changed any permissions manually but I guess that doesn't necessarily mean they are correct.

I am off out right now but will definitely look into that when i get back.
All the best

Simon

Mar 23, 2008 13:40

Usually 755 for folders and 644 for files. Regarding the 500 error you are typically looking for files with permission set to 777.

Good luck

Mar 23, 2008 13:53

I have been playing around with the settings but had no luck.
My folders were set to 755 and files to 644 as you mentioned. Changing them makes either no difference or stops access altogether.

I cant find any files even within folders that are set to anything but the above.

I'm stuck

Mar 24, 2008 09:50

admin.php?ctrl=items&action=edit&p=196&redirect_to=http%3A%2F%2Fwww.blog.hemminga.net%2Findex.php%3Fblog%3D12%26orderby%3Dptyp_ID%2520datestart


That 's one of my edit links. So I don 't think anything wrong with that. Anybody got an idea?

Mar 24, 2008 15:16

¥åßßå wrote:

the chances are that they have mod_security enabled and the http:// bit is killing the blog

I tested this and he looks to be correct. You can try to disable mod_security in either .htaccess or php.ini. Try a Google search for more information or explain to your host the situation and ask for help.

Good luck

Mar 24, 2008 20:28

MMMMM, thats interesting, thank you.

I did a quick google and found some slightly relevant info.

I have tried putting 'SecFilterEngine Off' in my .htaccess but it stopped my whole site working. I think I will ask my hosts if they have any ideas or settings they can change.

Thank you

Mar 25, 2008 09:14

This is what we had in our vhost.conf to disable mod_security

##edit by whoo (its off)
<IfModule mod_security2.c>
SecRuleEngine Off
</IfModule>

You can try the same thing in .htaccess and see if it works

¥

Mar 25, 2008 15:45

It looked promising but hit me back with an internal server error.

aaarrrrggghhhh

thanks anyway

Mar 25, 2008 23:47

Just an update for you.

Got this reply from my hosts:

We use the most secure setting with mod_sec to stop hackers from exploiting vulnerabilities from insecure scripts. Software vendors should be able to reprogram their scripts to stop 500 errors. If you do not want mod_security to check your site the add these lines in your .htaccess, however be warned that your site will be liable for attack on any vulnerable scripts.

SecFilterEngine Off
SecFilterScanPOST Off

I tried those additions to the htacces file but just got an internal server error again.

Looks like I'll be doing things the long way round!!


Form is loading...

Build your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.