Recent Topics

[2.x] B2Evolution Blog and Backoffice are all blank pages

Started by on Mar 30, 2008 – Contents updated: Mar 30, 2008

Mar 30, 2008 07:48    

My b2evolution Version: 2.x

Just finished installing version 2.4.1 stable version on my site. Everything said it installed correctly. On the success page, the admin username and password were provided and I followed the link to login. However, after entering the admin name and password, the resulting page was blank.

The regular blog page is blank as well.

In my searching of the forums, there were a couple of references to blank pages - usually in the back office. I have increased the memory in the php.ini file (and in the _advanced.php file in the /conf directory).

The php version installed on the server is 4.3.0 and the version of mysql is 3.23.56.

I deleted the database tables and reinstalled with the same result. Firefox, safari, and IE all just show blank pages with no error messages. There are no error messages in the error logs.

I tried to enable the error logs for b2evolution, but they returned the error:

MySQL error!
You have an error in your SQL syntax near 'sql_mode = "TRADITIONAL"' at line 1(Errno=1064)

I expect this error is showing up because I don't have mysql v5.x as documented in a previous forum post.

I am at a loss as to what to do.

Any hints or suggestions?

Much thanks in advance!

Mar 31, 2008 11:45

To get rid of the "TRADITIONAL" error, delete this section of inc/_core/model/db/_db.class.php ( approx lines 414 to 417 )

		if( $debug )
		{ // Force MySQL strict mode
			$this->query( 'SET sql_mode = "TRADITIONAL"' );
		}

Your debug should then work and will hopefully give you more of a clue.

You might also like to turn display errors on by un-commenting ( remove the // ) from this line in conf/_advanced.php ( approx line 41 )

// ini_set( 'display_errors', 'on' );

¥

Mar 31, 2008 14:48

I made the modifications to the _db.class.php module to eliminate the "TRADITIONAL" error and uncommented the ini_set( 'display_errors', 'on' ); line in the _advanced.php file and still am getting blank pages both in the blog and the backoffice.

I blew away the database and completely reinstalled everything from scratch, made the modifications to enable the debugging and am still getting the blank pages. Not even the debug info is showing up.

Mar 31, 2008 18:25

By any chance did you manually enter your details into /conf/_basic.config.php ? If so, check for errors/whitespace in that file.

Just in case you're thinking of copy/pasting that file into here, remember your database details are in there .... not something you want to publicise on the web ;)

¥

Mar 31, 2008 19:50

I actually did not touch the /conf/_basic.config.php file. It is as pristine as the installer can make it...

I can post it here if it would help. (Thanks for the reminder about it containing the database details).

Mar 31, 2008 20:05

bugger, it's never the easy answers :(

Any chance you could PM EdB with your ftp details and a link to this post? ..... He's far soberer than I am at this moment in time and, with a tad of luck, he'll have cured this before I next wake up :D

¥

Apr 01, 2008 01:12

Well that's odd. The web works but not the blog, but admin.php shows a login page, and summary.php shows the header section thing with no content.

2 things to think about and maybe try. I see you've got like 8 different blog-like folders. I assume those that are b2evo came from the same zip package you downloaded? Try (a) deleting all the b2evo installations from your server then (b) grabbing a brand new copy of the zip package from the downloads page and trying again. Just in case it's a crapped up file somewhere. The thing is it could have gotten crapped up anywhere from download to install, so starting with a fresh zip package will cure it IF that is the problem.

Second, I'd be talking to the host about what might be the issue here.

Oh wait I thought of a third thing that can give some potentially helpful info: try installing v1.10.3 and see if that works.

Also I would do it without spaces in the path name. Like "blogs_v1103" for testing that version.

Good luck with this.

Apr 01, 2008 06:31

Hey EdB - thanks for your suggestions.

So this is what I did. I deleted all of the old blog directories (failed attempts at installing 2.4.1) and did a fresh install...same result. Blank pages for everything except the admin login page and the summary.php header.

I talked to my host, and they of course referred me back to B2Evolution...

I then tried 1.10.3 and that installed without a problem and is the only thing that I have installed on the server right now. So what is different between 1.10.3 and 2.4.1. Should I try to upgrade?

Let me know your thoughts

Apr 01, 2008 12:11

The main difference between 1.10.x and 2.4.x is the amount of memory required.

I know you said that you increased the memory limit but you need to check your phpinfo() to see if the change actually happens.

¥

May 01, 2008 09:41

Hello,

I have the same problem.

All pages are blank after installation (version 2.4.2).
I tried several times, tried to update, install a bdd from another working site (with the same version).
Always blank screen.

Hosteur : ovh gp60

I try all I find on this post and some else, and nothing happens. Always blank screen...

On phpinfo, not mention about memory_limit. So maybe it can be the pb.

If you have the same plan and the same problems... Thanks for your help

8|

http://lesmagouilles.com/ b2evo works with an iframe (installation on another domain)
http://lesmagouilles.com/index.php b2evo shows only blank screen...


Form is loading...

Social CMS – This forum is powered by b2evolution CMS, a complete engine for your website.