Recent Topics

[Solved] New template $disp issues

Started by on Apr 01, 2008 – Contents updated: Apr 01, 2008

1 Apr 01, 2008 21:04    

My b2evolution Version: Not Entered

I'm working on a new template/skin2.0 for my website at http://www.amaranthsgardens.com/blog/ to match the other pages that are already there.

The blog area looks good so far (still have to get the menu to dropdown like the other pages) but the problem is that any links to index.main.php that include a ?disp={whatever} seem to re-render the index.main.php page's content within itself. You can see examples by using the Contact page or by testing the last 3 links in the Common Navigation Links widget at the bottom of the right-hand column.

Any ideas how to correct this? Bear in mind that it's very possible that I have simply mucked up either the style.css sheet or any number of the other include files or even index.main.php itself.

Thanks, Jeff

3 Apr 04, 2008 02:47

Way cool tool, ¥åßßå. I definitely stuck a bookmark to that in my "Scripting" bookmarks folder.

I cleaned up all the validation errors (for that specific page) but that didn't solve the problem.

What I found was that the _body_header.inc.php file had already included calls to 'Page Top', 'Header' and 'Menu' and they were being called again in index.main.php after that. At the end it was calling 'Sidebar'. Simply removing these fixed the main problem and the other pages were left working correctly.

Thanks again for the help though!
Jeff


Form is loading...

b2evolution CMS – This forum is powered by b2evolution CMS, a complete engine for your website.