Recent Topics

1 Apr 23, 2008 18:30    

My b2evolution Version: 1.10.x

Just installed the newest release (Nevada). I'm trying to change my admin password from the created default but do not have a submit button anywhere on the page. Also found that the create new user page is the same way. Looks like there is a problem in the code. I can see this line after the Focus on First Field option:

<input name="edited_user_focusonfirst" typ

Anyone else run into this? I'm trying to track down the page where this needs to be fixed. If someone already knows where it is I would certainly appreciate a heads up so I can save a little time.

Thanks.

2 Apr 23, 2008 19:02

I commented out the Focus on First Field line in the inc\users\views\_user.form.php file. Now I can see a setting for allowing smilies but still no submit button. Ugh.

3 Apr 23, 2008 19:22

Shouldn't have edited files to "fix" something that isn't broken!

So ... just to verify ... when you log in as "admin" with the default password you were given upon installation and visit your "Users" tab then click on the name 'admin' you do not see buttons for [Save !] [Reset] [Restore defaults] at the bottom of the page? Actually I better back up: if you are seeing "<input name="edited_user_focusonfirst" typ" on your back office page then you have a bonked up file somewhere, so you should be thinking about how to fix a bonked up file rather than trying to hack your way to success.

1. Get a brand new copy of the package.
2. Unzip it on your computer.
3. Delete stuff from your server that is likely to be the cause.
4. Replace the stuff you just deleted using the brand new copy you just unzipped.

In this case I would look at the entire /skins_adm/ folder and if that doesn't change the symptoms the entire /inc/ folder.

Also a different method of uploading files to your server is a good idea. The thing is if you have a bonked up file on your server you probably have no idea *where* it got bonked up. Could have been your initial download OR the method you uploaded with OR when the server got the file. Replacing from the very first step is the only way to be sure you got it fixed IF this is the actual problem.

Oh and hey welcome to the forums!

4 Apr 23, 2008 19:43

Thanks for the welcome. Used WSFTP Pro to upload the files. This is actually the second fresh install I've done. Did one from home yesterday. Came in to the office today and couldn't remember password. Used password retreaval. Clicked on link in email that I received. Said to set password to something else but no buttons displayed on page (all the fields appear to be there). I've tried this in IE, Opera and Firefox. Same thing in all three browsers. Putty'd into the server and logged in to mysql. Dropped all of the database tables and deleted all of the files. Downloaded a fresh copy of the zip file - unzipped it and followed all of the install instructions. Install went smoothly. Now I just have no Save Reset or Restore buttons at all on the edit or add user pages. Pretty much the same problem with each skin. We're on a T1 here at work so I don't imagine there would've been any problems with the download or upload process. I came to the forum thinking that someone else has probably experienced the same thing. Searched the forum but couldn't find anything. Anyway - I appreciate you taking the time to read my post and respond.

5 Apr 23, 2008 20:19

hmmm...

Something simple has to be the root of all evil here. Because, like, it's not here in the forums because the problem just doesn't exist - except obviously it does for you. Meaning there is a freakout going on somewhere with your installation. I was hoping a replacement of the appropriate files would fix it.

OT slightly: connection speed, to my mind, doesn't ensure success or failure either way. Near as I can tell something can go wrong if your connection is fast or slow.

So can you see the public side of your blog? Does it appear reasonably error free, or can you find code-like stuff showing up where it obviously shouldn't? Like seeing the "<input type blah blah" that you saw at the end of page creation in the ... oh wow I think I know something maybe!

Quite often it seems hosts have a memory limit that stops b2evolution from loading fully. I believe most of the time people see it on plugins stuff, and I believe most of the time it shows up as blank pages, but it is possible that this is affecting your ability to load a full page. All the buttons being at the end of the page yah? Because there is actually more missing from your user profile page than just the buttons. There is another block under the "use smilies" option that showed up when you edited out a line above it.

See where I'm going? It sort of sounds like you are getting a certain amount of page then - done. End of page even though it is NOT the end of the page b2evolution is trying to make. So can you get to your "dashboard" page? Does it end with the credits and b2evolution logo linked back to b2evolution? Heck does your user profile page end with the credits and link-back or are you really getting a page un-naturally terminated?

Anyway you should also search the forums for information about memory limit problems and see if it applies to you. Since I never had the problems I never really memorized the solutions :roll:

6 Apr 23, 2008 20:36

http://www.glassguides.com/images/blogcap.jpg
http://www.glassguides.com/images/blogcap2.jpg

The top image is the edit profile page. The second is the add user page. All kinds of craziness is going on now. I went and tried a fresh install again. This time I included the sample blogs and content. Can't see any of those. Getting a page can't be displayed error. Dashboard won't fully load now and the default page won't even come up (www.glassguides.com/blogs/)

I think you may right about the memory thing. I'm going to have to research that. I've run some pretty robust php pages before with no problem and I run a couple of phpBB forums on other sites (same server). We have VPS with Verio - all the luxuries of having your own server without having to worry about the backups and such.

I even tried restarting apache to see if that would help but nothing. Oh well - I'm not giving up yet. I'm ahead of schedule on this project so I've got time to mess with it. Maybe I'll try an install on one of our other servers.

7 Apr 23, 2008 21:07

"Page just dies" is a new description of a problem so there is no certainty that memory limit will be the solution, but here are some links you might be interested in checking out:

http://forums.b2evolution.net/viewtopic.php?t=15066

http://forums.b2evolution.net/viewtopic.php?t=14908

http://manual.b2evolution.net/System_requirements#PHP_memory_limit

http://forums.b2evolution.net/viewtopic.php?t=14612

As you will notice from the three forum threads linked, your symptoms do not match those that have been fixed with the memory limit increase. Nonetheless in my simple mind I say "it seems like it is dying before it finishes so maybe it is running out of something" and that something might be memory.

Hopefully one of the really smart people will come around to help out because I'm pretty much out of ideas here.

8 Apr 24, 2008 17:55

I changed the memory in the php.ini file from 8M to 16M and now it appears to be working fine. Running a little slow but working. Thanks for all the help and hopefully this will help someone else too.

9 Apr 24, 2008 18:09

Cool! This is now another symptom we can add to the list of things that 8M just isn't good enough for.

Thanks for reporting your success!


Form is loading...

b2evolution CMS – This forum is powered by b2evolution CMS, a complete engine for your website.