Recent Topics

b2evolution turkish language packs, demo and installation..

Started by on May 08, 2008 – Contents updated: May 08, 2008

May 08, 2008 19:55    

Dikkat:
b2evolution Türkçe dil paketi, 3.3 ve 4.x sürümüne güncellenmesi planlanmaktadır.Görüşlerinizi, varsa hata ve eksik yanları buraya bildirin lütfen.

[u]Download : [/u]

[url=http://www.tilqi.com/assets/tr_TR_utf-8.rar]b2evolution 2.4.2 turkish utf-8 language pack[/url]

[url=http://www.tilqi.com/assets/tr_TR.rar]b2evolution 2.4.2 turkish iso-8859-9 language pack[/url] *1(see below)

[u]Demo installations:[/u]

demos are being renewed

[u]Quick notes & Overview:[/u]

Those languages packs are %100 translated including the sample contents and ready for test.

UTF-8 install
There are no known issues about the utf-8 installation.Just make your db collation 'utf_unicode_ci' , use the tr_TR_utf-8 locale to install and everything would turn out well..

Recommendation: You are also advised to open your locales.php and set :

$force_io_charset_if_accepted = 'utf-8'

and

$db_config['connection_charset'] = 'utf8'

ISO-8859-9 Installation
After downloading the tr_TR language pack, create a db with 'latin5_turkish_ci'..

Recommendation: You are also advised to open your locales.php and set

$force_io_charset_if_accepted = 'iso-8859-9'

and

$db_config['connection_charset'] = 'latin5'

*1 For the iso-8859-9 installation to display the turkish special characters, you have to use a modified version of .../conf/_formatting.php where turkish special characters html codes are inserted in order to display properly, which is approved by me, however waiting for the approval of developers..

That formatting.php you need to replace can be downloaded here, please note that , for now, this file is not an approved fix by developers nor moderators:

[url=http://www.tilqi.com/assets/_formatting.php.rar]Modified _formatting.php[/url]

[u]Note:[/u]

Regarding the _formatting.php, i have found out that some of the Turkish special characters were not included..

for your information; i have not removed anything in the default _formatting.php, just added the following special Turkish character entities:

there are 12 special characters in Turkish alphabet and 6 of them were included i just added following lines for the rest not included..

	'Þ' => 'Ş',
	'Ý' => 'İ',
	'ý' => 'ı',
	'ð' => 'ğ',
	'þ' => 'ş',
	'Ð' => 'Ğ'

Sep 28, 2008 07:10

I have changed the function as mentioned.

I have the following set in the locales file:

$evo_charset = 'iso-8859-9';
$force_io_charset_if_accepted = 'iso-8859-9';
$db_config['connection_charset'] = 'latin5';
$default_locale = 'tr-TR';

I have uploaded the tr-TR folder to the right location

I have set global / blog / and user settings to tr-TR

I have changed database fields to use the Turkish latin 5. (especially the post_content ant post_title)

However I get strange behaviour. When I edit the text its fine, when I preview its fine, and when I post it its fine(!!), but when I refresh the page I just get questionmarks (?)

Its strange as soon as I post something it comes up on the page absolutely perfectly, then I hit refresh on the browser and questionmarks again.

The field in the database is being populated perfectly.

What can I do?

--------------------------------------------------------

Been messing around trying to get this to work. Since the database is ok I think its only a display issue and should be handled in the _formatting.php file that i downloaded from the above link. However this does not seem to be kicking in. How can I test it and is it possible that I have turned off that functionality some how?

Sep 28, 2008 17:48

hi and welcome to the forums denizopal..

why dont you simply install the utf-8 ? i can ensure you could make a smooth install within 2minutes with utf-8 using the instructions above..

but if you insist using the non-utf (latin5) version, you should really have a look at the note at the very below about the 'formatting.php'

Sep 28, 2008 17:59

Thanks.

I tried UTF-8 first but I was getting a problem with the spam table. I changed the spam tables (and fields) collation to turkish and that was fine. However the error message showed me that despite the fact that I had set everything to UTF-8 the text was being sent as Latin5. So I thought that would be a more standardised approach across the board.

I have updated the PHP I have even checked that the numbers represent the characters, however despite the text looking fine in the database its not fine once its refreshed on the page.

I'll try again with UTF-8 but if anyone has any other suggestions please let me know.

Also, what should the $evo_charset = setting be in either case?

Sep 28, 2008 18:34

Nopes still no luck

Changed all the settings in the control panel (user blog and global) to UTF8 Turkish

Set the following in the locale file

$force_io_charset_if_accepted = 'utf-8';
$db_config['connection_charset'] = 'utf8';
$default_locale = 'tr-TR-utf-8';

and set the database table and field collations to 'utf_unicode_ci'

Still the same error.

You can see screen shots of the page
1- after I add the post here:
http://www.sinekboku.com/1.JPG

2- after I just click refresh here:
http://www.sinekboku.com/2.JPG

3- The data in the phpmyadmin view here:
http://www.sinekboku.com/3.JPG

Sep 28, 2008 20:54

you can see running instances of b2 in tilqi.com and cssdizayn.com which is the proof of yer doing sth wrong ;) even better; take a look at [url=http://www.tilqi.com/blog1.php/2008/09/02/title]this post[/url]

could you please provide a screenshot of ur tables

like this one : http://i38.tinypic.com/ny9ugy.jpg

finally, if you cant manage to make a smooth install after all, i may be able to help you with the installation presuming it's a newly install if that's ok with you

Nov 14, 2008 02:01

Set the following in the locale file

$evo_charset = 'utf-8';
$force_io_charset_if_accepted = 'utf-8';
$db_config['connection_charset'] = 'utf8';
$default_locale = 'tr-TR-utf-8';

and set the database table and field collations to 'utf_unicode_ci' .

Everything on the database should be 'utf_unicode_ci'.

Use the Modified _formatting.php.

set global / blog / and user settings tr-TR-utf-8.

load the language packs.

i have upgraded from 1.8.7 to 2.4.5.
There were problems in older posts.I updated/corrected all of them one by one.

However every thing is ok in new posts.

Try this to solve character problem.

Nov 14, 2008 15:41

The solution above hs some problems in sending comments. Try below solution:

Set the following in the locale file

$evo_charset = 'iso-8859-9';
$force_io_charset_if_accepted = 'iso-8859-9';
$db_config['connection_charset'] = 'latin5_turkish_ci';
$default_locale = 'tr-TR';

Use the Modified _formatting.php.
set global / blog / and user settings tr-TR.
load the language packs.

and set the database table and field collations to 'utf_unicode_ci' .Everything on the database should be 'utf_unicode_ci'. (Change collations if the settings in the locale file isnt enough. it may work without changing collations. )

i have upgraded from 1.8.7 to 2.4.5.
There were problems in older posts.I updated/corrected all of them one by one.

However every thing is ok in new posts.

Try this to solve character problem. Let me know whether you solved your problem too.

Nov 14, 2008 19:39

thanks for the further information and tips Algorismus..
depending on my experience i may say it's the best way to start with an utf-8 install i currently have an utf-8 instance of b2 running smoothly ever since in every area.As mentioned above, you have to do a few tweaks and watch out for some points if you insist on using the iso charset.

Dec 21, 2009 19:05

Dikkat:
b2evolution Türkçe dil paketi, 3.3 ve gelecek 4.x sürümüne güncellenmesi planlanmaktadır.Görüşlerinizi, varsa hata ve eksik yanları buraya bildirin lütfen.


Form is loading...

Run your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.