Recent Topics

1 May 17, 2008 20:33    

My b2evolution Version: Not Entered

Right, so here we go again. Setup is as follows:
b2evolution 2.4.2
Apache 2.2.8
PHP 5.2.6

What I need is to have the URL's like so:
http://domain.com/2007/12/31/
http://domain.com/cat/subcat/
http://domain.com/2006/12/31/post-title

So essentially just rewrite http://domain.com/index.php/2007/12/31/ to http://domain.com/2007/12/31/ I guess.

What do I need to set as the base-URL and what do I need in the .htaccess for mod_rewrite? None of the examples found here seem to work out of the box. I currently have only FollowSymLinks enabled for the directory in Apache, if that makes any difference.

2 May 17, 2008 22:13

yes, you need to use mod_rewrite

Try to add this inside a .htaccess


RewriteEngine On

# Removed index.php in URLs
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^  index.php

3 May 17, 2008 23:51

Doesn't work as such, because with the blog URL set to "Default blog in index.php" I still have index.php in the URL generated by the blog. With absolute URL set to "http://domain.com/", I get 404 errors. However, the contact-form address works in both cases. So essentially rewrite it leaving the index.php out, as it shoud, but somehow the blog engine doesn't handle the requests correctly.

4 May 18, 2008 09:17

my htaccess ( for that bit ) is slightly different, it looks like this :

# send all others to the core
RewriteCond %{SCRIPT_FILENAME} !-f
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteRule .*      /index.php [L]

All my various blogs are set to "absolute url" ( which removes the index.php ) and it works flawlessly

¥

6 May 20, 2008 11:01

Could you provide a checklist for checking the settings of Apache? It seems there is something wrong with the config of the virtual host I'm using, and I can't find it. mod_rewrite works just fine on other vhosts on the same server.


Form is loading...

Secure CMS – This forum is powered by b2evolution CMS, a complete engine for your website.