Recent Topics

1 May 21, 2008 23:33    

My b2evolution Version: 1.10.x

I'm having this weird problem with my new b2evolution installation. I was going to create a new skin, so I copied the custom directory on the server:

cp -r custom oliver

I tried to find the new skin directory in the Skins Install page, but it wasn't there. I tried to refresh the page. I stopped and restarted apache. No luck, skin isn't there.

So I went and had a look at the File Manager - the directory isn't in there either. (In case you're wondering - yeah, I did 'ls' as well and the directory exists just fine on the server.)

I clicked the file license.txt in File Manager and saw a copy of the GPL. I made a change to license.txt on the server and clicked the file again in File Manager - great, my change is there! Up to this point I had thought that perhaps b2evolution was looking at a different directory or something. So, final test:

touch foo

Yes, foo is there. Reload in the browser - b2evolution doesn't see the foo file any more than the oliver folder. Magic. But not of the good kind.

Any ideas? I really don't have a clue where else to look - seems to be a weird bug/behavior either in PHP or in b2evolution itself. Hints?


2 May 21, 2008 23:40

I selected b2evolution version 2.x in the posting form, but somehow now my post says I'm using 1.1 or so. Not true - my version is 2.4.something

3 May 21, 2008 23:52

Okay - and the answer is: the problem was between the ears, as usual. I was hacking around in /usr/share/.... on my gentoo system instead of the hard-linked version of the files in /var/www/... bah. :-)

Sorry for wasting anybody's time!

4 May 23, 2008 17:28

Sometimes I don't waste enough of it and need a little help, so I for one am grateful ;)

By the way, in 2.* you will want to use your Global settings -> skins subtab to install the new skin so that you can use your Blog settings -> skins subtab to be able to select it. You may already have that part properly under control, but I thought I would add mention of that detail for the next user who can't find a skin they know is installed on their server.

5 May 23, 2008 20:01

Hey Ed,

Yeah, thanks, I actually found that part on some other thread already when I was trying to find why my skin wasn't there :-) I've got everything working fine now.

Form is loading...