Recent Topics

1 Jul 20, 2009 09:56    

There are changes in 3.3.1-dev as I noticed after upgrading today.

For one, all the other languages are back :p (In my previous thread, I suggested if there should be an option to install/activate these languages installed of having them activated already [yes, these are disabled, but still]).

Now I was re-adding my custom languages, two to be exact.

First Custom language: Priority set to 2.
Second Custom Language: Priority set to 3.

Then I disabled "English (US) latin1" because it is killing my site (more about this below).

Then I noticed that all posts suddenly changed to using the "Priority 2" language.

So I changed "English (US) utf8" to Priority 2.

Then all languages - including the disabled ones, started to get shuffled.
I tried saving
I tried refreshing
I tried moving languages up and down
I tried setting the priorities (by editing the language)
It just keeps shuffling the languages.

I looked closer and saw that there were overlapping priorities.

I tried then to click "reset to default" per language starting from the last language.

It worked. My desired language priorities returned to normal:
Priority #1: English (US) latin1
#2: English (US) utf8
#3: Custom A
#4: Custom B


Going back to "Then I disabled "English (US) latin1" because it is killing my site (more about this below)."

IF "English (US) latin1" is enabled in the Regionals tab, the whole system/installation will use that because it was defined as the default locale in /conf/locales.php (If I change the default locale in that file, it works as explained.)

Since it is not a UTF-8 locale and my site is UTF-8, it kills my non-ASCII characters.

Once I disabled "English (US) latin1" that's the only time the system considers or takes into account the Regionals Priority setting.

Now I'm not sure if this is a bug or not, but I was under the impression that the system should read the DB and not /conf/locales.php ^_^

That's all!!

Form is loading...