Recent Topics

1 Aug 09, 2004 14:11    

b2evo v 0.9.0.10

Egal ob ich die Settings eines Blogs ?ndern will oder einen neuen Beitrag schreibe. Wenn Umlaute im Beitrag enthalten sind kommt:

Parser Fehler: Invalid character near [...]

Was ist zu ?ndern?

2 Aug 09, 2004 18:58

wenn du die einstellungen ?ndern willst, dann wird ein fehler wegen "invalid character" gemeldet?

welche locales hast du denn ausgew?hlt? steht das auf deutsch? im reiter "blogs"

hast du ansonsten irgendwas ge?ndert oder ist das eine frische installation ohne irgendwelche anpassungen?

3 Jan 05, 2005 01:02

Ich hab genau das gleiche Problem bei den Posts und bei den Kommentaren. Egal welches OS und welcher Browser!

Ich hab nur den Haken "Deutsch" bei den Locales!

Was hab ich gemacht? Hm, also durch einen Webspace Wechsel, hab ich die Datenbank neu eingespielt, die Backup Daten des Blogs per FTP wieder hingeschoben, per /install/ die Conf Datei mit Datenbank Infos ge?ndert, und dann ging alles wieder. Erst jetzt hab ich bemerkt das keine Umlaute, ?, etc gehen !

4 Jan 05, 2005 17:45

das k?nnte an den einstellungen vom apache liegen. wenn dort die kodierung festeingestellt ist, kann das zu genau diesem problem f?hren.
kann dann aber nur dein provider beheben...

5 Jan 05, 2005 18:13

Naja ich hab noch ein Forum und andere dynamische Inhalte auf dem Webspace und da wird nicht gemeckert. Deswegen denke ich das es an dem Blog liegt (warum auch immer).

Datenbank-Backup und alles neu installieren?

6 Jan 05, 2005 20:42

wie sehen die umlaute denn stattdessen aus? gilt das nur f?r die alten beitr?ge oder auch f?r die neuen?

7 Jan 06, 2005 14:43

evtl. vergessen im eigenen Profil locales auf Deutsch zu stellen?

8 Jan 07, 2005 00:13

wie gesagt, locales ist auf deutsch und ISO-8859-1

Die alten Posts beinhalten Umlaute+?. Kein Problem ... Wenn ich nun eine News oder Kommentar posten m?chte:

Kann Kommentar nicht verarbeiten, bitte korrigiere diese Fehler:
Parser Fehler: Invalid character near hier stehen paar umlaute: ???????? ... und hier ein ?</body>

[Zur?ck zum Editieren des Kommentars]

Wenn ich alte Posts editieren m?chte, und neu abspeichern will (mit Umlauten, die werden ja normal aus DB ausglesen und angezeigt), dann kommt ebenfalls besagter Fehler. Posten mit ue statt ? geht dann ...

9 Jan 09, 2005 04:06

Ändere mal bitte in /b2evocore/_class_htmlchecker.php die Zeile 46 von

$this->parser = xml_parser_create( $this->encoding );

in

$this->parser = xml_parser_create();

, also kein Encoding übergeben.

Wahrscheinlich hilft das nicht, also füge dann in Zeile 100 von /admin/edit_actions.php folgenden Code ein:

$post_title = format_to_output( $post_title, 'htmlbody' );
$content = format_to_output( $content, 'htmlbody' );


ein (nach dem Kommentar "// CHECK and FORMAT content").

Hilft das (für einen neuen Eintrag)?

Wenn ja, dann füge diese beiden Zeilen auch unter die anderen beiden "// CHECK and FORMAT content"-Kommentare ein.

Hoffe es hilft, ich kann es hier leider nicht reproduzieren..

10 Jan 09, 2005 05:37

hm... danke erstmal ! Aber in der 1. Datei waren die ?nderungen die du vorgeschlagen hast, bereits gespeichert (funktion ohne parameter!)

In der 2. Datei hat der eingef?gte Code leider nur das bewirkt, dass zwar Umlaute sich posten lassen, aber der ganze Content mit dem Titel ersetzt wurde, also z.B. als titel "???-news" und als content "hier bin ich", war in der geposteten news der titel und der content = "???-news" :(
Als ich dann diese News ?ndern wollte kam wieder bekannter fehler ....

ich komm wohl um eine neuinstallation nicht rum, oder gibts noch vorschl?ge? w?re sehr dankbar!

11 Jan 09, 2005 06:26

Wenn du die erste ?nderung bei dir nicht drin hast, ist deine Version wohl schon ?lter, oder? nicht .11? Die solltest du sowieso installieren, da ein Sicherheitsloch entdeckt wurde!

Zum Fix: genaues hingucken kann einem eine Menge Arbeit ersparen.. :p

Der Fehler liegt nat?rlich darin, dass ich mich ver-copy'n'pasted habe. Richtig ist:

$post_title = format_to_output( $post_title, 'htmlbody' );
$content = format_to_output( $content, 'htmlbody' );

F?ge diesen Block einfach zu den anderen beiden, erw?hnten Stellen mit hinzu und es sollte klappen (beim Editieren trat der alte Fehler wieder auf, weil du dort ja den Fix nicht eingebaut hast).

12 Jan 09, 2005 14:35

ja, .10

hm ok hab ich gemacht, klappt! nur beim editieren wird der html-code f?r die umlaute angezeigt in der textbox...

13 Jan 09, 2005 20:01

Ok, I've thought this may happen.

So, remove the two-line-fixes you've entered below the three comments and replace instead line 193 of _functions.php, whcih should be

$checker->check( $content );

with this:

$checker->check( format_to_output( $content, 'html' ) );

This way special characters get replaced when validating the HTML, but are not stored into DB.

I hope this will finally fix it.

14 Jan 09, 2005 21:24

also kommando zur?ck? ok .... in b2evo../_func eingef?gt

nun kommt:

:: Neuen Eintrag hinzuf?gen...

Output format [html] not supported.

15 Jan 09, 2005 22:23

Sorry (auch f?rs Englische).

Schreibe bitte 'htmlbody' statt 'html' als parameter..

16 Jan 09, 2005 22:54

Dachtest du, du w?rst im englischen Forum? Oder gabs dort genau das gleiche Problem ? :-)

Egal, denn ich danke dir wirklich SEHR! Es funktioniert nun. Anscheinend wird diese Funktion auch f?r die Kommentare verwendet, d.h. alles mit einem Schlag wieder OK!

17 Jan 10, 2005 16:46

stellt sich nur noch immer die frage, wieso das problem bei dir aufgetreten ist und bei (allen) anderen nicht.

18 Jan 10, 2005 16:59

Stimmt. W?re hilfreich, wenn du hier einmal den Output von phpinfo() posten w?rdest.

Dank you.. ;)

19 Jan 10, 2005 20:02

Ja, allerdings.. diese Frage bleibt. Ich bin innerhalb des Providers umgezogen, daher d?rfte sich eigentlich nichts von der Konf ge?ndert haben ... Dateien + SQL sind ja dieselben wie auf dem "alten" Webspace...

http://pienkus.de/php/phpinfo.php

20 Sep 07, 2005 12:29

Bekomme beim posten neuer Beiträge und beim editieren alter die gleiche Fehlermeldung, wenn Umlaute im Beitrag vorhanden sind:

Kann nicht aktualisieren, bitte berichtige diese Fehler:

* Parser Fehler: mismatched tag: body near </a></a></body>

Ich habe die von blueyed vorgeschlagene Lösung ausprobiert, hilft nix.

Da ich eine identische Installation erst letzte Woche auf einem anderen Server gemacht habe, denke ich, dass es an den ServerEinstellungen liegt. Ich benutze die neuste Version von b2evolution (0.9.0.12).

Die phpinfo gibts [url=http://213.239.218.169/phpinfo.php]hier[/url].

Irgendjemand eine Idee?

21 Sep 12, 2005 18:19

hmmm ... ist noch ein bisschen anders, als ich schrieb. ich habe jetzt sämtliche änderungen rückgängig gemacht, und wollte eigentlich die von blueyed vorgeschlagene lösung nochmal nachvollziehen (weil ich da ja eventuell einen fehler gemacht habe) und bin dabei auf folgende präzisierung des problems gestossen:

steht der umlaut einfach so im fortlaufenden text: kein problem. sobald der umlaut aber in einem tag vorkommt (zb

<a></a>

, bekomme ich die genannte fehlermeldung:

Kann nicht aktualisieren, bitte berichtige diese Fehler:

* Parser Fehler: mismatched tag: body near </a></a></body>

any suggestions?

22 Sep 18, 2005 00:56

Bitte versucht es einmal bei der Demo-Version:

0.9.1:
http://demo.b2evolution.net/v9/blogs/admin/?log=admin&pwd=demopass

"Phoenix":
http://demo.b2evolution.net/HEAD/blogs/admin/?login=admin&pwd=demopass

Und eventuell auch unter den PHP4-Varianten:
http://demo.b2evolution.net/v9.4/blogs/admin/?log=admin&pwd=demopass
http://demo.b2evolution.net/HEAD.4/blogs/admin/?login=admin&pwd=demopass

phpinfo lässt sich über http://demo.b2evolution.net einsehen - ich kann es hiermit jedenfalls nicht nachvollziehen und tippe deswegen auf ein Problem mit einer PHP-Konfigurationsoption.

23 Sep 21, 2005 15:12

Danke, blueyed :D Leider hat das nicht geholfen. Hast du einen Tip, was da an der PHP-Konfiguration nicht passen könnte?
hier nochmal der link zur php-info http://213.239.218.169/phpinfo.php

24 Sep 22, 2005 21:21

Hast du in der Demo nun das gleiche Problem gehabt?

Es könnte zB mit default_charset zusammenhängen. Der ist bei dir nicht gesetzt, bei mir aber auf iso-8859-1.

Bitte schreib einmal, was du genau als Eintrag schreiben möchtest (den kompletten Text) und die komplette Fehlermeldung.

Danke.

25 Sep 22, 2005 22:34

In den Demo-Versionen lief das tadellos (ausser bei "Phoenix", liegt aber daran, dasses da aus irgendeinem anderen Grund wohl keine Kategorien beim Posten neuer Einträge gibt, sodass die Fehlermeldung: Kategorie auswählen! kommt).

default_charset wurde jetzt auf iso-8859-1 geändert - hat leider nicht geholfen.

der Text den ich als Eintrag schreiben möchte ist:

<ul>
<li><a href="http://hjwalter.blogs.com/blog/">Hans-Jürgen Walter</a></li>

  <li><a href="http://edu-blog.de/">Lutz Berger</a></li>

  <li><a href="http://www.bildungsgruppe.de">Marco Ripanti</a></li>

  <li><a href="http://www.smart-sign.com">Thomas Haaf</a></li></ul>

das geht wunderbar, wenn ich das ü bei Jrgen weglasse, mit ü kommt diese Fehlermeldung:

Kann nicht aktualisieren, bitte berichtige diese Fehler:

* Parser Fehler: mismatched tag: li near /a>> <li><a href="htt

Wenn du noch eine Idee hast, was da schief läuft, wäre das superklasse.

Danke sowieso für deine Hilfsbereitschaft bisher!

26 Sep 22, 2005 23:53

Da hab ich leider keine Idee mehr und hab mich auch noch nicht wirklich mit dem Validierungs-Token-Parser beschäftigt.. :/

Wer den Unterschied findet, darf sich ein Eis kaufen ;)
http://demo.b2evolution.net/content.php4/phpinfo
http://213.239.218.169/phpinfo.php

Du könntest die Validierung in /conf/_formatting.php ausschalten. Am besten zB erstmal

$use_balanceTags = 0;


und andere diverse Nichtigkeiten probieren (jeweils immer mit Test natürlich ob es hilft).

$use_html_checker = 0;


sollte es dann auf jeden Fall beheben.

27 Nov 21, 2005 06:37

Ich habe übrigens das genau gleiche Problem...

28 Nov 28, 2005 21:43

Hift das Ausschalten von $use_html_checker (siehe oben)?


Form is loading...

CMS software – This forum is powered by b2evolution CMS, a complete engine for your website.