Recent Topics

1 Apr 29, 2010 14:03    

My b2evolution Version:

[using version 3.3.3]

I've recently moved my blogs from my home computer to iPage, and have not been able to get images to show up in my posts. It appears that the IMG tags are stripped, and what is left is just the code in between.

src="http://www.pantstothewind.com/media/blogs/pttw/image.jpg" alt="" title=""

The posts themselves are intact when I return to edit them...the IMG tags are still there. Images elsewhere in the blog (ie. not inside posts) show up without error.

If anyone has any insight into what I might have done wrong or what kinds of hosting issues might cause this, I would be grateful.

The site is here: www.pantstothewind.com

The code in the posts is like this:

<img src="http://www.pantstothewind.com/media/users/ahusafael/puppy paw prints.jpg" alt="" title="" width="533" height="800" />

2 Apr 29, 2010 17:42

You should uncheck the "Auto links" renderer when you create a post. Alternatively you can search the forum for fixes

3 Apr 30, 2010 01:46

sam2kb wrote:

You should uncheck the "Auto links" renderer when you create a post. Alternatively you can search the forum for fixes

You know, I don't actually have the Autolinks plugin installed at present. I'll continue to search the forums. I've searched here directly and googled the site till I'm blue in the face, and I'm afraid I may just not know what to search for.

Thanks for your reply.

4 Apr 30, 2010 16:30

Strange. Have you contacted iPage and talk with an tech person? Look at the differences between your home server and your iPage host. Perhaps it is a question of PHP version between your home server and iPage; you may need to add to your .htaccess for files with extension .php be treated as php5 files.

Perhaps some files got corrupted on the upload and reloading the files may be the answer. You know the database table holding the post is OK as it contains the html code for the post. However, that data goes through the php scripts before being outputted as html, that is why I suggest reloading the scripts to the server.

If iPage offers b2evolution as a simple install script, use the control panel and let b2evlolution be installed by your host, creating the database as well and then upload the database through phpadmin or whatever iPage offers.

If you were running an older version of b2evo, please be advised that the database structure was changed with version 3+; moving from the old structure to innoDB.

5 Apr 30, 2010 17:50

Can you create a test post with this code?

text above<br /><img src="http://forums.b2evolution.net/templates/b2evo/images/home.gif" /><br />text below

Also try to disable all third-party plugins like Lightbox and Avatars

6 May 05, 2010 02:27

Well, I finally had a chance to get back to this, and I figured it out. The root of the problem was the Thumbnail plugin. It could not resolve the path to its ".evocache" folder.

First: the root path in the plugin settings must be correct. It is not based on any config settings, so this is set manually after migrating.

Second: it still didn't work for me until I deleted the ".evocache" folder and let the plugin recreate it. This was complicated by the fact that my host, iPage, does not display system folders (folder name preceded by a dot) to users through their file manager. You can see files like the ".htaccess" but not folders. I discovered the ".evocache" folder at work using Dreamweaver to connect through FTP.

One last note about iPage: They do have a native install feature for B2evolution, but they install it in one of the above-mentioned hidden system folders. It would seem to be a problem for anyone expecting the view of their files to be the same in the iPage file manager and FTP.


Form is loading...

Secure CMS – This forum is powered by b2evolution CMS, a complete engine for your website.