Recent Topics

1 Jan 14, 2011 19:33    

My b2evolution Version: 4.0.3

ok so I started a backup on my blogs last night. Well when I go to them now i'm still getting the 503 Service Unavailable page. They've been down for over 12 hours and there is only 1 user so I know they're not that big. Any ideas how to fix it?

2 Jan 15, 2011 00:02

any ideas on this would be great.

3 Jan 15, 2011 00:16

What are you using to back them up?

Most just do an sql dump and copy the installation directory via ftp.

If you're using b2evo's builtin backup and you're at 12+ hours, something's wrong. Either the backup process puked... or it finished and forgot to take your installation out of maintenance mode. You need to edit your /conf/_basic_config.php file and change:

$maintenance_mode = 1;


$maintenance_mode = 0;

to take it out of maintenance mode so you can get back in and see what's up.

4 Jan 15, 2011 00:16

I used the back up from the admin panel.

5 Jan 15, 2011 00:24

I realized that after I posted ;)
See the changes in my previous post.

6 Jan 15, 2011 00:27

It's set to 0 but still having the same problem

7 Jan 15, 2011 00:36

What exactly does your 503 page say?
If it says:

503 Service Unavailable
The site is temporarily down for maintenance.

Then b2evo still thinks it's in maintenance mode and you need to make sure you changed the setting in the _basic_config.php file and not the _basic_config.template.php file.

If that's not the exact 503 error you're seeing, then it's something else.

8 Jan 15, 2011 00:39

503 Service Unavailable
System backup is in progress. Please reload this page in a few minutes.

I tried changing the $maintenance_mode = 0;


$maintenance_mode = 1;
and re uploading, then changed it back to 0 which is where it was to start with. Then reuploaded that but so far nothing has changed.

9 Jan 15, 2011 00:42

I was looking the _config.php file and saw this. Not sure if this would have anything to do with it or not

if( file_exists(dirname(__FILE__).'/maintenance.html') )
{ // Stop execution as soon as possible. This is useful while uploading new app files via FTP.
header('HTTP/1.0 503 Service Unavailable');

10 Jan 15, 2011 00:52

If you have a file named maintenance.html in your conf directory, rename it to _maintenance.html.

11 Jan 15, 2011 00:54

I have both of those files in that dir _maintenance.html and maintenance.html should i just delete the maintenance.html and leave the _maintenance.html?

12 Jan 15, 2011 00:57

ok I renamed maintenance.html to _maintenance2.html and the blog loaded up perfectly. should I just go ahead and delete that _maintenance2.html file?

13 Jan 15, 2011 01:01

Yes, you should be able to delete the maintenance.html file... or rename it to anything but maintenance.html if you're nervous about deleting anything.

I'm not sure what happened with the backup, but getting rid of that file should let you back in.

14 Jan 15, 2011 01:03

yeah it's back up and running fine now. Thanks for the help. Now I have to start hunting the forums to see if there is a way to let me use the same logins for the blogs as the forums. that way users don't have to register twice.

15 Jan 15, 2011 04:02

PHP died during the backup process, most likely because of low memory.

This bug is fixed in CVS.

16 Mar 23, 2011 16:07

In the 4.0.4 install, the file to rename in the conf folder of your installation is called imaintenance.html

17 May 27, 2014 10:45

Hello. I am also getting the "I'm getting the 503 Service Unavailable after Backup"
error message. I did not manually start a backup. One may have been running automatically, I'm not sure.

I checked and the /conf/_basic_config.php is set to $maintenance_mode = 0

Also, I do have the _maintenance.html file in the conf dir. and do not have a maintenance.html file.

I am now no longer getting any error message; only a blank screen.

Does anyone know how I can fix this? Any help is greatly appreciated.

....OK, now I'm looking at my _advanced.php and half of it is missing! How can this be?
I renamed it and uploaded a former copy but it is still not working and I am only getting a blank screen. I don't know if the uploaded copy is from this install. Most likely not but I don't see any settings in this file specific to this install.

I am at a loss. My _application.php says that my app. version is: $app_version = '4.1.3';

Alright, for those of you that will have this same problem... here is what I did to fix it.

Most of what I did, didn't fix it and now 2 hours later it works. I copied the lower portion of the _advanced.php from an older backup and pasted it into the non-working copy of the _advanced.php on the server. It didn't work when I simply uploaded another copy. Either there is something I'm missing or possibly a backup was running in the background without me seeing it. I have no clue.

Thanks for reading.

Form is loading...