Recent Topics

1 Feb 23, 2012 00:39    

I upgraded from to 4.1.2 and promptly found I could no longer go past page 1 of the user list. The path to do so is apparently created without the name of the website before admin.php. I've tried writing it in the resultant, inoperative, path, but apparently there's a permission problem doing it that way. This means my sites will quickly become worthless, being unable to handle more than about 20 users. There seems to be at least limited ability to recognize users past that first page logging in, though I think some are not, and I can add ones who show up on page 1. Here's the path I get: http://admin.php/?ctrl=users&results_user_page=2, whereas the path to the first page is:

2 Feb 23, 2012 02:30

Can you post the exact link to the next user page?

3 Feb 23, 2012 16:25

The next page is link (I presume this what is generated to go to it):


The original link is:

I hope both of these come through OK. They were OK in my original message but got condensed both in the shortened version that appeared where I posted and then in the version transferred here.
Thanks for your prompt response.

OH, I see the first one cited got condensed here, again. Here's the middle part shortened: ?blog=1&ctrl=users&results_user_
You can see it all in the aborted transfer if you click the shortened version, anyway, or if you just hover over it.

4 Feb 23, 2012 16:28

First, you need to get rid of a double forward slash in your config file.
Edit your $baseurl in /conf/_basic_config.php

Have you tried different browsers?

5 Feb 23, 2012 16:46

Great! After I dropped the second slash and got out of my blogs, back to my front page, I did get to my page 2 when I got back into Users. The bug seems to be in the upgrade's putting the second slash in, 'cause it must have happened in the upgrade. I've never touched that file. (I believe the problem happened both in Firefox (for sure) and IE (probably).

I see this also fixed the problem that first got my attention, where my last user, my only privileged blogger, was unable to log in. (One above him on that page was able to.) I had to get the privileged one in by creating a group for him the fell onto page 1. I'm telling all this because it has some possibly useful aspects beyond the "//" problem, but that's the one that needs to be solved in the upgrade process.

I'm impressed with the speed of the solution!

6 Feb 23, 2012 16:50

I believe that extra slash was added by some kind of automated installer, they tend to break things. I recommend you to do a manual upgrade next time.

We can of course check for extra slash and warn the admin. I will try to add this in v5.

7 Feb 23, 2012 17:04

On a possibly related note, my add-on site was, I hope, upgraded with the main one, but has the $baseurl right:
$baseurl = '';
Notice that the directory for it got nested in the correct one for some reason--I guess that happened before the upgrade, when I created the add-on.

Yes, I see the add-on is running under the latest version of b2evolution.

Oh, I guess the "//" could have been in the $baseurl of the main site before the upgrade but was just misinterpreted by the new version of b2evolution.

8 Feb 23, 2012 17:09

sam2kb, I see you replied AGAIN even as I was typing a reply. I'll keep in mind about the manual upgrade. (Hope it's not too hard!) Thanks again!!!

9 Feb 23, 2012 17:23

Jeez, I've tried everything I could think of to record positive feedback for sam2kb, and the closest I got to a result was a warning that I would get -500 points if I clicked the "+" button again. Can anybody tell me how to do it?

10 Feb 23, 2012 18:48

You may not have enough points to give out.
I appreciate your trying anyway :)

Form is loading...

Advanced CMS – This forum is powered by b2evolution CMS, a complete engine for your website.