Recent Topics

1 Jan 23, 2005 10:01    

Hey guys,

Well, I know people have gotten this problem before. I myself have... I upgraded to PHP5 when it first came out and this is what happened then to: After the configuration page with the database login info, and I click next, I get the semi-blank page with the topbar and languages to the right, but nothing else.

If I remember right, this problem became two fold after I solved the blank page where MySQL changed their table algorithm or something like that with the newest version. That's not the problem here though I think because I still kept my "old" database with the same version of MySQL.

I can't remember this PHP problem. I'm also running Apache 2.041, but my Apache installation hasn't changed. I know the Config file is not being updated and so it's being stopped there somehow... I know I posted this solution on this board once but it's disappeared because somehow my account got deleted (or perhaps it was when the forums were hacked). Thanks for your help guys. I'm hoping I can figure this out but it's been a good 4 months...

2 Jan 23, 2005 10:24

zend optimizer update, was it?

3 Jan 24, 2005 00:31

Hmm... could be... I'll check it out.

4 Jan 24, 2005 00:37

Trying to figure this out, it seems like it doesn't even connect to the MySQL... At least when I try to force it to spit out an error like can't locate database or wrong password to connect to the DB, it still comes back with a blank screen.

5 Jan 24, 2005 01:32

Got it... This is really stupid, but basically MySQL is not automatically enabled in PHP5. I hate the Windows system to because even though I moved my PHP.ini out of the windows directory (as I hate stuff in there) and moved it the PHP folder, it wouldn't work even though PHP would still load. libmysql.dll had to moved into the windows folder so basically MySQL was not enabled. For anyone having troubles with PHP5, uncomment the php_mysql.dll extension by removing the ; before it. That's also why it works to downgrade to PHP4 because it's already enabled in that.

6 Mar 06, 2005 07:55

I did this and I still can't get it to work...nothing but a blank screen!

I'm using Windows 2003 server, php 5.0.3, and mysql 4.1.

What else could I be missing?

7 Mar 06, 2005 08:15

zambizzi wrote:

What else could I be missing?

Linux. Apache. (sorry, I just had to)

What happens using php 4?

8 Mar 06, 2005 09:30

whoo wrote:

zambizzi wrote:

What else could I be missing?

Linux. Apache. (sorry, I just had to)

What happens using php 4?

You're absolutely right! Actually I'm stuck w/ this box for now but will be migrating to a new Gentoo server very soon.

I have to use php 5 because I'm developing some of my own apps w/ it and would *not* like to revert to 4.x for *anything*.

I've run it on linux/apache w/ php 5 so I FIGURED it would work similarly on Windows...but to no avail. :>

9 Mar 06, 2005 12:43

Or Apache for windows. Never windows server.

10 Mar 06, 2005 18:44

It's a bit more complicated than that...actually. I have several applications running in and can't simply dump IIS at this see, I've been a C# programmer for about 4 years now.

I'm doing some newer applications, which will be open source, in PHP (now that it's properly object-oriented...yeah baby!)

Anyhow, it's solved, I got it working just fine (albeit a little slower than when using Apache.)

I had installed the php 5.0.3 installer for windows which doens't contain *any* of the extensions. I just downloaded the .zip for windows, pulled out the extensions DLLs, placed then in the php directory, and pointed the php.ini file to that location...and life is good.



Form is loading...