Recent Topics

1 Jan 24, 2005 14:59    

I am having trouble upload pictures through b2evo. Here is what I have confirmed:

1) File uploads are turned on by my hosting provider.
2) I have chmodded the appropriate folders in my htdocs folder to 777 (for testings sake)
3) I am logged in as admin and have the proper rights to upload.

Here is what is happening:

b2upload.php executes from the link inside the compose new post window. A separate window pops up and asks for file name and description. I enter the appropriate info in, and I get the following after submit (apologies for the BMP file):

As you can see, I modified b2upload.php to try and chmod the file once it has tried to upload, however, it looks like

</html><?php die();


	if (!strlen($imgalt)) {
		move_uploaded_file($img1, $pathtofile) //Path to your images directory, chmod the dir to 777
		 or die( T_('Couldn\'t upload your file to:').' '.$pathtofile);
	} else {
		rename($img1, $pathtofile)
		or die( T_('Couldn\'t upload your file to:').' '.$pathtofile);


isnt working for some reason. Anyone else run into this?

2 Jan 25, 2005 01:13

resolved... my hosting provided needed to configure the temp area where files are uploaded to. Thanks.

3 Mar 19, 2005 20:22

Search is a goo thing! :D

I'm getting the same issue. from in B2E I upload an image to /?/media/what ever.jpg and the post only shows an image place holder.

It sounds like I have the same permissions in place....So, what did your provider have to configure?

you'll see what I mean at default blog, last post about Terri Schiavo

Thanks for any answer


4 Mar 19, 2005 21:28

You don't have permission to access /media/schaivo.jpg on this server.

go in chmod your media dir to 755, and chmod that image to 644 (double check)

Nearly any decent ftp ap has permission setting built in.

Some hosts use a stricter default setting so that ppl dont automatically open up dirs.. the key thing being that YOU should be able to change them

additionally world-writable dirs (777) are commonly "disallowed", meaning theyre flagged and NOT accessable even though theyre chmod'd as such.

5 Mar 20, 2005 10:28

Man, that was difficult.....(i rode the little bus) HAHAHAHA! That worked!!
I'm using Cpanel it wasn't that straight forward but I got IT WOOHOO.
Those permissions don't leave me open to an exploit, right? :?:

Thanks for the help!

and they say you can't teach an old dog....

6 Mar 20, 2005 11:41

nope, thats exactly what they should be .. wont hurt a thing :)

glad to help!

Form is loading...