Recent Topics

Dotted Comments Box

Started by on Mar 15, 2005 – Contents updated: Mar 15, 2005

Mar 15, 2005 18:26    

Hi I have a blog setup, and when you click on the comments, they are seperated by dotted boxes.

I have setup another blog, on another site, using the same custom skin, but when you click on the comments, they are not seperated by dotted boxes, how do I enable this.

Regards

Chris

Mar 15, 2005 18:38

You "enable" that in the CSS formatting file.

Post a link to both and I could probably point you in the right direction.

If you want to hunt on your own, game can usually be found in the field (the fieldset tag is usually the culprit). ;)

CHeers

Mar 15, 2005 19:13

Hi

Thanks for your reply, I copied the custom.css file from the blog that works with the dotted boxes, and pasted in ito the one that does not work, but it did nothing, the dotted boxes still do not show up.

Any Idea's

Regards

chris

Mar 15, 2005 19:38

Yes.

Post a link to the two pages.

Mar 16, 2005 02:05

Chris,

The Custom.css file for the file that doesn't have the dotted lines calls the other CSS files. The path to "forms.css" and "comments.css" is not valid (you're getting a 404 error on those).

OPTION #1: FIX their paths, so they point to the files right files

OPTION #2: Eliminate their @ calls and INSERT the "forms.css" and "comments.css" CSS directly into the custom.css file.

When I did OPTION 2 for comments, the dotted lines showed.

However, as I mentioned earlier, the fieldset tags still have a default border, which I needed to eliminate to get it to look right.

So, if you choose option#2, just insert the following CSS into the custom.css (for comments) ... you'll still need to find the forms.css and insert that, as well.

div.bComment, /* Entire comment block */
form.bComment /* New comment form */
{ 
	margin: 1ex 2ex;
	padding: 0 1ex;
	border: 1px dotted #999;
}
div.bCommentTitle {
	margin: 1ex 0;
	font-weight: bold;
}
div.bCommentText {
	margin-top: 0;
	margin-bottom: 0;
}
div.bCommentSmallPrint {
	clear: both;
	font-family: Arial, Helvetica, sans-serif;
	font-size: 80%;
	margin: 1ex 0;
}
fieldset {border:none;}

And remove

@import url(../../rsc/comments.css); /* Import default comment styles */

This should get it looking proper. :D [/quote]

Mar 16, 2005 02:35

Hi

It's okay I have sorted it out now,

I copied the RSC folder from one site to the other, and it seems to work now.

Thanks for your help anyway.

Chris

Mar 16, 2005 04:49

That would be Option #1, above!

Glad you got it sorted. :D


Form is loading...

CMS + forums – This forum is powered by b2evolution CMS, a complete engine for your website.