Recent Topics

Russian

Started by on Oct 26, 2003 – Contents updated: Oct 26, 2003

Oct 26, 2003 02:26    

i changed _locales.php as it shown in french version but with Russian settings

	$languages = array(
	'ru' => NT_('Russian'),

and

	'ru_RU' => array(	// Russian, RUSSIA
									'charset' => 'windows-1251',
									'datefmt' => 'd.m.y',
									'timefmt' => 'H:i:s',		
							),

but on previewing of the blog (after i've posted with new settings) it shows as symbols "Ïðîâåðêà Ðóññêîãî
Èíòåðåñíî, áóäåò ëè îí ñåé÷àñ ðàáîòàòü è ïðîñìàòðèâàòüñÿ? " enconing on the page stays Western European (ISO).

When I tried to change all iso-8859-1 in all documets to windows-1251 it was still displaying those symbols.

I was trying to solve this problem for 3 days. I made it work for b2.. I NEED HELP!

Oct 26, 2003 12:31

In your browser, do a view source for one of your pages and find the line that looks like:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

what does it say? 'windows-1251' or 'iso-8859-1' ?

what page are you referring to?
what skin?
what browser are you using?

does 'windows-1251' include standard ASCII in the lower 7 bits?

Oct 31, 2003 07:06

in source preview it says iso-8859-1
i'm using noskin_a
i'm using ie6 (but it doesnt matter, does it)

i wonder where do you change locate charset option?

Oct 31, 2003 13:26

Check the language for blog a in the blog conf screen. Have you set it to russian?

If yes, check line 51 of noskin_a. It should read:

<meta http-equiv="Content-Type" content="text/html; charset=<?php locale_charset() ?>" />

Nov 01, 2003 17:39

yes, i can see russian on the page where you edit and browse new posts.
but i cant see it in preview area.

Nov 01, 2003 17:44

so this

<?php locale_charset() ?>

takes info out of

'ru_RU' => array(   // Russian, RUSSIA 
                           'charset' => 'windows-1251', 
                           'datefmt' => 'd.m.y', 
                           'timefmt' => 'H:i:s',       
                     ), 


this, right?

Nov 01, 2003 17:55

in summary.php it displays all russian stuff. but when I click on a link -> it brings me to noskin_all.php and it doesn't show me normal russian - it shows symbols. I tried to reply to the post, encoding still was ISO, but comment is showing correctly.

Nov 01, 2003 20:16

Once again: Check the language for "blog a" in the blog configuration screen (NOT in the browse/edit/post screens !)


Form is loading...

Content Mangement System – This forum is powered by b2evolution CMS, a complete engine for your website.