Recent Topics

1 Jun 18, 2006 10:31    


Fatal error: Call to undefined function: mb_convert_variables() in location\blogs\inc\_misc\_misc.funcs.php on line 1084

When trying to install latest cvs build.


I enabled php_mbstring.dll in my php.ini, and now i get lots of;

Warning: mb_convert_variables(): Unknown encoding "" in location\blogs\inc\_misc\_misc.funcs.php on line 1084


2 Jun 18, 2006 10:42

Moved to this forum due to subject.

3 Jun 18, 2006 10:46

Which forum was it in originally? and where'd it get moved?

Edit: oh nevermind.

4 Jun 18, 2006 16:25

What does

pre_dump( $evo_charset, $io_charset );

result in in, around line 654, after

$Debuglog->add( 'evo_charset ( '.$evo_charset, 'locale' );
$Debuglog->add( 'io_charset ( '.$io_charset, 'locale' );


5 Jun 20, 2006 15:43

I get the same error and i'm a total noob. So no latest build and no gallery plugin.

*sad panda*

6 Jun 20, 2006 21:21

If I'd had the requested output from above, I'd look at fixing it.

Without it, I'm doing other things first.


7 Jun 21, 2006 05:18

The problem only happens when there is no b2evo database, once b2evo is installed the installer works with no problems.

I inserted the pre_dump function where you wanted but it never ran... well in my page their was no <pre tags at all....

Try what i said above and delete your b2evolution database and it should happen to you as well....

I stuck the pre_dump right after the debuginfo output in install/index.php and heres the result;


So here is the fix that has worked for both me and f3rn.
Configure b2evolution by manually modifing /conf/_basic_config.php, then when that is done try install.php, upgrade from existing database etc.
If you are doing a clean install (new database), do the same as above, but create your database via phpmyadmin, then chose new install in install.php

8 Jul 01, 2006 01:02

I've just abstracted the charset handling, please test it again in a few hours, when anonymous CVS catches up. _locale.funcs.php should be revision 1.9.


10 Sep 17, 2006 05:02

Solved? I mean, is CVS HEAD and v-1-9 installable for you?

11 Sep 17, 2006 05:06

Hrmm this thread is a bit old...

Umm well 1.8.1 is installing fine, cvs i haven't fidled with since 1.8's release.

I will install the cvs head and the 1.9 branch later when i have time, so probz next weekend.

Form is loading...