Recent Topics

1 Jul 09, 2006 03:55    

Interesting one this. I am trying out the latest 1.8 build on my site.

I can post fine.

But if I try and edit a post then save, I am told to "Please enter a valid issue date". And not knowing what the system requires as a valid issue date cannot edit posts.

Is this a case of a genuine problem or user error on my part?



2 Jul 09, 2006 17:41

Have looked at this a bit further.

Creating a post is fine. However if I create a post then put a tick in the "edit date" box I then get the "Please enter a valid issue date message".

When I try to edit a post there is no tick box. I assuming that the date edit is always switched on and then I get "Please enter a valid issue date message".

Either way. I can't edit posts.

3 Jul 11, 2006 03:55

I'm hitting the same problem.

If I check the 'edit' checkbox, I cannot create a post. If I leave the 'edit' un-check, I can create a post but CANNOT edit it. Either way, I cannot edit any posts just like you!

I've never been so lost and I'm stranded! :'( Calling for experts help here... :oops:

4 Jul 11, 2006 08:04

Which browsers are you using?

And are you using the official just released build of 1.8....
You can get it from the main page, or from specifing your cvs branch as v-1-8...

5 Jul 11, 2006 09:07

Yup, I believe so... it's 1.8-beta and the downloaded filename is [b2evolution-1.8-2006-07-06]

I did a clean upgrade from my 1.6 and the problem's already there. I've not even migrated my old hacks.

BTW, I'm using the latest version of IE.

6 Jul 11, 2006 09:10

Can you give a build number of ie, help->about.

I'm using firefox and it is working perfectly fine for me. I will look into it if you can provide the build number.

7 Jul 11, 2006 09:15

Version: 6.0.2900.2180.xpsp2_sp2_gdr.050301-1519

8 Jul 11, 2006 09:19

Working perfectly normal for me....

Can you submit the date you are trying to use, which it is complaining about?

9 Jul 11, 2006 09:20

I don't have a problem with it.
I'm using ie
I can post/edit/change,...

A possibility : the system is expecting a date in the format dd/mm/yyyy and the date you enter is mm/dd/yyyy ??

Look into

I'm not sure it is that, but it can't hurt to try..

10 Jul 11, 2006 10:04

I solved the problem. Though it does seem to be a bug. I've had the problem with the last CVS 1.8 build and the public beta.

I had a date format in my locale as like this:
Saturday June 8th 2006

But it couldn't seem to cope with it. When I changed the date format to:
08/06/06 it worked fine.

11 Jul 11, 2006 10:05

Thks, Akeldama. I've just tried your method on mine and it works too! It's indeed a bug. My locales date format was [ d/m/Y (l) ] in version 1.6 and it works perfect. Apparently, 1.8 couldn't handle such format.

12 Jul 11, 2006 10:06

Must be a problem with the date format next to the blog not being the same as the users locale date format....

13 Jul 11, 2006 22:13

ms6682 you don't have the exact 1.8 release (but a pre-relase which was used for testing). Check the date in the filename.

Yes, 1.8 will not handle long dates in the date edit field.

Please help me understand why you had such dates configured in your locale.

14 Jul 11, 2006 22:38

I know in my case I had long dates configured in my own locale because that's the way it was in my database before I upgraded.

15 Jul 11, 2006 22:41

I guessed it was a legacy format since the 0.9.x version and I can't really recall why the locale was set this way. :oops: Now that I've set it to the standard date format, it's working great.

16 Jul 11, 2006 22:42

Yes, but what for are you or were you using such long dates in your locale?

17 Jul 15, 2006 01:02

There's a good reason to use them. Because depending on taste some people feel they look better. I did assume they would be supported given that an explanation of the various php dating code is given on the page where you can edit the date format.

18 Jul 15, 2006 02:23

I think we should add an "input date format" in addition to the date format to the locales.

19 Jul 15, 2006 04:54

Why not just stick the locale date format (which the user is currently using) right next to the date, just like the (hh:mm:ss) right next to the time.

Solves all problems...

20 Jul 17, 2006 14:14

Hmm so that's the problem after all... I spent a lot of time figuring out if it was from my modification/hack...

I am also using the long date format mainly because it is the standard date format here in our country. Additionally, PHP allows it (and is in the instruction) so some (example for me), I set it up as such to follow our date standard.

1.8-beta do not recognize the long date format as the 0.9.1/.2 series. Could it be brought back? :(


21 Jul 26, 2006 11:53

Has this been resolved yet?

I want my blog date to display as D, F d, Y...... but if I don't set it to d/m/y then I can't edit the dates on posts.

Any solution yet? :?:

22 Jul 26, 2006 17:20

The thing is that you all must input the date the same way. d/m/y or whatever. But if you want your post dates to display in a different way, (that should already be done if you chose your correct locale - providing you are not a rebel), just go into Settings->Locales, or your user profile (maybe) and change it there...

I think this has been fixed in the lastest dev version, if not it probably will be. In the mean time just put up with it ;)

23 Jul 26, 2006 17:56

In the 1.8 summer beta release it isn't fixed.

If you change the local date format it changes it in the editor too - which then means you can't alter the date.

24 Jul 26, 2006 23:12

Darn... oh well, I'm happy with the rest of it, so I suppose I can wait for the fix. ;)

I'd actually really like to see the ability to use the skin to specify how the date format displays... so one user could have multiple blogs with different date formats.

25 Jul 27, 2006 02:30

cassiadawn wrote:

I'd actually really like to see the ability to use the skin to specify how the date format displays... so one user could have multiple blogs with different date formats.

Date formats are relative to the user. Just like the english speak english, the french speak french, the germans speak german, etc. Different cultures/languages write dates/numbers/whatever differently. If i view a site, i want the date to be displayed how i know it, and that is what currently happens (in general). Everything cool now?

26 Aug 01, 2006 20:02

The problem is also present in the Scheduler. I also had a different date format (M j Y if I'm not wrong). The thing is that I could not input a date in any other format.

27 Aug 20, 2006 19:40


I was near to despair! I am from germany and I set my date-format "l, d.F Y" like it is usual and nice for me. For example:
Sonntag, 20.August 2006

Now I changed the date-format to "d.m.Y" and I can edit again.

Thanks again for the tip. I hope that will be fixed in one of the future versions. It worked in the older versions very well, so I think it will be in newer versions.. I hope...

28 Aug 29, 2006 19:51

Bummer. I thought this was fixed in 1.8.1 but I'm still havign the same problem. I'm getting used to short dates, but I do miss the long formats.

29 Aug 30, 2006 11:31

Yep, tried it myself, the date during edit mode is still restricted to



30 Aug 31, 2006 23:19

I had a similar problem.

My regional / locale date setting was a customised one, "jS F Y" I think it was
(ie 31st August 2006).

The input field on the form was too short to allow so many characters and selecting from the calendar just gave me those letters above in the input field. I tried entering a d/m/Y date but that still didn't work, either way it came up with the "Please enter a valid issue date" message.

I really liked having the date format I mentioned above and it would be great if this could come back in a future version.

PS I'm using the 1.8.1 / Milestone version.

Form is loading...