Recent Topics

1 Sep 25, 2006 22:40    

Hmmm...So I would like to import a typepad blog into b2e. Unfortunately the only instructions that I can find ( tell me to place the .TXT file into the /admin folder on your server. Unfortunately there is no /admin folder anymore.

Any ideas?

2 Oct 04, 2006 03:54

I am trying to figure out how to move my Blogger stuff using the MT import tool.
I figure out that the TXT file must reside in (for version 1.8.?) inc/CONTROL/import/

I"m still getting an error telling me the text file does not appear to be a MT export file.
I'm not sure how to fix that.

3 Oct 13, 2006 09:08

I, too, don't have an /admin folder so I moved my .txt file to inc/CONTROL/imports which got me past the first hurdle. I am now getting the following error...

"The MT export file [supyo2.txt] you've chosen does not seem to exist. Please check path/permission"

I've tried serveral permissions for the file and have also created a sym link to an admin folder I made.

The text file is exported from MT 2.63 and my b2evo is 1.8.2

4 Oct 13, 2006 15:01

I had a similar problem and solved the cannot read the file issue. For me, it was a permissions problem. I moved the MT file to the /tmp directory and made the file universally accessible (chmod 777). That solved the cannot read the file problem. (I had to manually edit the import-MT.php file and point it to the new location.) I suppose you could also solve the problem by using chmod on your b2e folder structure, but that is not recommended because of negative security implications.

I also had the "does not appear to be a MT text file error". I had an old version of MT around (2.661) and exported the blog to a text file. The import function worked perfectly. I then tried to import a text file generated by an MT export plugin for Wordpress and had the error. I think that b2e's import script is sensitive to the format of the MT text file and if your file does not meet the MT spec exactly then you will get the error.

5 Oct 13, 2006 19:05

I still haven't gotten the script to work, even with a test import file I downloaded from this forum. I was about to give up with b2evo but tried one last thing. I downloaded the older version, 0.9.2, and was up and running, with all my 7 years worth of MT posts, in less than five minutes. Rock on! Now that all my posts are imported, I could "upgrade" to the latest version, but I don't really see any advantage to that. I guess I'll be kickin' it with 0.9.2 for awhile! ;)

6 Oct 18, 2006 22:53

I was just loading b2evolution and importing from Movable Type for a client today. The import failed, just as you all descri:bed.

Walking through the "import-mt.php", I found that the name of the directory was not being "remembered" when the script tried to work with the name of the import ".TXT" file. I revised a few lines as follows:

		if( !file_exists($exportedfile) )
			dieerror("The MT export file [$exportedfile] you've chosen does not seem to exist. Please check path/permission.");


		if( !file_exists(dirname(__FILE__)."/".$exportedfile) )
			dieerror("The MT export file [$exportedfile] you've chosen does not seem to exist. Please check path/permission.");


	$fp = fopen( $exportedfile, 'rb');
	$buffer = fread($fp, filesize( $exportedfile ));


	$fp = fopen( dirname(__FILE__)."/".$exportedfile, 'rb');
	$buffer = fread($fp, filesize( dirname(__FILE__)."/".$exportedfile ));

After that, it worked, although there was at least one other (non-disabling) error message. I'm sure there's a more "elegant" way to do this, but I'm behind deadline and needed to get this working. :-)

7 Oct 22, 2006 19:52

Can someone please send me (a part of) a MT export file he/she has? I'll look into fixing it for 1.8.3 then.. I've written the import tool initially, but have not tested it since.

8 Oct 22, 2006 20:31

I just sent a short excerpt

Form is loading...