Recent Topics

UNZIP while Upgrade - command error or Bug?

Started by on Jan 29, 2019 – Contents updated: Jan 31, 2019

Jan 29, 2019 16:53    

Hello,

I tried to auto-upgrade from 6.10.5 to 6.10.6. The process stopped because the system does not allow automatic unzip. This is for the first time, because I have used auto-upgrade for years. I asked my hoster, because I presume that this is a problem on her side.
The hosters' support asekd: does the command runs: unzip file.zip -d destination_folder ?

So could you please tell me the command line for unzip while auto-upgrade?

On the other hand I recognized, that the ZIP File this time has Permission 0644 instead of 0775. Whenever I download the pack it is set to 0664. But even if I change to 775 the server quits with "system does not allow automatic unzip"
So did you change something in the auto-upgrade process?

Thanks, Will

Here is a screenshot of the message:

Exact b2evolution version :6.10.5

Jan 29, 2019 23:52

This looks more like your b2evo admin account is not allowed to edit all files, including potentially dangerous one.

Jan 30, 2019 09:19

@fplanque I tried with another admin 10 level account and got the same problem. How can I check and adapt permissions to allow unzip in b2e?


Form is loading...

Bootstrap CMS – This forum is powered by b2evolution CMS, a complete engine for your website.