Recent Topics

1 Jan 16, 2018 18:08    

Hello all,

I am trying to install b2evo on my testing server. I'm using XAMPP with PHP version 7.0.

When I try to install using the auto installer, it gets to here \/ and stalls out. I don't understand what's wrong. I've made doubly sure all database information is correct for the config/_basic_config.php file.

Creating minimum default data...
Creating default blacklist entries... OK.
Creating default antispam IP ranges... OK.
Creating default groups... OK.
Creating groups for user field definitions... OK.
Creating user field definitions... OK.
Creating default currencies... OK.
Creating default countries... OK.
Creating default regions... OK.
Creating default sub-regions...

On top of that, I've tried to install it onto my free hosting site and the installation fails. Still not understanding what's wrong.

Any idea's are welcome...

2 Jan 24, 2018 02:36

I keep getting issues of not installing using auto and have to delete all files except media and ftp new version. Even overwriting doesn't work some/most times.

3 Jan 24, 2018 05:15

I'm having the same problem here.
After a zillion years of "auto update" announcements and "use with care" warnings, I thought: just bite the bullet - they ought to have gotten it right by now.
The update process stalled half way, with better than 755 and other warnings and now my site is down.
Trying to repair it from BU, but MAN! is it annoying that B2Evo still cannot be updated automatically after all these years.
If it were not that I have such a great investment in this platform, I would leave it happily!

4 Jan 24, 2018 06:03

Well, the hosting provider restore of the DB and Site failed. Now I'm trying to recover through a local back-up.
My hopes are slim, at best.
Wish me luck!

5 Jan 24, 2018 13:17

Hi gerardp
I frequently download a copy of the database so the best option then is just to delete all b2evo files and upload the newer version.
It is a pain and puts me off updating but I'm used to it now, except that I only do it at a fiends where there's more than the 0.2Mb upload speed I have. This slow internet speed was the reason I liked the auto update and it did work a few times back a couple years.

I can't work out the problem. I get the 503, remove the [conf/umaintenance.php] then I get a 404 saying the [install/index.php] cannot be found even though I can see it via ftp. Once I waited a few minutes, more like an hour and it did work.

I'm wondering, as has been suggested, that it is something to do with my hoisting setup, but that's beyond any fix as my host haven't any idea what the problem could be.

The strange thing is a new install works every time if I completely unistal the current install, so some sort of cache on the host or in b2evo is stopping access to files or not seeing them ?????

6 Jan 24, 2018 19:12

Hi Amoun:

In the end I solved the problem by deleting all files in my B2evo folder after an FTP upload through Dreamweaver failed too.
So, that is exactly as you suggest in the sense that wiping everything is probably the best way to go.
I then managed to reinstall the files from the latest back-up, through my hosting provider
My database was already restored at the first intent; it appears that the 503 error is thus related with the failed upgrade since I had renamed all the maintenance files (maintenance, umaintenance and imantenance) and was still getting the error.
Now, finally all is working well, but I still have to upgrade.
Which I will put off, for a while ;)

7 Jan 24, 2018 22:27

Ok, guys, auto upgrade works very fine... except when your webhost decides to shut it down in the middle because it's running too long or taking up too many resources, or making too many SQL requests.

Most of the time, it auto fixes itself if you just reload the installer page that didn't finish.

Short of that the 503 message actually tells you what to do (last line).

8 Jan 24, 2018 22:39

After reading the ftp logs, I finally solved my problem. I had to edit the my.ini file on my testing server to increase the innodb_buffer_pool_size to 1024M. Worked like a charm. It was acting like something was timing out, so that's the only thing I could come up with.

9 Jan 29, 2018 23:02

Thanks wetodd, will check the innodb_buffer_pool_size to 1024M. Have tried waiting as fplanque has suggested but maybe this memory issue as I can't see how a reinstall with take less resources etc.

10 Feb 01, 2018 04:37

Hi Francis,

Thanks for chipping in.
Not too many SQL requests. Rather better than 755 rejections and problems with htaccess...


Form is loading...

Community CMS – This forum is powered by b2evolution CMS, a complete engine for your website.