Recent Topics

[3.3.3] Comment from Hotmail.com not allowed?

started by on Mar 25, 2015 – Last touched: May 19, 2017

Mar 25, 2015 11:29    

A friend has contacted me saying her address, something@hotmail.com, is invalid. How can I let her comment? I've checked the anitspam blacklist and hotmail isn't on it (apart from the Russian one).

Mar 26, 2015 03:56

Please try typing a comment with her email in your blog and make a screenshot of the error message ( or at least copy/paste the very very very exact error message ).

Is there a special char in the email address?

Mar 26, 2015 15:32

Her address works fine when I put it in -- it's just that she can't post from her computer. I also had another reader report the same problem last night, from an ntlworld.com address.

Neither of them are au fait with making screenshots but I'll do my best to get any error messages from them.

Mar 26, 2015 16:32

My hotmail friends reports this error message:

Cannot post comment, please correct these errors:Supplied email address is invalid.Supplied website address is invalid: URL not allowed[Back to comment editing]

Apr 02, 2015 23:55

We can't help without knowing which email and which URL generated these error messages.

Especially if you can't reproduce the problem yourself.

Apr 04, 2015 03:34

and what's your blog so we can try it?

Apr 04, 2015 11:07

@loobyloo turning the debug mode on will give you the information about which blacklisted word is blocking the comment.

I sent a couple of test comments using your data and didn't get the error. While we are not able to consistently reproduce the error, there is no more option than try to coordinate with the user to enable debugging and get the full error message.

If that's not possible, another option is making a temporal change to the antispam check script in order to show the full error message instead of only the "URL not allowed" message. In order to do that, and as you are using v3.3.3, you can go to the file inc/_core/_url.funcs.php and locate this section around line 179:

PHP

return $verbose
                sprintfT_('URL "%s" not allowed: blacklisted word "%s".'), htmlspecialchars($url), $block )
                : T_('URL not allowed');

and replace it with:

PHP

return $verbose
                sprintfT_('URL "%s" not allowed: blacklisted word "%s".'), htmlspecialchars($url), $block )
                : sprintfT_('URL "%s" not allowed: blacklisted word "%s".'), htmlspecialchars($url), $block );

Just remember to rollback this change after getting the info.

Regards!

Apr 04, 2015 11:19

Thank you! I'll let you know how we get on.


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.