Recent Topics

APis Error after - upgraded from 6.8.2 to 6.8.6

Started by on Feb 11, 2017 – Contents updated: Mar 20, 2017

Feb 11, 2017 18:35    

After a upgrade I get this errors in my systems view (backoffice)

I have my own Linux server
openSUSE Leap 42.2 (kernel 4.4)
Apache 2.4
php7.07
MariaDb 10.0.28

Any ideas of what I should do. The site itself seem to work o.k. though (its a new install with the provided demo content only at this stage)

=================================================
APIs

REST API
Failed
https://www.mydomain.com/api/v6/collections
This API doesn't work properly on this server. Probably you should update a file .htaccess to the latest version or check permissions to use this file. Error: file_get_contents(https://www.mydomain.com/api/v6/collections): failed to open stream: operation failed

XML-RPC
Failed
https://www.mydomain.com/xmlrpc.php
This API doesn't work properly on this server. Error: Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)

AJAX anon_async.php
Failed
https://www.mydomain.com/htsrv/anon_async.php?action=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/anon_async.php?action=test_api): failed to open stream: operation failed

AJAX async.php
Failed
https://www.mydomain.com/htsrv/async.php?action=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/async.php?action=test_api): failed to open stream: operation failed

AJAX action.php
Failed
https://www.mydomain.com/htsrv/action.php?mname=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/action.php?mname=test_api): failed to open stream: operation failed

AJAX call_plugin.php
Failed
https://www.mydomain.com/htsrv/call_plugin.php?plugin_ID=-1&method=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/call_plugin.php?plugin_ID=-1&method=test_api): failed to open stream: operation failed

b2evolution 6.8.6-stable – GPL License – ©2003-2016 by François Planque & others.

Feb 16, 2017 14:22

I used the sample.htaccess and it still has those same errors.
Even after a new install!

Anyone from the developers?

Feb 16, 2017 14:34

Since you are running your own server, what does your php.ini file say?

Check for allow_url_fopen

Feb 16, 2017 14:51

Hi @achillis

php7.ini values are:
allow_url_fopen = On
allow_url_include = off

The first 6.8 release that had installed was 6.8.2 and did not have these errors!

Feb 16, 2017 15:02

@zebulon wrote earlier:

I used the sample.htaccess and it still has those same errors.
Even after a new install!


What are the permissions on b2evolution/htsrv/ ?

Who owns the b2evolution/ directory tree?

Does the web server have eXecute/Read permissions to the directory?

Is the PHP7 from the SuSE repositories? If so, can you try using PHP5 ?

@zebulon wrote earlier:

Anyone from the developers?

;-D

Feb 16, 2017 15:18

Try enabling debugging. In conf/application.php set debug = "2" for both debug and post output.

Feb 16, 2017 17:41

Try b2evo 6.8.7. There have been fixes on the API check part.

Feb 18, 2017 22:49

Hi all

Thanks for the feedback

I have 6.8.7 installed now. Complete new install.
Now I have this errors on top of the ones mentioned:

Notice: Undefined variable: info in /srv/www/b2evolution/inc/tools/system.ctrl.php on line 716
Notice: Undefined variable: info in /srv/www/b2evolution/inc/tools/system.ctrl.php on line 716

Also from this error:
APIs

REST API
Failed
https://www.mydomain.com/api/v6/collections
This API doesn't work properly on this server. Probably you should update a file .htaccess to the latest version or check permissions to use this file. Error: file_get_contents(https://www.mydomain.com/api/v6/collections): failed to open stream: operation failed

I do not have such a directory .../api/..

Feb 19, 2017 01:00

I do not have such a directory .../api/..

This is why you should update your .htaccess file as suggested by the error message. You are missing an important Rewrite rule.

compare your .htaccess with sample.htaccess

Feb 19, 2017 03:53

@fplanque

My .htaccess is a copy of the sample.htaccess. - No change whatsoever...
So, what do I need to change?

Feb 19, 2017 18:54

Please copy the content of your .htaccess file and paste it here

Feb 20, 2017 10:06

Hi @achillis

This is the .htaccess. It is just copied from the sample.htaccess provided from v6.8.7 zip file - no editing:

# Apache configuration for b2evolution's base folder
# Lines starting with # are comments.
# Updated 2016-01-25

# PHP / SECURITY:
<IfModule mod_php5.c>
	# On some overly "secured" systems, the following may need to be added in each folder:
	# AddHandler application/x-httpd-php5 .php

	# The following will try to configure PHP in the way b2evolution would like it to be:
	# However, these falgs will only work if the server configuration allows them...

	# Increase memory limit
	php_value memory_limit 384M

	# Security settings
	php_flag register_globals Off
	php_flag allow_url_include Off
	php_flag magic_quotes_gpc Off

	# For uploading
	php_value upload_max_filesize 32M
	php_value post_max_size 40M

	# You may increase the following if PHP is not able to increase it by itself when needed
	# Otherwiwse it's better to keep the number low enough for general use
	php_value max_execution_time 30
	
	# You may want to turn the following to Off on production servers
	# Please do this only if you know what you're doing and will be able to retrieve potential errors from your error log
	php_flag display_errors On
	# The following is the same as 'E_ALL & ~ E_STRICT' (except those constants may not be available here)
	php_value error_reporting 30719

	# To avoid warning about the automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version
	php_value always_populate_raw_post_data -1
</IfModule>

# DISABLE LISTING FILES ON SERVER:
# Don't show directory contents (not desirable, especially for media folders)
Options -Indexes
# Note: if you have access to the command line of your server, it would probably
# be even better to type this:  a2dismod autoindex
# (This disables the directory listing module completely)

# DEFAULT DOCUMENT TO DISPLAY:
# In case no specific file is requested, we want to fall back to index.php
# In case some subdirectories are accessed, we want to display index.html
<IfModule mod_dir.c>
	DirectoryIndex index.php index.html
</IfModule>

# CLEAN URLS:
# The following will ensure you can pass extra params after the filename on the URL
AcceptPathInfo On

# CATCH EVERYTHING INTO B2EVO: (even if no php file appears in the URL)
# The following will allow you to have a blog running right off the site root,
# using index.php as a stub but not showing it in the URLs.
# This will add support for URLs like:  http://example.com/2006/08/29/post-title
<IfModule mod_rewrite.c>
	RewriteEngine On

	# This line may be needed or not.
	# enabling this would prevent running in a subdir like /blog/index.php
	# RewriteBase /

	# Redirect to REST API controller:
	RewriteRule ^api/v(\d+)/(.+)$ htsrv/rest.php?api_version=$1&api_request=$2 [QSA,L]

	# Redirect any .htm .html or no-extension-file that's not an existing file or directory to index.php:
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteRule ^[^.]+(\.(html|htm))?$ index.php [L]
</IfModule>

And this is my vhost from the apache2 config:

<VirtualHost *:443>
 DocumentRoot /srv/www/b2evolution
 ServerName www.mydomain.com
 ServerAdmin postmaster@mydomain.com
 <Directory /srv/www/b2evolution>
  AllowOverride all
  Options +FollowSymLinks -Indexes
  AcceptPathInfo On
  Require all granted
  DirectoryIndex index.php index.html
 </Directory>
 ScriptAlias /cgi-bin/ /srv/www/cgi-bin
 <Directory /srv/www/cgi-bin>
    # AllowOverride none
Options +ExecCGI -Includes
  Require all granted
 </Directory>
 <IfDefine SSL>
  SSLCertificateFile /etc/apache2/ssl.crt/mycrt.pem
  SSLCertificateKeyFile /etc/apache2/ssl.key/mykey.pem
  SSLEngine on
 </IfDefine>
</VirtualHost>

Kind regards,

Feb 21, 2017 08:58

Okay, there are several things that you need to do as a process of elimination to attempt to resolve the issue.

To make sure we have good feedback, clear your browser cache after each step.

1) make sure your server is not making use of an aggressive caching integration. If this is the case it may rely on cached content, and not the new installed files.

One way you can check this is by removing the b2e install folder and then typing in: localhost/install/index.php if it still loads, then there is a caching issue.

Then make a copy of .htacccess and name as .htaccess.txt and then open .htaccess on your server and remove ALL content, and replace it with:



# This allows you to redirect your entire website to any other domain
Redirect 301 / http://b2evolution.net/
Redirect 302 / http://b2evolution.net/

Clear your browser cache and reload, if the site is not redirecting to b2evolution then your server is either a) unable to execute .htaccess or; b) has another .htaccess active in the cache c) the Apache serve crashed on executing .htaccess

Did it redirect? Yes: replace .htaccess with original content.

then create a php file test.php in your root folder (where b2evolution is installed) and add:


<?

phpinfo();

echo ini_get('allow_url_fopen') ? 'allow_url_fopen: Enabled<br/>' : 'allow_url_fopen: Disabled<br/>';

echo (( extension_loaded('curl') ) ? 'curl: loaded':'curl: not loaded').'<br/>';

?>

save file and load it in the browser http://localhost/test.php

See what the results say. Post it here.

Still not working?

2) make sure error logging is enabled in your php.ini file and then check your error log file which should be found in either/all
a) site root
b) siteroot/install/

Post it here

Still not resolved?

3) try new install, start all over with a clean database.

open conf/_basic_config.php

At around line 85, set

$allow_evodb_reset = 0;

change to

$allow_evodb_reset = 1;

first try install now, if problem still persist, start install over and try with following:
at around line 104, uncomment

// $htaccess = 'force';
to

$htaccess = 'force'; (not recommended on production server)

Delete old tables, start new installation and on install, post screenshot of the .htaccess installation (see image)

Feb 21, 2017 14:10

Hi @achillis

First off all - THANK you for your time in assisting me to solve this problem.

I will go through your steps above - but let me first let you know this:

  • have created a new directory for a test b2evolution install + a new database/user etc.
  • Installation worked and this time I only have 1 error left - this one:

====================================================
APIs
REST API
OK
https://www.mydomain.com/api/v6/collections
XML-RPC
Failed
https://www.mydomain.com/xmlrpc.php
This API doesn't work properly on this server. Error: Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)

AJAX anon_async.php
OK
https://www.mydomain.com/htsrv/anon_async.php?action=test_api

AJAX async.php
OK
https://www.mydomain.com/htsrv/async.php?action=test_api

AJAX action.php
OK
https://www.mydomain.com/htsrv/action.php?mname=test_api

AJAX call_plugin.php
OK
https://www.mydomain.com/htsrv/call_plugin.php?plugin_ID=-1&method=test_api

The only change that I did was in the .htaccess to change 'mod_php5.c' with 'mod_php7.c'
But this change did not solve anything in the original installed location.

On the new test install and on the previous install I both tested the redirect with your Redirect code in the .htaccess and on both locations it worked fine.

Also there wasn't a cache issue. After removing the install folder the install folder index.php would not show (error 404)

.....

Feb 21, 2017 23:33

@achillis
Following your instructions under 3) - a new install:

=======================================================
Installing b2evolution...
Checking files...

Preparing to install /.htaccess in the base folder... (Force=yes)
.htaccess installation successful!

=======================================================

I still get this error:

XML-RPC
Failed
https://www.mydomain.com/xmlrpc.php
This API doesn't work properly on this server. Error: Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)

Feb 22, 2017 08:18

It is possible that your xmlrpc extension may not be loaded/installed.

put <?php phpinfo() ?> in test.php and execute. Post screenshot/results here.

Check your php.ini file.

Or put following in test.php and execute.

foreach( get_loaded_extensions() as $key=>$val ) echo $key.': '.$val.'<br/>';

Feb 22, 2017 10:19

O.k.
I had to install the php7-xmlrpc extension however I still get this same error:

I still get this error:

XML-RPC
Failed
https://www.mydomain.com/xmlrpc.php
This API doesn't work properly on this server. Error: Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)

But the xmlrpc extension is loaded. Here is the result of the test.php:

0: Core
1: date
2: libxml
3: pcre
4: filter
5: hash
6: Reflection
7: SPL
8: session
9: SimpleXML
10: standard
11: xml
12: mysqlnd
13: apache2handler
14: bcmath
15: bz2
16: calendar
17: ctype
18: curl
19: dba
20: dom
21: mbstring
22: fileinfo
23: ftp
24: gd
25: gettext
26: iconv
27: imap
28: intl
29: json
30: ldap
31: exif
32: mcrypt
33: mysqli
34: odbc
35: openssl
36: pcntl
37: PDO
38: pdo_mysql
39: PDO_ODBC
40: pdo_pgsql
41: pdo_sqlite
42: pgsql
43: zlib
44: posix
45: pspell
46: sockets
47: sqlite3
48: tidy
49: tokenizer
50: xmlreader
51: xmlrpc
52: xmlwriter
53: zip
54: Phar
55: Zend OPcache

Feb 22, 2017 13:03

I know it's obvious, but I think it's essential to cover the most basics first, please check and confirm that the file/s exist.

Check for:

1) site_root/xmlrpc.php
2) site_root/xmlsrv/xmlrpc.php

Feb 22, 2017 13:21

Did you restart the server after you installed the extension?

Feb 22, 2017 13:30

@achillis wrote earlier:

Did you restart the server after you installed the extension?

Yes I did. Restarted apache. And after that it did not fix the problem I also rebooted the server.

It is not that I want to use the API (or that I would know what to do with it). I want to use b2evolution for some publishing and to that extend it seems to work o.k.

But it would be nice to know that everything is working as supposed!
I also read earlier a reply from François, a recomendation for a new install. He said go for php7. I don't know anymore where to find that.

My server is in production for other purposes already that use php, so I can't just switch back to php5.

Feb 22, 2017 13:58

No need to downgrade to php7.

I did not see the soap extension loaded in your server either.

Feb 22, 2017 14:50

I now have all php7 extensions installed that were available to my linux distribution - still the same error.

0: Core
1: date
2: libxml
3: pcre
4: filter
5: hash
6: Reflection
7: SPL
8: session
9: SimpleXML
10: standard
11: xml
12: mysqlnd
13: apache2handler
14: bcmath
15: bz2
16: calendar
17: ctype
18: curl
19: dba
20: dom
21: enchant
22: mbstring
23: fileinfo
24: ftp
25: gd
26: gettext
27: gmp
28: iconv
29: imap
30: interbase
31: intl
32: json
33: ldap
34: exif
35: mcrypt
36: mysqli
37: odbc
38: openssl
39: pcntl
40: PDO
41: PDO_Firebird
42: pdo_mysql
43: PDO_ODBC
44: pdo_pgsql
45: pdo_sqlite
46: pgsql
47: zlib
48: posix
49: pspell
50: readline
51: shmop
52: snmp
53: soap
54: sockets
55: sqlite3
56: sysvmsg
57: sysvsem
58: sysvshm
59: tidy
60: tokenizer
61: wddx
62: xmlreader
63: xmlrpc
64: xmlwriter
65: xsl
66: zip
67: Phar
68: Zend OPcache

Feb 22, 2017 15:05

This is what I see when I use the


a2enmod -l

command (enabled modules for apache2):


authz_host actions alias authz_groupfile auth_basic authn_file authz_user cgi dir include log_config mime negotiation setenvif status userdir asis cache deflate file_cache headers imagemap rewrite ssl vhost_alias perl python json reqtimeout version php7 authn_core authz_core socache_shmcb xmlrpc soap xml

Feb 23, 2017 09:12

Since we already considered / reviewed things like .htaccess and php.ini, and taking into account that you loaded a "default" installation, where redirect settings should be on default behavior, the only remaining areas to consider would be server configuration and any graphical interface used to manage the server.

XML-RPC is considered (and can be) a security risk. The topic can be rather complex, but the point is that some servers has a security feature that redirects calls to the xml-rpc, regardless it being enabled or not.

The way forward would be to establish if your server has such an interface and security protocol enabled which overrides and redirects all xml-rpc calls.

Some of the most common ways xml-rpc is "disabled" is through the .htaccess settings. So revisiting the .htaccess file might still be worth looking into. I know you changed <IfModule mod_php5.c> to <IfModule mod_php7.c> but it might be worth leaving the original <IfModule mod_php5.c> section before the <IfModule mod_php7.c> section. I know it is a shot in the dark there, but my objective is to keep the .htaccess file as close to the original as possible. You can also try adding the following to .htaccess:

<Files xmlrpc.php>
order allow,deny
allow from all
</Files>

You should also look into
mod_security,
/etc/apache2/conf.d/block.conf

Feb 23, 2017 14:16

@achillis

Thanks for that info - much appreciated.

I had a look if there is anything in my system logs concerning xml-rpc, but there is no reference there.
openSUSE uses by default AppArmor (something similar to SELinux) - so I tested with AppArmor disabled, but still the same error.

I also do not use mod_security.

Do I miss anything important in functionality for normal use of b2evolution (no fancy things integrated etc..) if I can't solve this?

Feb 23, 2017 18:53

As a quick reminder I can add that whenever you make changes to your server settings you should flush/clear any caches and restart the server. Also clear your browser cache before you test again.

Feb 26, 2017 11:16

Yes I understand

Did another test blog the same way than before.
Now I do get the same problem as before:

Notice: Undefined variable: info in /srv/www/b2evolution/inc/tools/system.ctrl.php on line 716
Notice: Undefined variable: info in /srv/www/b2evolution/inc/tools/system.ctrl.php on line 716

REST API
Failed
https://www.mydomain.com/api/v6/collections
This API doesn't work properly on this server. Probably you should update a file .htaccess to the latest version or check permissions to use this file. Error: file_get_contents(https://www.mydomain.com/api/v6/collections): failed to open stream: operation failed
XML-RPC
Failed
https://www.mydomain.com/xmlrpc.php
This API doesn't work properly on this server. Error: Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)

AJAX anon_async.php
Failed
https://www.mydomain.com/htsrv/anon_async.php?action=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/anon_async.php?action=test_api): failed to open stream: operation failed

AJAX async.php
Failed
https://www.mydomain.com/htsrv/async.php?action=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/async.php?action=test_api): failed to open stream: operation failed

AJAX action.php
Failed
https://www.mydomain.com/htsrv/action.php?mname=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/action.php?mname=test_api): failed to open stream: operation failed

AJAX call_plugin.php
Failed
https://www.mydomain.com/htsrv/call_plugin.php?plugin_ID=-1&method=test_api
This API doesn't work properly on this server. Error: file_get_contents(https://www.mydomain.com/htsrv/call_plugin.php?plugin_ID=-1&method=test_api): failed to open stream: operation failed

b2evolution 6.8.6-stable – GPL License – ©2003-2016 by François Planque & others.

Though everything is the same with .htaccess, apache config, permissions, the way I installed it etc..

The other test blog just gives this error:

XML-RPC
Failed
https://www.mydomain.com/xmlrpc.php
This API doesn't work properly on this server. Error: Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)

I can't really believe this is caused by the system.

Feb 26, 2017 16:30

Where is your php.ini file located? Look at the location of the loaded php.ini in both blogs.

Use:

<?

phpinfo();

?>

Feb 28, 2017 00:50

@achillis

The location is /etc/php7/apache2/php.ini

This is the location for all 3 b2evolution (test) sites (all with the above errors, though the types of errros differ for each, see above).

There is no difference for each b2evo installation in the apache2 config.

So I am the only one with these errors, no one else?

Mar 02, 2017 21:34

@zebulon first than all, please make all your tests using version 6.8.7 and https, just to make sure that we are in the same page. You shouldn't get more file_get_contents errors due to that method was replaced.

In the second place, are you using a self-signed certificate (or any other that produces a message like the one in the screenshot below in your browser)?

Versions lower than 6.8.7 may fail with the error you're reporting here, and version 6.8.7 may also fail, but with a different error.

Mar 03, 2017 01:11

@mgsolipa

Hello

I do use v6.8.7
I use certificates from Commodo and Lets Encrypt, not self signed certificates. They are valid in the brouwser.

Mar 03, 2017 07:42

All right @zebulon, so there is no way to keep getting the file_get_contents error in version 6.8.7. Can you confirm?

Also, can you share the URL of the site where the errors are displayed? (maybe by private message, if you don't want to do it publicly).

Mar 03, 2017 11:53

@mgsolipa wrote earlier:

All right @zebulon, so there is no way to keep getting the file_get_contents error in version 6.8.7. Can you confirm?

Also, can you share the URL of the site where the errors are displayed? (maybe by private message, if you don't want to do it publicly).


Hi @mgsolipa

I don't know of any file_get_contents error.

What I see is in on the Backoffice System/Status tab:

One blog on a domain with more errors than the second. All new test new install allways have the lots of errors.
I can test / use with 3 different domain names (all have valid certificates - not self signed).

Mar 05, 2017 22:31

@zebulon let's check each issue separately.

Regarding the REST API error (your first screenshot here: http://forums.b2evolution.net/apis-error-after-upgraded-from-6-8-2#c108666).

In this comment: http://forums.b2evolution.net/apis-error-after-upgraded-from-6-8-2#c108599 you still reported a file_get_contents error (check your own copied/pasted text), as in your original post, back in February, which is related to versions lower than 6.8.7. That's what I meant in my previous comments.

Now, note on your latests screenshots that the error messages are different, and they mention an SSL certificate problem. So, please test adding this code: curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false); to file ìnc/_core/_url.funcs.php`, around line 315.

The section should looks like this:

		$ch = curl_init();
		curl_setopt( $ch, CURLOPT_URL, $url );
		curl_setopt( $ch, CURLOPT_RETURNTRANSFER, true );
		curl_setopt( $ch, CURLOPT_CONNECTTIMEOUT, $timeout );
		curl_setopt( $ch, CURLOPT_TIMEOUT, $timeout );
		curl_setopt( $ch, CURLOPT_SSL_VERIFYPEER, false);

After adding that code, all API checks should turn into OK. This indicates some kind of problem with the certificate installed in your site, even if it's not self-signed. If you share a link to the site where the checks fail, we could get more info from your certificate.

Regarding the XML-RPC errors. Also, a link could help us to find more information. However, is it possible that you somehow redirected xmlrpc requests on your server by default? Try to go directly to https://www.example.com/xmlrpc.php and see where you end up redirected.

Mar 06, 2017 11:14

Hi @mgsolipa

@mgsolipa wrote earlier:

@zebulon let's check each issue separately.

Regarding the REST API error (your first screenshot here: http://forums.b2evolution.net/apis-error-after-upgraded-from-6-8-2#c108666).

No - I don't have this error anymore after switching to 6.8.7 (sorry - did not see that at first)

@mgsolipa wrote earlier:

Now, note on your latests screenshots that the error messages are different, and they mention an SSL certificate problem. So, please test adding this code: curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false); to file ìnc/_core/_url.funcs.php`, around line 315.

The section should looks like this:

    $ch = curl_init();
    curl_setopt( $ch, CURLOPT_URL, $url );
    curl_setopt( $ch, CURLOPT_RETURNTRANSFER, true );
    curl_setopt( $ch, CURLOPT_CONNECTTIMEOUT, $timeout );
    curl_setopt( $ch, CURLOPT_TIMEOUT, $timeout );
    curl_setopt( $ch, CURLOPT_SSL_VERIFYPEER, false);

After adding that code, all API checks should turn into OK. This indicates some kind of problem with the certificate installed in your site, even if it's not self-signed. If you share a link to the site where the checks fail, we could get more info from your certificate.

I will do the test.
I will send you a private message with the url to both test installations (same server). I use 2 different certificates, one is from Commodo and the other from Lets Encrypt.

@mgsolipa wrote earlier:

Regarding the XML-RPC errors. Also, a link could help us to find more information. However, is it possible that you somehow redirected xmlrpc requests on your server by default? Try to go directly to https://www.example.com/xmlrpc.php and see where you end up redirected.

In both case I get this line XML-RPC server accepts POST requests only.
I'm pretty sure I did not set up any other xmlrpc settings. And by default openSUSE does not do so either.

Mar 06, 2017 11:56

Hello @mgsolipa

After doing these changes:

$ch = curl_init();
		curl_setopt( $ch, CURLOPT_URL, $url );
		curl_setopt( $ch, CURLOPT_RETURNTRANSFER, true );
		curl_setopt( $ch, CURLOPT_CONNECTTIMEOUT, $timeout );
		curl_setopt( $ch, CURLOPT_TIMEOUT, $timeout );
		curl_setopt( $ch, CURLOPT_SSL_VERIFYPEER, false);

I get in both installations this error:


XML-RPC
Failed 
https://www.mydomain.com/xmlrpc.php
This API doesn't work properly on this server. Error: Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)

Mar 06, 2017 18:48

@zebulon all right, we finally found the issue causing the XML-RPC error. It's now reported to the dev team and will be fixed as soon as possible.

Regarding the "SSL certificate problem" errors, I'm still unable to reproduce. So, I'll do a bit more research before to suggest you a blind shot.

Mar 06, 2017 19:30

@mgsolipa wrote earlier:

@zebulon all right, we finally found the issue causing the XML-RPC error. It's now reported to the dev team and will be fixed as soon as possible.

Regarding the &quot;SSL certificate problem&quot; errors, I'm still unable to reproduce. So, I'll do a bit more research before to suggest you a blind shot.

Hi @mgsolipa
Thank you - sounds promising.

Mar 14, 2017 00:32

HI @mgsolipa
this is a new screenshot of the domain that still uses the old ssl certificate from commodo. The other 2 use a newer ssl from another vendor.

Screenshot below from the domain that I last send you a private message:

This post has 1 feedback awaiting moderation...


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.