Recent Topics

Setting up login for a new Blog

Started by on Aug 18, 2018 – Contents updated: Aug 25, 2018

Aug 18, 2018 09:50    

Hi,
I'm just setting up a blog prior to spending 3 months in France on Long Service Leave (something peculiar to Aussies.

A couple of questions:

  • Can I have users log in with out setting the "Site level skin"? At the moment I only want 1 blog and this seems to be an unnecessary element on the page
  • How do I force the blog to https? My site has https, but every time I put https://mydomain.com/blog in, the URL reverts to http://...

Thanks.

Brian
PS I did search for this but couldn't find any thing. Perhaps I didn't search thoroughly enough. If this is documented somewhere please point me in the direction.

Aug 19, 2018 22:04

1) Yes, just put the menu link/button widget somewhere on your skin and configure it as login button

2) check the URL settings of your collection

Aug 20, 2018 14:38

Thanks,
Just following up the SSL question. I can see an option that either forces SSL to "Always direct to URL above" or allows both http & https.
In the "URL above" section I currently have "Default collection in index.php" selected. This seems to refer to just http: So the first option seems to send https to http. So this doesn't achieve what I wanted -> to force http to https (rather the opposite).

Do I need to choose the "Absolute URL:"option and then fill it in with "https://www.mydomain.net/blog/index.php"

Thanks
Brian

Aug 25, 2018 14:07

Yes you could use the absolute URL.

However if you want your site to be 100% SSL it’s much better to go to your basic conf file and change the line

$baseurl = http...


Form is loading...

powered by open-source CMS software – This forum is powered by b2evolution CMS, a complete engine for your website.