Recent Topics

Account Activation on localhost

Started by on Apr 01, 2019 – Contents updated: Apr 19, 2019

Apr 01, 2019 16:43    

Hello
A little help would be most appreciated. I installed the 6.11.0 beta version as localhost using Xampp. I got the Welcome screen saying the installation was ready but I hadn't created any content collection yet. So, clicked on create a first collection option and received " In order to access the admin interface, you must first activate your account by clicking on the activation link in the email we sent you. See below:" where I am asked for email address in order to receive an activation email. But this does not function, so I cannot find out how to activate and get started. Thank you

Apr 02, 2019 00:19

Hi @alfiepanda ,

I had a similar issue when installing with XAMPP too, please try this solution, it worked for me at the time: https://forums.b2evolution.net/topic-13945

script to change a password on v6.

Create a new file in the root "/hacks.php" with the following code:

PHP

	<?php
	require_once dirname(__FILE__).'/conf/_config.php';
	require_once $inc_path.'_main.inc.php';
	 
	if( param( 'reset_admin_pass', 'string' ) == 'your_secret_key' )
	{
	    $your_user_ID = 1; // ID of your admin user
	 
	    $UserCache = & get_UserCache();
	    $User = & $UserCache->get_by_ID( $your_user_ID );
	 
	    $new_pass = generate_random_passwd();
	    $User->set_password( $new_pass );
	 
	    if( $User->dbupdate() )
	    {
	        $Messages->add( 'Admin password changed to "<b>'.$new_pass.'</b>"', 'success' );
	        $Messages->add( 'You should now remove the file /hacks.php', 'success' );
	        $Messages->display();
	    }
	}
	?>

Then call an url http://YOUR_SITE.com/hacks.php?reset_admin_pass=your_secret_key

Do not forget to delete the file /hacks.php once you're done! otherwise anyone will be able to reset your password at any time!

Note: ideally you should change your_secret_key in the code and in the url when you call the script. This way it's harder for anyone else but you to use the script.

Apr 02, 2019 02:04

Hum... it's not normal that the admin account is not activated by default.

Apr 04, 2019 12:14

@alfiepanda @theking did you install using b2evolution's installer or did you use a script installer that was bundled with XAMPP?

Apr 04, 2019 23:40

Hello
Thank you for your interest and follow up. I installed on MX18 linux using the b2 installer. I have not resolved the matter but am now going to retry using AMPPS that has a direct link to B2evolution installation and seems to be a better option. We'll see. I would comment that the installation instructions for localhost installations are somewhat ambiguous -at least to me.
Thanks I'll evaluate the AMPPS option and then if OK, uninstall XAMPP and try again.

Thanks
Tony

Apr 06, 2019 03:00

Hi @fplanque

I have two scenarios, in both I used the b2 installer from b2evolution.net (b2evolution-6.10.7-stable-2019-02-12):

1) At home on my personal computer (Windows 8.1 64bits with XAMPP 7.3.2, Mozilla Firefox 66);
2) At work on the company's computer (Windows 10 64bits with EasyPHP Portable (https://www.easyphp.org/), Google Chrome);

The second (at work) ran amazingly well, installed well as predicted. The problem I had was at home, with the XAMPP/Firefox, for some reason, the installation was stopping while in progress (the part when we see the list of tasks updating on the broswer's page), then freezes. I had to refresh the browser to finish it, and that's when I end up not receiving the password message on screen.

Luckilly I found that workaround that I described above, that worked like a charm.

Apr 07, 2019 13:40

Then the issue is not that the admin account. The issue was that the install did not finish, which is a completely different issue.

It would be interesting if you could post a screenshot showing exactly where the install stopped.

Apr 07, 2019 16:46

Hi,
Ok so I did it again to screen capture it, a clean install in a test folder, I also used Firefox in private mode to avoid any caching issues. Find attached the sequence of images. For some reason it freezes while creating table "<evo_items__prerendering>".
User/password for database local I'm using the default "root"/(none);

[b2evolution 6.10.7-stable]

Apr 07, 2019 17:44

Ok you show screenshot where the installer seems to stop at "created table evo_items__prerendering" but did you scroll down all the way?

In the next screenshot you show all tables up to evo_widget have been created. So where did the installer really stop?

Apr 07, 2019 19:40

Yes I did scroll down all the way, the page just froze like that (then I used firefox capture tool to capture the full page image).
I said installer "stopped" because on another computer, the installation that worked, the top bar got fully complete and I remember I saw some password for first use.

Apr 15, 2019 07:11

I tested the install script of b2evolution versions: 6.11.0-beta and 6.10.7-stable on the following server:

Windows 10 64-bit

XAMPP 3.2.3
Apache/2.4.38 (Win64)
PHP Version 7.3.3
mysqlnd 5.0.12-dev

FireFox 66.0.2(64-bit):

Chrome 73.0.3683.86 (Official Build) (64-bit):

Apr 19, 2019 00:41

Guys, good newzzz! Problem solved!

Having the same issue while installing the 6.11.0-beta, I decided to go all in and kill the beast once and for all!!!.
The page stops refreshing after 30 seconds so... (does it ring a bell anyone?), script max execution time! I went to edit the php.ini, changed the max_execution_time to 180, and now it works like a charm!
For some reason my system is slow or something, needing more than 30 seconds to finish the install
Find images below :D


Form is loading...

Run your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.