Recent Topics

1 Oct 08, 2019 01:51    

Antispam won't update blacklist

everytime I trie to upgrade blacklist the get the same results (see screenhot)

I have seen something that says you have to ping b2evolution.net to agree to TOS and I do.

Please help!

2 Oct 08, 2019 15:21

Hi wrc
Using 6.11.3 I get this ??? 2009 is somewhere way gone ** but it did work ! So is it any use ?

3 Oct 08, 2019 19:19

@amoun,
I don't know where that timestamp comes from ( Yours or mine)? Do you know if it is derived from our php code, b2evolution.net or our mysql db ?

I also don't know the significance of the "crumb_antispam" in the url.

4 Oct 08, 2019 19:30

@fplanque @amoun
As an experiment I tried to post a term to my website and b2evo blacklist. It appears that it was added locally but failed at the b2evo server. Ie I appears that I can't connect to the b2evolution.net server.

5 Oct 08, 2019 20:03

Yes from my last post it was clear it was updating my local blacklist, which implies a connection to the b2evo.

On the uploading issue : it seems odd that any b2evo user would be allowed to upload as any such person could blacklist any site ??

What term did you try to blacklist? I will try it.

6 Oct 08, 2019 22:31

shithead

I agree with the implications in your comment. Note that I did not make that call. It was the software that did it automaigically. I was hoping that my addition would set a new timestamp.

It did not and I received the same message.

7 Oct 09, 2019 00:12

@amoun

I have an install of 7.0.1 on my development server. I just upgraded the blacklist perfectly.
It now seems the problem is the the 6.11.3 installation on both the development install and the production install. I'm not sure where to go from here.

8 Oct 09, 2019 00:21

I also had problems with the dates

advanced.php -> Lign (84) $date_default_timezone = 'Europe/Paris';

9 Oct 09, 2019 17:05

@nospy
I'm not sure how this relates to the blacklist problem. It did, point to the fact that the time on my server was not in sync with the b2evo time. I changed it via you hint, Thanks!
It did not correct my problem.

In making that change did you correct your time problem?

I wish one of the b2evo gurus would weigh in for this. @fplanque @yurabakhtin etc.

10 Oct 09, 2019 17:19

We have no error_log of your website?

12 Oct 09, 2019 17:29

If there is a problem you should have an error log history at the root of your website (in folder b2). Or in the Admin interface of your host.

15 Oct 10, 2019 00:48

Do you have some extension in mind?

The error log suggests that the antispam.b2evolution.net server is not responding.

[09-Oct-2019 08:54:17 America/Denver] XML-RPC: xmlrpcmsg::parseResponse: no response received from server.
[09-Oct-2019 09:01:35 America/Denver] XML-RPC: xmlrpcmsg::parseResponse: no response received from server.

17 Oct 10, 2019 18:02

@amoun
https://womensvoicesmedia.org/phpinfo.php reveals the extensions that have been enabled. The major difference is that opcache and apcu are not on that list. bluehost tells me that they are included in the 7.3.9 php and will not be displayed in the info tool.

It has been my contention that while the 2 (opcache and APCu) extensions are bundled with 7.3 they are not necessarily active. That has been an ongoing discussion. Also, what possible relationship do these cacheing extensions have to do with blacklist. what is your opinion as to these extensions.

@fplanque wrote that simple xml, xml-rpc, mbstring, and gd need to be available and they are.

18 Oct 11, 2019 13:23

It is not necessary that opcache and APCu caches are enabled for this to work.

Do you have the ping module in your CP-Panel?

if it should be tested if you can ping the database it will define if there is a firewall that blocks the IP or not

19 Oct 11, 2019 16:12

Ping seems to be possible from my development server! I don't know how to ping from Bluehost (production server) where the error takes place.

20 Nov 08, 2019 19:17

For all who have given attention to the antispam update problem. Bluehost refused to acknowledge their role in this, despite the fact that I had 3 different installs that worked as designed. I also was unable to get Bluehost to activate the php extensions (APCu and Opcache, which are recommended for b2evo to work efficiently. As can be seen, in my posts in this forum, I have been frustrated with Bluehost.

My solution was to change my host to a2hosting. Right out of the box everything has worked with the exact same b2evo version (with my modifications). I could not be more pleased.

It is clear to me that Bluehost has no interest in supporting b2evo and I could never recommend them to anyone.

To others who have these problems, it is my conclusion that it is your host at the root of the issues.

21 Nov 08, 2019 22:57

@james7a87 wrote earlier:

I have this issue too

Hi. I wonder if you followed the topic through, i.e. you may have to keep updating until all entries are downloaded, or do you get the message that No data was received. If the later it may well be the host as @wrc last posted

"I have this issue" isn't that clear, a) no connection to server, b) no download, c) not updating. All three are different issues addressed in the topic.

22 Nov 09, 2019 00:25

@amoun, for the record, I changed host to a2hosting Turbo and I no longer have antispam, extensions, and cache problems. I'm really happy with A2! :-) I must admit that I didn't stick around to identify the cause nor do I know what the difference is. I do know it works now, with exactly the same b2evo code.

23 Nov 09, 2019 00:33

RE; my last post
I understand your switch and outcome etc. I was just trying to ensure that @james7a87 had a handle on the various ways the update appears to fail. I saying "have this issue to" is not helpful in such a messy issue :)

24 Nov 09, 2019 03:48

@amoun, I understood your intent. Since you have been such a big help, I thought it important to let you know what I decided. I am very grateful for your help. wrc

25 Dec 01, 2019 21:29

@wrc thanks for the feedback on bluehost and a2. We removed some stars from our bluehost rating.


Form is loading...

CMS software – This forum is powered by b2evolution CMS, a complete engine for your website.