Recent Topics

Have installed xampp. Cannot get any php files to execute. Kindly advise,

Started by on Aug 13, 2018 – Contents updated: Aug 14, 2018

Aug 13, 2018 01:32    

Aug 13, 2018 09:49

Some information would be a start.
This is not a b2evolution query is it?
What platform are you using, and is it on the main hard drive or a USB key

You could try and provide some information and screen shots of what you have.
Do html files work OK?

Can you run a phpinfo.php file? if not then your setup is at fault.

XAMPP would normally have php incorporated so if the phpinfo file doesn't work you probably need to reinstall

Make a file called [phpinfo.php] with the followinf single short line of code and try and run/execute that
<?php phpinfo(); ?>

Aug 13, 2018 15:21

Thanks amoun for your prompt reply. True; I supplied minimal information which did not help.

i am running windows 7 pro on my Dell laptop and running xampp on the main c: drive. Yes; HTML files work OK via my Chrome browser.

I will take your advice and start again by downloading and installing xampp. Thanks also for the little php test file.

Aug 13, 2018 16:25

amoun. Big frustration. I get right up to the Install procedure. It nearly finishes the b2evo install, and then hangs up right here:

Loading module: maintenance/model/_maintenance.install.php

It then refuses to proceed. Can I get through this blockage?

Would like your advice. Thanks.

Aug 13, 2018 19:29

Can you post a screenshot?

Aug 13, 2018 19:47

Hi johnnicza

Did you get the phpinfo file to work? before you tried installing b2evo, as if it works is shows php is being interpreted.

The file output also shows what version of php you have, not that is should be critical and what database you have.

On the subject of database, did you set that up with no problem.

Just trying to confirm if php works and that you've created a viable database for b2evo to exploit.

Though if you get as far as you indicated then there's no problem with php and database.

As @fplanque has asked would you provide a screen shot when you get the problem, the whole screen to include the url in the browser address bar please

Aug 13, 2018 22:31

Hi amoun and @fplanque.
Yes; php now works thankfully.
From the "Activate your account" email, I now arrived here:

Welcome to b2evolution
b2evolution is installed and ready but you haven't created any content collection on this system yet.

Create a first collection →

When I click on Create a first collection, I get to the "login" page. I enter my username and password, which is refused. I then apply to reset my password. It says that an email has been sent to reset the password. This email never arrives.

My username is johnnicza.
My email address is .

All I want to do is to login and get a blog system going. But it seems that there are many obstacles.

Aug 13, 2018 22:53

OK so things are getting a bit better :)

if it just a password issue see post #11

By the way the issue around posting screen shots is that no one else can really see what is happening, a picture speaks a thousands words and so on.

The more info you provide the less questions you are likely to be asked.

For example no-one can see what you typed in for your email, not that we want to see your password or email, I would remove your email from the above post.

Aug 14, 2018 12:35

Thanks again.

I went to that password issue topic, and tried to use phpMyAdmin/index.php as they said. All I got was "url not found" or similar.
Can you state exactly how to access phpMyAdmin on localhost?
Having problems getting the right urls, as you can see.

Aug 14, 2018 13:58

Please write down the password that is displayed at the end of the installation.

(note: the second image is a test, please ignore)

Aug 14, 2018 14:48

Well, that clarifies the issue. In fact, I never reached that point in the installation.

Thanks for the info throughout this thread by everyone.

I am away for a week, so will start afresh on return.

Aug 14, 2018 14:54

It is possible that XAMP dies before the end of the installation, for example if it doesn"t have enough memory allocated to PHP.

Form is loading...

Build your own site! – This forum is powered by b2evolution CMS, a complete engine for your website.