Recent Topics

HELP! Auto upgrade (6.10.4) stranded: Database schema is not up to date

Started by on Dec 06, 2018 – Contents updated: Dec 08, 2018

Dec 06, 2018 19:55    

Hi everyone!
I had this same problem in january and solved by restoring everything.
This time I'm not goin to back down before figuring out why this does not work.
Francois told me I had not provided enough info, last time, so now I'll try to do better ;)
What I've done so far:
1 - Checked error log:
[2018-12-06 10:50:52]: error: directory is writable by others: (/home/gerardpr/public_html/blog/install)
[2018-12-06 10:50:32]: error: directory is writable by others: (/home/gerardpr/public_html/blog/install)
[Thu Dec 06 10:22:18.431676 2018] [:error] [pid 23240] [client 54.36.148.166:54260] script not found or unable to stat: /home/gerardpr/public_html/main.php
2 - Renamed _maintenance.html to maintenance.html and _imaintenance.html to imaintenance.html
I can still not access the install folder: when I click on the "installer" button I get a 500 - Internal Server Error You have schema version «12320», but we would need «12987».
3 - Checked permissions on the Install folder: 775
4 Checked for the existence of main.php in the site root. The file does not exist here nor in B2evo directory (Blog)
Shot a bunch of screenshots.
It appears I'm close, but not yet quite there.
Any help will be greatly appreciated.
Thanks beforehand!!

HELP! Auto upgrade (6.10.4) stranded: Database schema is not up to date
HELP! Auto upgrade (6.10.4) stranded: Database schema is not up to date
HELP! Auto upgrade (6.10.4) stranded: Database schema is not up to date

Exact b2evolution version number :6.10.4
Name of your webhost :Siteground

Dec 07, 2018 01:11

In between we have added a blue box on the "new support request" from. You ignored most of it.

  • Name of your webhost?
  • URLs of your screenshots?

Your screenshots show no URLs. So it's guesswork and I hate it. I am assuming the last screenshot is what you see when you try to access the install directory to finish your upgrade. ---> Name of your webhost?

[2018-12-06 10:50:52]: error: directory is writable by others: (/home/gerardpr/public_html/blog/install)

Your screenshot seems to show correct permissions yet this error is still generated... by the CPanel on your webhost. NOT by b2evolution. ---> have you asked your webhost why that error occurs despite correct permissions?

Is there a way to check owner and group of files in addition to just the permissions (ie 755) ?

Dec 07, 2018 04:28

Hi Francois,

What would my life be without you kicking my ass every once and a while?
Hahaha kind of love it by now
If I had seen a blue box with the word support, believe I would have clicked on it...
We host is site ground, and I'm running php 5.6.
I took the site off-line with $maintenance in basic_config because as far as I know everybody could see screenshot one.
The URLs are standard, I.e. blog.gerardprins.com/installer/index.php.
All others generate a 500 error.

And just to clear that one up: I was at no time blaming B2evo; i am fully aware that this is server side.
Which is why your help is even more appreciated
THANKS

Dec 07, 2018 16:22

Hi Francois
Problem fixed
As it turned out, a whole bunch of directories had 775 permissions on them even when cpanel was showing 755.
I am clueless why, but my hosting service fixed it and the install finished in seconds.
As I have confirmed once again, bevo install is a very robust process.
Thanks for the hard work!
Looking forward to the next time you kick my butt
:D

Dec 07, 2018 21:24

@fplanque

As I've had the same problem .i.e. permissions needed changing, although this only happened doing an auto upgrade, can you confirm that the default file/folder settings as per your link are the ones to keep

  • All boxes checked
  • Folders 775
  • files 664

Dec 07, 2018 23:59

@amoun No I can't confirm that. The required permissions depend on the server setup.

If your server is like @gerardp's you probably need 755 & 644.


Form is loading...

CMS + forums – This forum is powered by b2evolution CMS, a complete engine for your website.