Recent Topics

question about updating after failed attempt

Started by on Mar 26, 2019 – Contents updated: Mar 27, 2019

Mar 26, 2019 16:16    

UPDATE: I went ahead and rolled everything back to our update from Friday, and will probably try to update again this week, this time making sure php has been updated first, and then perhaps doing it manually instead of using the automatic option.

Hi all,

Summary: Was trying to update b2evo, but didn't upgrade php first; upgrade failed; php is updated but site now shows an out-of-date version of site and admin page says "Database schema is not up to date!" No access to full backend, Not sure now if I should upgrade, or restore the database first.

So here's what I did:

  • Made a backup of my database (sql file is on computer)
  • Tried to auto-update b2evo before updating php on host server. (stupid, I know; but I misinterpreted an email from the host where I thought it said they had already updated php)
  • got stuck in maintenance mode
  • went through my host to undo maintenance mode (by changing file name)
  • updated php to 7.0
  • Admin login screen gives me message:

Database schema is not up to date!
The b2evolution files are present on your server, but it seems the database is not yet set up as expected.
For more information, please visit our Getting Stated / Installation Guide.
This is b2evolution version 6.10.7-stable.
You cannot use the application before you finish configuration and installation.
Database schema is not up to date!
You have schema version «11486», but we would need «13075».
Please use the installer to finish your configuration/installation now.
On most installations, the installer should be here (but I can't be sure since I have no config info available!)

  • upgraded from a previous version of b2evolutio
  • site is now showing an old version of the database

I have a copy of the database from a few days ago, but am not sure why it's currently showing an old version of the database, and whether simply restoring the database will solve anything.

Thanks for your help,
Mason

Affected website URL :http://www.xchanges.org
Exact b2evolution version number :6.10.7-stable
Name of your webhost :bluehost

Mar 26, 2019 23:03

@mason >I have a copy of the database from a few days ago, but am not sure why it's currently showing an old version of the database, and whether simply restoring the database will solve anything.

I had a very similar situation when moving hosts php version etc. I checked the database version and the one in the database was not that in the [/conf/_application.php] so I manually edited the database and changed the version number there, which is in the settings tables. Luckily, like yo,u I have a couple of recent copies of the database so I could play around a bit.

Looking at your post. Is it really showing the old database i.e. no recent posts or is it just the database version that is 'old'

Mar 27, 2019 02:10

I went ahead and rolled everything back to the backup (I did the whole public_html folder and sql file, since I wasn't sure exactly what was changed in the failed update, and figured it couldn't hurt). I thought I might be able to just tweak the upgrade somehow, but decided that might be a bit unpredictable compared to just reverting to the backup (especially after I read somewhere about how damage to databases may not always be immediately noticeable) .

@amoun I didn't dive into the php files to confirm, but it did look like it was a different sql file (maybe a previous backup?) that had become the active one. We're an academic journal now in issue 13.2, and the front page became that for issue 11.2 (from two years ago) using a previous skin and such. Also, I checked and recent post pages from the last two months were not accessible either after the update, when I tried using their direct links. I made a copy of the database from this morning before I rolled everything back that I could perhaps look through to see if there's any clues as to what happened.

Thanks for the support, emotional and otherwise.

Mar 27, 2019 09:56

So if you have, say, phpMyAdmin what I would do is, yet again export the current though 'old' database, that you know works, drop all tables, check to see they have ALL gone and then import the more recent database.

If the version number is correct then there should be no warning to update.

Before importing you can run the database through a text editor and check for 13075

Here is a list of b2evo version and corresponding database version numbers

6.10.7 :: 13075
6.10.6 :: 13070
6.10.5 :: 13050
6.10.4 :: 12987
6.10.3 :: 12972
6.10.2 :: 12910
6.10.1 :: 12890


Form is loading...

Open-Source CMS – This forum is powered by b2evolution CMS, a complete engine for your website.