Recent Topics

1 Mar 23, 2017 14:32    

Third post on this topic, stumbling point had been a request for screenshot of the error page. Done that this time

I have two domains which show the same problem. The other two posts refer to and

This one to

The problem is is exactly the same so you can read the beginning of the first url above and a screen shot of this instance is at

The error is live at

If you go to the base site you will see the live 503 error

Repeated upgrade failure: This time to 6.8.8

2 Mar 25, 2017 20:49

The 503 error "System upgrade is in progress. " is normal at this point.

The 500 error "green screen" you screenshoted is complete BS from your webhosting company. If the script "requested isn't found at this location", they should send back a 404 message and not a 500 error.

1) So, first, you need to go and check if install/index.php actually exists on your server at the time that error is displayed.

2) Then, if it exists, you need to look at the apache error log to see exactly what error is recorded at the time you get the green screen above.

3 Mar 25, 2017 22:22

Thanks for your response

As in previous attempts

Auto upgrade went well,, until asked to update the data base and I get this which is my 500 file,
but the file does exist in public_html

So to answer your question 1. yes the file does exist

If I rename the umaintenance file and I get the 'Database schema is not up to date!' page but going to the install page gets me a 500 error again just this time it's the /install/index.php without the parameters, and yes the file still exists

Since the update any request for a php file gives a 500 error
all others txt, html htm whether the file exists or not go to 'Database schema is not up to date!' page a 503 error

Will try and get the apache error info

Has there been a change since 6.7.8 as I had the same error doing auto then but it worked when I did a full ftp but since then even a full ftp overwrite does the same except for the older versions from 6.7.8 back Nothing since then works.

I can imagine something on my host doesn't like something in the newer versions and it's only the php files in b2evo it doesn't recognise. Once the auto upgrade has been done I can't access any php files. Thought it may be an .htaccess but haven't found anything there

Quest 2 The only error on my server relating to the blog is one telling me my install folder is writeable by group Soft exception ccp 603

If I rename the folder, the install url goes to a 503 not a 404, if I url the new name I go back to the 500 error

4 Mar 26, 2017 16:55

Who is your webhost?

Just to be extra clear: the green error screen is not generated by b2evolution, it is generated by your webhost and it makes absolutely no sense to me what it's supposed to mean.

You need to ask them what the hell the real error is when they display that.

Also again: you need to know what the meaning of the green screen error is wehn you hit

It is completely pointless to talk about all the other errors you see because they are all consequences of you not being able to execute

Has there been a change since 6.7.8

There are hundreds of changes in each new release.

5 Mar 26, 2017 17:12

The only guesswork solution I can give you (until your host replies) is: try to reset the unix file permissions of all files to mimic the file permissions of a working file.

6 Mar 26, 2017 21:51

Ok thanks. I've emailed my host.

The problem as I see it is that since 6.7.8 if I try and update my b2evo, either auto or ftp, no php files can be accessed across the whole domain. The blog is in it's own directory and it's the same with my other main site where the blog is the root, but on that one I managed to reinstall 6.7.8 and all is fine. ??

The green page is just my 500.shtml but why it's being called ???

Changing all file permissions, by recursion, seems a problem to undo

Just edited a file, if the file starts with <?php it causes the 500 error saying file doesn't exist, but it's ok if it's a script after an <html> tag has been read.

That seems to be in only certain directories. Where I have my own directories for stubs both issue work but not in b2evo directories. There seems to be some script that doesn't allow php in standard directories in the blog

On the green page I've edited that as it's not that the file can't be found
Here's an example of the problem
I have made two files phpinfo0.php and phpinfo1.php and placed them in
the root
the blog
the install folder

if I try phpinfo2.php which doesn't exist
in the root I get a 404
in the blog and in /blog/install I get the message 'Database schema is not up to date!' that's without the umaintenance file else I get the 503 error

for the phpinfo0 and phpinfo1
in the root all is ok
in the /blog ok
in /blog/install I get the 500

7 Mar 27, 2017 12:08

Just heard again from my host

As our webserver uses suphp on PHP5 you will notice the following error in your cpanel error log (found under your cpanel account > errors):

[Mon Mar 27 08:46:44 2017] [error] [client] SoftException in Application.cpp:603: Directory "/home/rogerlov/public_html/blog/install" is writeable by group.

This is due to the server running SuPHP and the files having higher permissions than allowed, to fix this problem you need to make sure your files are chmod 644 for all PHP based files and 755 for directories in order for them to work with SuPHP.You can easily do this by connecting via FTP with Filezilla and right clicking on the problem folders and files and selecting file permissions.

My reply

Yes thanks I saw the cpp:603 and checked permissions and all are as should be

There's something in the blog that is off like there's a directive to not allow php in certain directories ???

Well that's what I've got to as I get the 500 error only in preset directories in the /blog/ when accessing php files

Their latest

VooServers Limited

Hello Roger,

We will continue to look into this now for you.

Best Regards,
Luke Germano

Well I haven't checked every file and directory in /blog/ but /blog/install/ is fine

Their last

Hi Roger,

You will need to raise your last question with the software that makes the blog as the only current issue is with the file permissions which I have addressed how to fix in my previous response.

8 Mar 27, 2017 14:37

OK I have found it

I did a recursive permission change to all folders in /blog/ and the upgrade went as planned but why permissions got changed on the auto upgrade I don't know. I will check the download files

Just auto upgraded 2bevo on another site with the same problem, but this time, via Filezilla, I noticed the install folder had permissions 775 once I changed then to 755 all went well

Still can't understand how. I've just ftp'd the /install directory and it came out as 755 How on two domains it ended up as 775 is a mystery. Will see what happens with the next auto update, but this has been happing since 6.7.8 and I haven't managed to sort it until now.

Thanks Francois

Form is loading...