Recent Topics

1 Jun 08, 2007 16:54    

My b2evolution Version: 1.9.3

Hello Folks,

I've just moved my entire site to a new web host, managed to transfer
the database and everything seemed to be working fine. However, as
soon as I press [Save] in the edit post menu, the response is to take me
back to my base url index.php. I'm guessing that there's a path error
somewhere, but I haven't a clue as to where.

[url=]Caronia Timeline Blog[/url]

Thanks in advance if you can help - I sorely need to do an update.

Steve (Peter S.)
[url=]Caronia II Timeline Webmaster[/url]

2 Jun 18, 2007 16:48

Hello Folks,

Following some further trials I changed the ./conf/_basic_config.php on
the web site from...

 * @global string $baseurl
$baseurl = '';


 * @global string $baseurl
$baseurl = 'http://localhost/car2blog/';

...and everything worked fine. However, within the blog pages viewed by
visitors, instead of the referring URLS showing, they
were showing localhost - useless for RDF / RSS feeds.

In the meantime I upgraded to Version 1.10.2 and the problem persisted.
All worked fine on my localhost server, but not on the remote one.
So I wrote to my site hosts explaing the problem and back came this

Looking at the apache error logs on the server, it seems that the
mod_security module is affecting your b2evolution application.
Mod_Security is a web firewall and provides protection from a range of
attacks against web applications and allows for HTTP traffic monitoring
and real-time analysis with no changes to existing infrastructure. We have
disabled the mod_security for your account.

Disabling the mod_security cured the problem, but my questions now are...
1) Does this mean that my blog is now insecure?
2) Is this an issue for the development team? IOW, should B2E work
with mod_security enabled?

Steve (Peter S.)
[url=]Caronia II Timeline Webmaster[/url]

3 Jun 18, 2007 17:26

Um... because "localhost" is what you use when it's locally hosted and it's your domain name when it's out there in the wilds?

If you want a visitor to see it correctly then $baseurl has to be the base url of your blog, but if you want to see it "locally" then you have to be set up to do that. That's all I know. I have no clue how it works, but for sure one of the reasons for my way-cool custom computer is to figure out how to make my computer be like a server to me for testing. That's pretty much whole "localhost" thing, right?

5 Jun 18, 2007 21:02

EdB wrote:

Um... because "localhost" is what you use when it's locally hosted and it's
your domain name when it's out there in the wilds?

Well, yes, _if_ it was the localhost that was causing the problem...

The problems have always occurred on the remote server. Click on [Save]
and instead of showing the "page updated" stuff - I was taken to the site
home page index.php - not the blog one!

I didn't see much point in installing b2E on my local server, but did so to
see if the problem was replicated locally. It wasn't. I then uploaded the
changed _basic_config (with localhost) to the remote host and tested
- it all worked, except as indicated above. So, the questions I asked in
my previous post remain...

Steve (Peter S.)
[url=]Caronia II Timeline Webmaster[/url]

6 Jul 19, 2007 11:33

Oops. Shouldn't have left this hanging like this. Have you tried replacing your inc/ folder with a fresh copy? It's a maybe, and it didn't work for someone with a similar file. They referenced this post is how I got back here btw.

I'm reaching here, but did you transfer any other commonly used php/mysql applications like phpbb or wordpress or whatever? If you did and you have no problems with them that might help narrow down the problem - for those smart enough to understand how it all works of course.

Also have you considered upgrading even though you have a bug in your installation? Keep copies of the current files and database handy because if the upgrade makes things worse you'll be pissed at me!

Form is loading...