Recent Topics

1 Aug 05, 2007 02:26    

My b2evolution Version: 1.10.x

New to blogs; Very green with PHP/MySQL configs;

Think I have done all ok - setup dbase on my hosted account; have username and pwd also; changed chmod settings for /conf/_basic_config.php in my ftp program to 666; ran index.php in the /install directory; Got following error:

MySQL error!

Error establishing a database connection!

(Access denied for user 'brianmod'@'localhost' (using password: YES))

Are you sure you have typed the correct user/password?
Are you sure that you have typed the correct hostname?
Are you sure that the database server is running?


Is it ok to leave 'MySQL Host' parameter as localhost ? Or should I be using the IP address or URL of my ISP hosted account ?

thanks for any help

2 Aug 05, 2007 03:38

Usually 'localhost' will do. That is in a situation where your host has a MySQL database set up for you within your domain. In certain cases however, there is a different server for the database(s). If this is the case for you, you will have to replace 'localhost' by the servername provided to you by your host.

Normally you will find this information in the cpanel or phpMyAdmin or similar control panel of your host. There click on databases and have a look around.

Good luck

3 Aug 06, 2007 14:39

My hoster has advised that localhost is the correct name to use.

They are runnning

php - PHP 4.4.6
mysql - 4.1.20

Could there be a compatibility issue with the version of b2 I am using ? which is 1.10.2

Form is loading...