Recent Topics

1 Dec 30, 2007 10:12    

I get this error saving posts

XML error: not well-formed (invalid token) at line 15 (104)

And I checked it with English and non English titles. Everything was fine in version 2.2.

Is it a new version bug or not? Cannot copy it in Demo because this function is disabled.

2 Jan 09, 2008 04:59

It happens every time when pinging even on the new installation.

4 Jan 15, 2008 00:41

That didn't solve the problem.

It looks like a bug in 2.3.0 version. I did 3 installs from scratch and every time I get this error.

Maybe doesn't like my posts :)

I'm wondering why nobody else get this error?

5 Jan 15, 2008 15:30

Can you post an example of a file you're trying to publish?
Perhaps the best thing to do is upload it as a file, so that the text is not altered (codepages, etc); or maybe you can use something like

6 Jan 15, 2008 15:43

To gr8dude

I'm not trying to post with external editor. I get this error saving posts in b2evo.

# Pinging Ping-O-Matic...
# Response: [0] [Pings being forwarded to 16 services!]
# Pinging
# Remote error: XML error: not well-formed (invalid token) at line 15 (104)

7 Jan 16, 2008 14:01

Ok, then post here whatever you are trying to post on your blog.

8 Jan 16, 2008 16:46

It doesn't matter what I'm trying to post.
I even tried absolutely empty post with no plugin installed (except ping b2evo). I also tried different languages.

I only see 1 possible reason - it's a bug in 2.3.0.

The question is WHY NOBODY CARES? 16 days left and no dev's reply...

9 Jan 16, 2008 17:16

Um... given that no one else is having this problem maybe it's not a bug in b2evolution?

Exactly which site are you getting this error from?

Is it a 100% clean installation of b2evolution, or are you running your "Russianized" version when you experience this issue? No offense here, but if it's your version it could be your code.

Assuming you're using the original version of 230RC1, do you have any file edits in conf that you need to satisfy your locale, and if so can you duplicate the problem without that change?

10 Jan 16, 2008 17:21

All right, I'm now installing again non "Russianized" verion :) (the only difference is ru-RU folder, I always make changes after install).
And I always drop tables before clean install.

Will see...

11 Jan 16, 2008 17:24

By the way, you can make a post yourself. In demo (there is no Russian now)

12 Jan 16, 2008 18:19

I just did a test post and it did not ping or say it got an error when pinging. After a very long time it gave me a blank page.

I will download your Russianized version and test it on my server, but I can't say exactly when. (I know - you heard that about your skin then had to do it yourself :oops: )

Currently I am DRIVEN to produce a high quality "creative commons license" plugin that will work for all nations that have a ported version of the various CCLS, so I must first reach a respectable breaking point before I focus on another task.

13 Jan 16, 2008 18:44

sam2kb wrote:

The question is WHY NOBODY CARES? 16 days left and no dev's reply...

Can I just point out that since christmas eve I've had a sum total of 3 hours off work as I'm busy migrating 3 servers from various parts of the world to their new homes.

On top of all this we've been trying to upgrade our own b2evolution site where we frequently release and support plugins for the software for free.

As well as all that I've also got a shedload of work to do to resynch my own cvs version with the 3.0 version so that I can commit the changes to the UI that I've made ( sorry FG, still haven't had a chance, it's high on my todo list ) so that the new version isn't delayed by me.

None of the above includes my normal daily workload which is also piling up ( thankfully we have very understanding clients )

All of which means that :
a) it's not appreciated when you get pissed off that I haven't dropped everything to bend over backwards to fix your unique problem
b) I'm not liable to get a day off before the end of febraury
c) I don't have the time to work through potentially complex problems so I've just been solving the ones that I do have time for

Thanks for your understanding


14 Jan 16, 2008 18:58

Thanks for reply. Sorry for complains. You guys, do a great job. :no: No more complains. ;)

15 Jan 16, 2008 19:00

No problem, I was just letting you see things from my perspective ;)


16 Jan 16, 2008 20:53

sam2kb I just installed your version on my server, changed nothing, wrote a sample post, and it successfully pinged both b2evolution and ping-o-matic. I immediately deleted the installation because that's what I do after a test installation pings.

Therefore I would say it's either something about your server config OR the exact copy of the files you have on your server.

Best of luck with it!

17 Jan 16, 2008 21:09

Thank you for your time, this is better than program bug ;)
I'll upload files again, this should help.

Thanks to all who cares :)

18 Jan 17, 2008 22:32

Have you actually solved this yet or are you still having a problem?


19 Jan 17, 2008 22:38

Don't have time to try, got some job.
I'll come back in a couple days with my results.

20 Jan 17, 2008 22:45

Let us know if you still have a problem when you get a chance to try.

Something you might like to try is repeating the error :
1) without uploading your RU translation ( it'd narrow one thing down )
2) with your browser set to UK or US or one of the other ignorant locales in the world ( it could possibly narrow it down to a charsets problem )
3) same as 2, but with a bog standard db install and default config files ( dunno what that would narrow it down to but it sounds geeky and technical so I couldn't resist :D )


21 Jan 21, 2008 04:41

I did some tests...

:D 1. Install with English demo posts - no errors
:D 1.1 Install with English demo + Rus locale - no errors

:( 2. Install with Russian demo posts - XML error
:( 2.2 Install with Russian demo and without Rus locale - XML error

:( 3. Install without demo, but using Russian installer - XML error !?
:D 4. Update 2.2 system (was installed without demo at all) using Rus locale - no errors

All test posts were published without content.
I tried this on 2 different servers.
For all installs I used the same files and settings:

$force_io_charset_if_accepted = 'utf-8';
$db_config['connection_charset'] = 'utf8';
$default_locale = 'ru-RU';

All files were uploaded as a single archive and extracted on servers.

22 Jan 24, 2008 09:50

No errors in 2.4.0 !!!

I don't know if it was a translation or encoding problem, but it is fixed in 2.4.0

23 Jan 25, 2008 00:54

Yay, gotta love it when a release cures a problem ... buggered if I know how though ;)


24 Feb 03, 2008 20:56

It's not a unique problem. Whenever I submit a new post to my blog (b2evo 2.4.0-rc2) I get this error as well: It's only when posting a new message:

# Pinging
# Remote error: Invalid return payload: enable debugging to examine incoming payload (XML error: Invalid document end at line 2, column 1) (2)
# Pinging Ping-O-Matic...
# Response: [] [Pings being forwarded to 16 services!]

25 Feb 06, 2008 18:34

I realize that everyone's busy but does anyone have any idea why this is happening?

26 Feb 06, 2008 18:41


My error was caused by Russian language pack and it's fixed in 2.4.0

I have no idea how to fix yours, sorry.

28 Feb 18, 2008 19:14

I just tried from a 2.4.x install ( [url=]Dev blog[/url] )

ping messages wrote:

# Pinging Ping-O-Matic...
# Response: [] [Pings being forwarded to 16 services!]
# Pinging
# Response: This is the first time you ping us for this blog. Allow a few days for validation before your blog appears on .


Form is loading...