Recent Topics

1 Dec 30, 2007 12:54    

My b2evolution Version: 2.x

Hi there,

I am almost done setting up b2evo and so far it is working like a charm.

All users need to login before they can see the blogs. I've set user permissions and that seems to be working properly. So the only content visible is that of the blog the user has permission for.

Now my next question is about blog posting.

If a user wants to write a posting now he will be presented with various tabs in the admin section. Including one where he or she can change the blog settings.

That I don't want. Just give the person the option to write and/or upload files and that's it.

For the rest the blog admin is the person who should handle settings.

I've set the user up as bloggger. with permission level 2. On the permission tab I have given the admin full access and the user contributor access.

But this doesn't seem to do the trick. The user can still see all the tabs.

Can somebody point me in the right direction?


2 Dec 31, 2007 07:14

There's a tab in the user section with permissions.
The original name is "Privileged users"
If you click on that you get to a whole section of possibilities.
Maybe this helps?

3 Dec 31, 2007 08:54

If you mean the tabs that you get switched when you tick the box in the features tab (user permissions and group permissions), then I have found those.

I already tried setting the permissions before initially posting here.

Today I noticed the the advance link there, went there and switched of all the options except posting. Saved. Now the user is on custom. far nothing.

Logged in as that user, went to the admin and I could still change the blog settings.

If I am reading things on that page properly that should work. But why isn't it doing the trick?

Just in case I also tried it on a different browser (since I read the cookies can be a bit too persistent) but no dice: still the user can change his settings. Even though as administrator I've only given him posting privileges.

I hope some of the experts here can point me in the right direction since I cannot see what I am missing here


4 Dec 31, 2007 09:06

Mh, dunno :S

*scratches head*

5 Dec 31, 2007 10:16

My thoughts exactly :(

I've tried putting the user permission level on 0. Doesn't make a difference either.

If you currently look at the user permission settings he should only be able to post and nothing else.

Yet, after logging in the user can happily change everything!

Am I missing something or have we run into a bug?

I've tried it on two computers, deleted the cookies beforehand.

And what can I do about this?

I would happily give an expert the password so that he or she can have a look and help me in this.

6 Dec 31, 2007 10:18

After changing the settings and saving, etc.
did you try to restart your Computer, clean the cache, etc.?
Maybe that will help?

If it doesn't we can only hope that one of the Gurus will pop in soon.

I have some slight trouble myself and would love some lovin' :D

Hope someone can help you!

7 Dec 31, 2007 10:58

Tried that.

Deleted the temp internet files, cookies, even the temp dir that's located in xp's documents and settings.

Restarted the computer.

Still exactly the same.

So weird, since according to the setting it should be ok. But it isn't!

8 Dec 31, 2007 11:44

You are fairly correct in changing the permissions. So now you have a custom usergroup.
You will have to find the new user and assign him the new custom usergroup rights. He probably still has the Privileged Blogger rights.

To allow changes made you can not only delete the cache from the browser but also the Prerendered Item Cache in Tools -> misc.

Good luck

9 Dec 31, 2007 13:48

I have not set any user groups, since the only persons having access to the blogs are the registered user and the admin (it will be used as a logbook for the user).

So all except the admin are on 'not a member'.

In the user permission tab I have the admin as a member (obviously) and the user.

So there the status is on custom.

I checked the user, it has Blogger rights. Unless I am totally overlooking it I don't see any Privileged Blogger rights anywhere.

I deleted the cache and also the Prerender Item cache. Doesn't make a difference.

I had someone test it from another connection (thanks Nicole!). But she also was able to get to the blog settings and change the permissions and such.

You're more than welcome to take a look if you want. This is driving me crazy, I mean from the looks of things all is correct but in practise it doesn't work (yet).

10 Dec 31, 2007 13:52

The area where the user can change those permissions looks different though than on my Site.
That's one of the weird things about it.

If I have time later, I'll register on my blog as a new user and will check that out that way.
(Now I have to get my butt going ;) )

11 Dec 31, 2007 14:07


That might be because advanced is selected as opposed to simple. Which it is set to as default.

Still, the settings seem to be correct but still the user can change everything. Hope Afwas or one of the other experts will be able to crack this nut.

12 Dec 31, 2007 15:29

hi draxeiro,

There isn't really a secret. You are doing great but you just need the settings to your liking.

Well there is a secret actually. I'll tell you.

Your browser has set up a cookie and knows you are the admin. That means you have all rights in the backoffice regardless of how you logged in. So, if you want to test how a regular user sees the backoffice, you must do so from another browser or even another computer.

Good luck

13 Dec 31, 2007 15:33

Even if you clean the cookies, Afwas?

Dra, you lost me at advanced and simple (sometimes I DO wish I had stayed with wordpress, ducks & runs ;) )

14 Dec 31, 2007 15:36


Well, I figured as much already. I tried deleting the cookies and what have you. Shouldn't that have done the trick then?

Tried it on another computer here. But I guess I logged in as admin there too in the past.

Then I had the idea to have NicoleB try it. Only let her login as the user. And she too got the blog permissions tab and could change the permissions if she wanted.

So it would not seem to be a cookie problem...

But in the meantime it IS driving me mad ;)

15 Dec 31, 2007 15:40

You know what - I just remember - the option to login as an admin was still there and *shame on me* I think, I clicked it.....

OK, loggin in as a user I can still change the perms for the other users but not the admin.
But in the group perms I can.


16 Dec 31, 2007 15:40

Nicole, if you look at the permissions tab, you see the links simple and advanced above the current settins. If you click the advanced setting it will switch to a different screen where you can create custom settings.

Which I have done. User should only be able to post.

Maybe I am missing a setting somewhere. But for the life of me I cannot seem to find it.

So if Afwas or another expert wants to have a look, by all means PM me and I will send you the login details.

17 Dec 31, 2007 15:43

Just saw it, but it just changes the Layout a tad.

Now, I have an idea, why don't you (you can delete it later) sign up for one of my collective blogs and test what you can do there?
User perms should be similar to what you were planning.
But I have no clue if it works, I didn't test it, shame on me

18 Dec 31, 2007 15:45

That's what I mean.

You might have clicked the admin login button but you logged in with that user's details so it shouldn't have made a difference which button you clicked.

According to the settings the user shouldn't be able to see, let alone change the blog settings. But like you say, you can easily do it.

Weird stuff this...

19 Dec 31, 2007 15:47

Go ahead and see if it looks similar at mine *shrug* can't hurt, no?

I see you did, well, now we go and see what this is all about ;)

20 Dec 31, 2007 15:53

I did indeed!

On your's it works like it should!

I think we may be on our way to solving this.

We can compare :)

21 Dec 31, 2007 16:02

I have not delved into user perms in 2.*, but I can hopefully offer a clue from days gone by. By the way I don't even remember the old days at this point, so it's really all guesswork.

Make sure both the USER and the GROUP permissions are set the way you want them for each blog. What I mean is if you set A_SPECIAL_GROUP to have certain limited permissions, and have somehow given the user extra powers then it is possible that the user perms are over-riding the group perms.

Okay scratch that. I now see where each blog, after hitting the Blog settings tab, has a feature on the bottom of the "features" subtab for "use advanced perms". So perhaps that is not checked and therefore needs to be checked?

It is also possible you've hit a bug. If so it's a biggie because The Admin has always been and is supposed to be able to control the permissions of all other bloggers on each installation. It has never been "perfect", but it has always offered multiple methods of controlling permissions.

22 Dec 31, 2007 16:24

Hi Ed,

Thanks for your input.

Regarding point 1: I have not set any group permission. All are 'no member'. I am just controlling it on the user level.

Point 2 is checked, I did also uncheck it to see if it made a difference. It doesn't. Previously set permissions are kept to. Which is good.

You might have a point with it being a bug. I just tried creating a new user and a new blog. Set up everything as with the other blogs.

Guess what? Now it works!

For that user and on that new blog, that is. Haven't tried adding the new user to one of the previous blogs.

So it would seem that if you start changing the permissions on an existing blog and/or user it doesn't properly adhere to the settings.

Yet if you create a new one it does.

Either the problem is with the users or with the blogs.

Will look into it more tommorow as I have to be off to go to have dinner with friends and celebrate the new year later on.

Have a good one everybody!

23 Dec 31, 2007 16:33

OK, what I did was make a default group for users named "bloggers"

You might consider giving that a try.

Catch you tomorrow, I'm falling asleep typing ;)

24 Jan 01, 2008 16:09

I am not using groups, since these blogs will act as logbooks only the admin and the user itself will have access to the blog.

So therefore it could be controlled on a user permission level.

I played around some more and if I add the new user to an existing blog it also works properly.

So the problem is clearly not with the blog but rather with the previous users.

In any case, upon creating the new user I've set the user level on 0. And on the user permission tab I've only given him posting permission. The rest of the boxes are unticked.

That works.

Also with any new users that are created.

But not if you change the settings for older users.

So it would seem this is indeed something of a bug.

One that can luckily be worked around by creating new users and giving them the proper permissions.

Form is loading...