Recent Topics

1 Jan 19, 2008 18:47    

I'm using Opera 9.5 (build 9745) from

I know its a beta build of Opera, but I thought I'd give you a heads up. Have not tried the last full version (9.25).

I cannot login. Works fine in Firefox 3 beta 2 and Internet Explorer 7 however.


As of 2.4.0 I can't log in with Firefox 3 Beta 2 either. Same issue.

[Update #2]

Rechecked for 2.4.1, can't login with Opera 9.5 or 9.2

2 Jan 19, 2008 21:46

Opera 9.50 Build 4506 on a Mac Leopard, works fine

It did come up with an odd tooltip whie entering the password "The entered text is large. You used 64 letters"!!!!!
but it didn't stop me logging in

3 Jan 20, 2008 11:33

Yesp see that warning box too, and at ther same time the password field is filled with *'d characters.

4 Jan 27, 2008 12:12

Updated for 2.4.0. Now broken in FF3 B2 as well.

5 Mar 17, 2008 12:26

Updated again, can't login using Opera 9.2 or 9.5

6 Mar 17, 2008 12:46

Once again, this is on a Mac using all versions up to b2 2.4.1.

Opera 9.5, Firefox 2.2.10, Firefox 3 and Safari have given me no problems, apart from that odd Opera message at login.

7 Mar 17, 2008 12:54

I'm on a PC (with both Vista and XP) with Opera 9.26 and 9.5 Beta 1 and I'm manually typing it in just to be sure (but the previously saved wand password from 1.10 worked before and I havn't changed the password, but doesn't now).

If I manually type it into IE7, it works just fine.

8 Mar 17, 2008 12:55

Incidentally my password contains numbers and lowercase letters, and my suername is just lowercase letters, if that makes a difference.

9 Mar 17, 2008 13:02

It shouldn't. I don't use the Win box any more but have always had beta browsers one it without issues up to a year ago.

Have you always performed a clean new install of all b2 files? ie deleted all old files and run the installer for an upgrade?

Beyond that it does seem like an odd one off issue.

10 Mar 17, 2008 23:53

Not for the last upgrade (2.4.0 -> 2.4.1) but for the previous ones, yes.

12 Apr 17, 2008 16:31

I can now login with Firefox 3 beta 5. No dice with Opera 9.x though. I get this message now:

Either you have not enabled cookies or this login window has expired.

Plus I still get the flash of "the text you have entered is too large" when I submit the password.

If I disable javaScript I get the following error:

You must log in!

Does this mean you REQUIRE JavaScript to login? Thats pretty poor accessibility... :-/

13 Apr 17, 2008 22:04

b2evo uses javascript to enhance security, WHEN AVAILABLE, by encrypting the password before transmitting.

No JS is required. At all.

14 Apr 18, 2008 03:21

I can confirm erratic behaviour in Opera.
It reports using 61 characters for password and claims a maximum of 50.

The 50 is easy to explain:

<input maxlength="50"

The 61 is either an intermediate step of some sort or a quirck from Opera.

This doesn't prevent me from logging in.

15 Apr 18, 2008 11:13

Thanks Afwas I was beginning to feel like the lonely Opera user guy, or that it was a problem somehow unique to me.

@fplanque So how come I can't log-in at all with JS disabled? A mistake or an oversight? Or a problem with JS detection? Or perhaps a problem with Opera still?

16 Apr 18, 2008 18:20

I'm changing maxlength to 70.

Frazor, try IE otr FF with js disabled and see for yourself. You CAN log in without JS.

17 Apr 18, 2008 23:30

You are right (of course).

In Opera you can't log in with JavaScript disabled, AFTER you've tried with it enabled. It's cookieing something. So it won't work after that.

However, once I deleted the cookies, it worked. Hmm, that'll do as a workaround for me for now. Cheers.

Looking forward to testing the next release.

18 Apr 18, 2008 23:34

Ok, so now I can logn WITH JavaScript enabled in Opera... I still get the warning message about there being too many characters... but the login succeeds.

So my problem all along was a cookie from a previous version of B2Evo. At some point something changed about what is in that cookies, or whats being read from it, such that it has been preventing me logging into the 2.x builds. Or maybe something between B2Evo and Opera is corrupting the data in the cookie? Who knows. If it happens again I'll save the data in the cookie.

This seems to have effected the Captcha image issue I was having too, as now thats fixed too.

Thanks for the help.

Form is loading...

Free CMS – This forum is powered by b2evolution CMS, a complete engine for your website.