Recent Topics

[Solved][2.4] The "nofollow" tag flag has no effec

Started by on Feb 12, 2008 – Contents updated: Feb 12, 2008

1 Feb 12, 2008 10:47    

In the _item_comment.inc.php file

$Comment->permanent_link( array(
							'before'    => '',
							'after'     => ' '.T_('from:').' ',
							'text' 	=> T_('Comment'),
							'nofollow'	=> false,
						) );

Changing the 'nofollow' variable to false has no effect. It doesn't remove the nofollow attribute.

3 Feb 12, 2008 11:19

Hi harishankar,

Empty the Dashboard -> Tools -> Misc -> Prerendered Item Cache

Good luck

4 Feb 12, 2008 13:51

Hi, ¥åßßå, the comment URL in your linked example shows like this for me:

<a rel="nofollow" href="http://example.com">http://example.com</a>

Afwas, I tried that too; actually it didn't work. :(

EDIT: Er... I meant the author URL no-follow. My fault... :oops: How do I get that to work? I want to reward my commenters and give their site a no-follow link when they comment. :)

5 Feb 12, 2008 14:02

OK, I worked a solution around this problem like this:

Replaced the author_url () function with this code:

<a href="<?php echo $Comment->author_url ?>"><?php $Comment->author(); ?></a>

6 Feb 12, 2008 14:11

You muppet, now you make sense ;)

This is what I ended up doing in my skin :

$Comment->nofollow=false;// turn this crap off :|

¥

7 Feb 12, 2008 14:14

Moving this to Support. No offence intended.

--F

8 Feb 12, 2008 14:18

Thanks ¥åßßå, thats a simpler solution too.

I really confused myself with comment permalink URL and author url :o

Moving this to Support. No offence intended.

:lol: My fault. Too quick to see a bug where there is none...

9 Feb 12, 2008 14:34

harishankar wrote:

:lol: My fault. Too quick to see a bug where there is none...

We've all been there :roll:

11 Feb 12, 2008 16:41

Hey, by any chance does the spam karma plugin "Basic Antispam" automatically add a nofollow to all comments?

EDIT: confirmed, yes it does.

My question now is: will removing basic antispam unprotect my blog from a whole lot of spam?

12 Feb 12, 2008 17:07

I don't use that plugin, but "no follow" NEVER stopped spam from happening. All it does is deny link-love in some search engines by not crediting the linked URL with an inbound link.

Seems to be, by looking at the settings for that plugin, that you can turn off "no follow" by setting the "Apply rel="nofollow"" bit to 0 and still have all the other antispam benefits that plugin offers.

Hope it helps!

13 Feb 12, 2008 17:10

Thanks EdB.

I figured this just before you replied, but I'm glad I sorted that out. :)


Form is loading...

Advanced CMS – This forum is powered by b2evolution CMS, a complete engine for your website.