Recent Topics

[2.x] 2.4 Problems After Upgrading from 1.10

Started by on Feb 23, 2008 – Contents updated: Feb 23, 2008

Feb 23, 2008 16:34    

My b2evolution Version: 2.x

I would appreciate any help I can get. I have been at this for hours.

I have several issues after upgrading. The install seemed to go smoothly. When I bring up my page, it looks like it is okay, but the comments and the Read More functionality is broken.

You can see the problems here: http://kitchen.mrorph.com/

If you click on Comments or Read More you will see the error:
Notice: Trying to get property of non-object in /home/mrorph5/public_html/foodblog/inc/_core/model/dataobjects/_dataobjectcache.class.php on line 283

I am pulling what's left of my hair out over this!

Please help!

Feb 23, 2008 16:44

Hi MrOrph,

Welcome to the forums.

It looks like your stubs are outdated after the upgrade. Although stubs should be working in 2.4, there is a tendency towards moving all essential settings from the stub files and the config files towards the Backoffice (now called Dashboard).
In your blog settings go to URLs and (for a starter) set the Blog URL to "Default blog in index.php". This should run your blog error free.
In a later course you can change the settings to your wishes and/or have a look at the file blog1.php.

Good luck

Feb 23, 2008 16:57

Thanks! That worked.

Now on to the other issues.


Form is loading...

Build your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.