Recent Topics

Problems with b2Evo after installation

Started by on Feb 28, 2008 – Contents updated: Feb 28, 2008

Feb 28, 2008 17:39    

My b2evolution Version: 2.4.0 Venetian

I have some troubles with the installation of the forum.
After I do a install on the b2Evo, it brings me to the admin login screen, where after I enter the login/pass combination I encounter the following problem:

"Warning: main(/homepages/0/d91588195/htdocs/bostonbg/xpress/blog/skins_adm/chicago/_adminUI.class.php) [function.main]: failed to open stream: No such file or directory in /homepages/0/d91588195/htdocs/bostonbg/xpress/blog/admin.php on line 163

Fatal error: main() [function.require]: Failed opening required '/homepages/0/d91588195/htdocs/bostonbg/xpress/blog/skins_adm/chicago/_adminUI.class.php' (include_path='.:/usr/local/lib/php') in /homepages/0/d91588195/htdocs/bostonbg/xpress/blog/admin.php on line 163"

I have tried to find other people with the same problem here on the forum, but I couldn't so here am I stucked with this. Anyone can help on this one? My hosting is on 1and1 and the MySql version is 5, php version is 4.4.7

Feb 28, 2008 18:28

Hi skabg. Welcome to the forums!

Does your blog work on the public side, meaning can you see it even though you can't get to the admin section?

I would start by assuming a file got jacked up somewhere somehow. Download the .zip package again, unzip it on your computer, DELETE the /skins_adm/ folder from your server, then upload the NEW /skins_adm/ folder to your server. If the problem was a corrupted file in that admin skin it'll be gone. If it wasn't then you'll know that's not the solution :)

Feb 28, 2008 19:24

Yes, the blog seems to work on the public side. I can post comments and view the demo articles, but I can't go in the admin section. It appears on the login screeen, that I'm logged in as an admin
"Note: You are already logged in as admin! Continue ยป", but when I click continue that error is what i see.
I have tried to remove all files and database and then reinstall the b2evo, but I get the same thing. Is it possible that the problem is with the skin? Is there way to change the default skin w/o entering the forum as an admin? maybe somewhere in the config files?

This is admin.php - Lines 161 to 167

161 * Load the AdminUI class for the skin.
162 */
163 require_once $adminskins_path.$admin_skin.'/_adminUI.class.php';
164 /**
165 * This is the Admin UI object which handles the UI for the backoffice.
166 *
167 * @global AdminUI

Feb 28, 2008 19:49

Problem solved. the blog was downloaded and unzipped thru SSH shell, then installed. I guess during the unzip process some files were corrupted or had different chmods.
Now i used FileZilla to re-upload the skins folder and everything seems to work.
Thank you for your help.

Feb 29, 2008 02:43

Congratulations, and thanks for reporting what you found and how you fixed it!


Form is loading...

b2evolution CMS – This forum is powered by b2evolution CMS, a complete engine for your website.