Recent Topics

[0.9.0.8] IIS: $ReqURI is empty [duplicate]

Started by on Jun 15, 2004 – Contents updated: Jun 15, 2004

Jun 15, 2004 04:29    

Sorry guys, it looks like I may have broken it already. :oops:

I did an upgrade from 9.0.5 to 9.0.8.
- I deleted all of my original files from 9.0.5 files
- Ran the installation and let the b2evo update my _config file
- Upgraded my database to the new version
- Verified I could login
- Enabled "New User Registration" and logged out.
When I attemped to login again I received the following error:

The page cannot be displayed
The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.
--------------------------------------------------------------------------------

Please try the following:

Contact the Web site administrator if you believe that this request should be allowed.
Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
HTTP Error 405 - The HTTP verb used to access this page is not allowed.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

This is the URL that is being displayed at the login screen:
{http://www.phoenixcolony.com/blogs/htsrv/login.php?redirect_to=%3Fpaged%3D1%26amp%3Bpage%3D1%26amp%3Bdisp%3Dposts}

After not being able to logon I created a new user and was successful, however I was still presented with the same error when I used the login info for the newly created user. I was able to page back to the previous 'Settings' screen and deselect 'Enable New User Registration'.
I was asked to login again, entered my information (and it was sucessful), had to repeat deselecting 'Enable New User Registration' (I was taken directly to the Settings screen) and clicked Apply. After disabling that feature I was able to logon and off repeatedly without incident.

If an admin/moderator/bug-squasher would like access to my server for their testing needs feel free to contact me.

- Phoenician

UPDATE:

It appears that it actually has nothign to do with enabling 'New User Registration'. It seems like IIS 6.0 does not like the way 9.0.8 handles the logon URL. Or it could be a PEBKAC issue.

Jun 15, 2004 10:53

I had to roll back to 9.0.5 however, I did a clean reinstallation of 9.0.8
to a different directory incase the mods and other offical-type folks want to check it out. I even tinkered with my server configuration for a few hours just to eliminate the PEBKAC factor. *sigh* Bleeding edge technology.
FYI - I have 9.0.8 installed at www.phoenixcolony.com/oslo
If people want the passwords to tinker with it contact me offlist.

Jun 20, 2004 09:22

Greets from Texas!

I see you're running windows with IIS. I am too. I haven't had a lick of trouble with b2evo until just now. I get this very same error you are experiencing. I don't know enough about PHP to be an expert, but I want to conjecture that this error is due to their use of a feature of apache known as url_rewrite or mod_rewrite that does not work under our IIS webservers.

Just for grins, I uploaded the exact same directory I have on my personal server and the associated database to a hosted linux box I have access to for test purposes. SURE ENOUGH, the login page works on the linux box. This leads me to believe that my primary conjecture is correct and they are using a URL_rewrite type function that is unsupported in windows.

Developers/Admins - can we please get a fix?? I'd like the main login form link to work for windows please.

OP- there is a temporary solution to this. Instead of using the link to the login form off your index page, you can go to b2_install_dir/admin and that login form works perfectly for administering the blogs.

Jun 20, 2004 22:50

That's exactly correct. I was about to ask if there was anyone that was running IIS 6.0. Even running IIS 6 in 5.0 isolation mode does not work. I had to revery back to 9.0.5 for a fuctional blog site.

Jun 21, 2004 12:30

It's the same bug that mattbta has [url=http://forums.b2evolution.net/viewtopic.php?t=1596]reported[/url].

the URL displayed at the login screen only includes the GET params and not the whole $ReqURI, therefor it will probably give an ifinite loop or sth.

Please try adding the debug info I posted in the other thread.

Also answers should go there please..


Form is loading...

b2evolution CCMS – This forum is powered by b2evolution CMS, a complete engine for your website.