Recent Topics

Installation problems *sigh*

Started by on Jun 16, 2004 – Contents updated: Jun 16, 2004

Jun 16, 2004 19:15    

I had the same installation problem as RonB, and I tried to follow what advice was given to him but I keep getting the same message:

MySQL error!

Error establishing a database connection!

1. Are you sure you have typed the correct user/password?
2. Are you sure that you have typed the correct hostname?
3. Are you sure that the database server is running?

This has happened every time I`ve been hosted when my mySQL host was localhost. ...>_<...

Jun 16, 2004 20:22

Forgive me if I'm asking the obvious, but it's always best to cover the basics first. Are you sure the DB username and password are right? Does the database already exist?

Jun 16, 2004 20:25

I`m pretty sure, I`ve double checked, I run into this problem everytime I am hosted.

Jun 16, 2004 21:16

Every time you are hosted? What do you mean? Surely your site needs to be hosted somewhere to get it working... Unless you run your own server...

Jun 16, 2004 21:24

I mean, when I am hosted with a subdomain. Usually I want to set up b2 or b2evolution and the mysql host is "localhost" it doesn`t work, but if it`s an outside source then it`s perfectly fine.

Jun 16, 2004 21:37

How are you setting the config up? Through the installation routine or by manually editing the file?

Jun 16, 2004 21:52

I tried the installation routine, then I tried manually editing the file...what do you do after you edit the file?

Jun 16, 2004 21:59

Save it, the upload it to the /conf folder. I have to say, it sounds very much like it's a problem with your server somewhere...

Jun 16, 2004 22:03

Are you sure? This has happened four times with four different accounts.

Jun 16, 2004 22:10

No I'm not sure. My money is still on either a config error, or the database not existing...

Jun 16, 2004 22:24

localhost may not be the right setting here. check with your hosting provider.

Jun 17, 2004 00:15

Maybe its: localhost.localdomain

Jun 17, 2004 01:07

I asked my host, she said it was localhost and I tried localhost.localdomain which didn`t work either :(

Jun 17, 2004 01:52

can you log into MySQL using any other method? Do you have shell or terminal access to your server? If so, try connecting, and typing this at the prompt:

mysql -h localhost -u YOURUSERNAMEGOESHERE -p

and press return. (Replace YOURUSERNAMEGOESHERE with your MySQL username.) It'll prompt for your password, so type that in. What happens?

If you don't have shell access, do you have phpMyAdmin, or any other program where you can log in and do MySQL stuff? When you're in phpMyAdmin, it should say "database on hostname" at the top of the page. What do those say?

Somehow, there's a discrepancy between the name that is entered in b2evolution, and the reality of where your server is. But we certainly wont' solve the problem by just repeating over and over, "are you sure it's localhost?" "yes, i'm sure" "is that what you entered" "yes, that's what i entered."

Jun 18, 2004 15:52

I had this problem, but resolved it by doing the following:
Removing and re-adding the user to the database with proper permissions.
Manually editing the config file.
Closing all browser windows and clearing the cache.
Going to www.mysite.com/admin and running the initial database setup there.

Everything seems to have gone fine after that.


Form is loading...

Photo gallery software – This forum is powered by b2evolution CMS, a complete engine for your website.