Recent Topics

1 Mar 18, 2009 00:00    

My b2evolution Version: 2.x

I have searched everywhere for this prob, but did not find anything.
If it exists, please let me know where.
Where do I go to solve this??

PHP upload_max_filesize = 8 Mb
PHP post_max_size = 8 Mb.

Pink bar underneath:
post_max_size should be larger than upload_max_filesize

b2evo version = 2.4.6 released on 01/12/09
MySQL version = 5.0.67.d7-ourdelta-log+
PHP version = 5.2.5


2 Mar 18, 2009 01:01

You can adjust these variables in your .htaccess file.

For example, if you want to make the post_max_size bigger, say 10Mb, add a line to .htaccess that reads:

php_value post_max_size 10M

3 Mar 18, 2009 01:40

Tried it, does not appear to work. Know nothing about coding tho'

4 Mar 18, 2009 02:39

Maybe you hosting provider doen't support changes to php though .htaccess files. In that case, you should ask them for changes in your php.ini.

5 Mar 18, 2009 04:43

I'm with Godaddy. What should I ask for?
Sorry for the newbie Q

6 Mar 18, 2009 04:44

PS: I have made other changes to php.ini but they don't show/work

7 Mar 18, 2009 09:54

Some hosts don't much care for clients changing php default values. these values are normally kept in php.ini but can also be changed on a directory-by-directory basis by .htaccess

So you need to find out from Godaddy how you do this, or indeed if they will let you. They might want to do it for you, or they might tell you some other way to do it.

While you are at it, can you tell us your domain, and exactly where the .htaccess you are changing is kept? Possibly you are changing the wrong one.

8 Jul 25, 2009 19:40

THX, guys.
Sorry I did not come back to this earlier. As you may know, asking Godaddy for support is much like asking a camel to lay eggs. It's just not gonna happen ;)
Since this "problem" does not seem to affect site operation, I've decided to just let it lay...
My domain is and the .htaccess I was changing is located in the site root.

Again: thanks for your input.

9 Jul 26, 2009 07:17

All my websites hosted on Godaddy and I like the price, can't say anything about their support since I don't need it :)

Anyway, you should name your ini file depending on PHP version you're using: php.ini or php5.ini

Here's a copy of my php5.ini
ps you may not need that huge values if you don't play with large DBs

register_globals = off
allow_url_fopen = off
magic_quotes_gpc = off
cgi.fix_pathinfo = 1

memory_limit = 128M
post_max_size = 100M

file_uploads = On
upload_max_filesize = 90M
upload_tmp_dir = /tmp

expose_php = Off

max_execution_time = 1900
max_input_time = 1800

variables_order = "EGPCS"

extension_dir = ./

precision = 12
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimiz er-3.3.3
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Opti mizer_TS-3.3.3

10 May 03, 2010 18:17

Hello! Is there a fix for this same problem in version 3.3.3? I've tried all these fixes stated for version 2.x but nothing seems to work. Any help will be appreciated. Thanks!

11 May 03, 2010 18:36

What problem are you talking about?

12 May 03, 2010 18:42

Trying to set the max post size larger than the max file upload size.

13 May 03, 2010 19:09

You should ask your hosting support about php.ini
The server might be configured to ignore user's php.ini files.

14 Jun 12, 2010 04:50

Just wanted to say thanks. Reading this post got my problems solved after about 30 minutes of tinkering.

15 Jan 12, 2011 06:04


I just had to remove this line of code to solve this: cgi.fix_pathinfo = 1
You rock!

Form is loading...