Recent Topics

1 Mar 15, 2010 04:53    

My b2evolution Version: 1.10.x

I have b2evolution on my webserver. I was having trouble uploading my posts to the new version. I have copied some of the files through sql importing but I only got 2 posts. How can I upload the additional posts?
Nancy Clothier

2 Mar 15, 2010 06:29


Please go to this URL

try to look and follow the upgrade from 1.10.x to 2.x

try to go back here if that fails. And we will troubleshoot for you.

good luck

3 Mar 15, 2010 13:52

I contacted my isp (LiquidWeb) and they checked the status and this was their reply:
I have investigated further, and found that the reason the upgrade would not
commence is because the blog folder was owned by root instead of your domain
user. I have corrected this and it has properly upgraded.

Now when I go to the site I get the following error:
An unexpected error has occurred!

If this error persists, please report it to the administrator.

Go back to home page
Additional information about this error:
Requested Skin does not exist!

5 Mar 15, 2010 14:53

I didn't import the database. I do have an sql version of the data. Should I import it now? I couldn't do the incremental upgrades and it wasn't as option with the isp.


7 Mar 15, 2010 15:18

and make sure that the skin is for 3.3 version

8 Mar 15, 2010 17:01

I am making progress. I don't want to reinstall the full sql so I have been doing it table by table. I have the posts showing but not the sidebar or header. Do you know which tables those would be in?

9 Mar 15, 2010 17:38

I am making progress = now have the skin, header and sidebar.

Now I cannot upload photos - which is were I started with this problem. when I create a post, and try to attach photos, the popup comes up empty.

10 Mar 15, 2010 18:21

You really need to import the full 1.10.x database and then just run the installer and choose the upgrade option


11 Mar 16, 2010 01:26

I get error messages because the fields are not the same in the old version as the new version. Does this require that I edit the sql fields to match the new version?

12 Mar 16, 2010 08:12

No, once you upload your old database it should squawk at you that the database is out of date "I require version ### and you have version ###" and a link to the installer.

Click the link and then select "upgrade database"


14 Mar 16, 2010 14:49

I am running this through my ISP. The upgrade was done by them. The database is already 3.3.3 but all the data didn't get converted. Now I have the new version but all the data didn't get imported. I have determined some of this data and done the import manually by checking the table and making sure the fields match. As far as I can tell the only thing not working correctly is the file manager so I think there is some data that isn't there. Does that make more sense?

15 Mar 16, 2010 17:49

If you have a backup of your 1.10 database then this is what you need to do :

1) drop all your 3.3.3 evo tables
2) import your 1.10 evo tables
3) hit
4) choose "upgrade"


16 Mar 16, 2010 21:53

Thank you for the help. I did the process and it worked well. Unfortunately, I still have the same problem that led me to the upgrade in the first place. I can no longer upload photos from my computer. I actually have two installations now and on one, it said the media file doesn't have the proper permissions. However, my original installation does and it still doesn't work. When I check the upload images and links, the popup window is blank. I checked to be sure filemanager is enabled.

17 Mar 17, 2010 17:41

To be able to upload files php needs write access to /media/ /media/blogs/ /media/users/ if you run suphp then 0755 will suffice, otherwise you'll need to 0777 those folders.

You shouldn't be getting a blank popup so you may have a corrupted file. Best thing to do is to grab a brand new copy of the zip and re-upload the whole of your /inc/ folder


Form is loading...