Recent Topics

1 Apr 08, 2010 01:32    

My b2evolution Version: Not Entered

I recently installed 3.3.3 and have an issue where many of the images (like smilies, or skin thumbnails, etc) are not showing. For example, when I am editing a blog entry, in the editor, where I should be seeing a bunch of smilies, all I see is the "alt" code for t he smile. Some thing when I try to insert a smile in a post. The image files are all there in the proper directories, but for some reason the are not showing up. A similar problem (probably related) is when I view the available skins, I only see the name of the skin and not the thumbnails for the skins. Any help would be greatly appreciate.

3 Apr 08, 2010 04:59

Yes, if I type in the URL of the image directly I can see the image in my browser.

4 Jun 06, 2010 20:51

I am having this exact same problem after a new installation of 3.3.3.

You can see it here:

There are lots of red x's anywhere an image should appear. Clcking on the red x shows the image (so it is being hosted... just not displaying in posts). Some other images (logo, etc) do show, but others don't.

The same problem also exists with some icons in the admin panel.

I'm puzzled.

5 Jun 07, 2010 02:38

You need to install PHP GD library. You should talk to your host

Fatal error: Call to undefined function imagecreatefrompng() in /home/zqv/public_html/blog/blogs/inc/files/model/_image.funcs.php  on line 150

6 Jun 07, 2010 17:21

Thanks sam2kb. Your help is very much appreciated.

I did the PHP GD library installation (I have the cpanel/whm) so it was easisly accomplished). And you can see that it worked for many of the images (mostly for the various icons). But, I am experiencing another problem which you can see here:

.evocache folder read/write error check file system permissions

I did a search for that... and found this thread (from 2009) where you (sam2kb) had disussed this same problem:

And so I tried the recommendation which you gave there to make the permissions to the media folder and all the sub dirs to 777. But, the problem still exists.

Perhaps a clue is that I do not see any .evocache folders in any of the media sub dirs.

I tried adding an image on that first post in the admin panel (with the Add/Link files feature)and I got this messge:

An unknown error occurred when moving the uploaded file on the server.

I tried creating a new folder to try to add an image that way... but then I got this:

Notice: Undefined variable: fm_Filelist in /home/zqv/public_html/blog/blogs/inc/files/files.ctrl.php on line 405

Notice: Trying to get property of non-object in /home/zqv/public_html/blog/blogs/inc/files/files.ctrl.php on line 405

Warning: Cannot modify header information - headers already sent by (output started at /home/zqv/public_html/blog/blogs/inc/files/files.ctrl.php:405) in /home/zqv/public_html/blog/blogs/inc/_core/_template.funcs.php on line 174

Warning: Cannot modify header information - headers already sent by (output started at /home/zqv/public_html/blog/blogs/inc/files/files.ctrl.php:405) in /home/zqv/public_html/blog/blogs/inc/_core/_template.funcs.php on line 182

Would it help for you to have my ftp info and admin info? I would be happy to provide that to you. Like I said, your help on this is really appreciated.

7 Jun 07, 2010 17:30

If you have WHM access, install suphp and kill the world write access ;)


8 Jun 07, 2010 18:55

Hi ¥åßßå, thanks for your response. I just now (after your suggestion) installed suphp and recompiled everything and then killed the world write access.

But, the problem still remains. As you can see here:

I would be happy for you to have server, ftp and blog admin access if you would care to look at it deeper. Or if you have any other ideas, I will try them quickly.

Here is my phpinfo.... I don't see the suphp on there (although I did go through the install and compile, and when I go look in whm it shows it as checked)... should it show here?

9 Jun 07, 2010 19:21

Assuming you also have ssh access, check the ownership of your .evocache folders, or just run

chown [your-user]:[your-user] ~/public_html/media/ -R

Amend user/group && path to suit your install.

Also make sure that you've enabled suphp for your version of php ( WHM > Apache Configuration > PHP and SuExec configuration )

And, finally, make sure you've killed safe mode ;)


10 Jun 07, 2010 21:17

That fixed it!!!! ¥åßßå, you are the best, as I first observed back in 2007. Thank you so much. And thanks also to samkb2 who recommended the GD library installation (who has also helped me previously).

As you can see, everything is working now. What amazing support... I do attempt to give a bit back from time to time, but it is always based on my limited knowlege. It's experts like you who enable me to learn (and fix my messes).

11 Jun 07, 2010 21:49

Giving back what you can when you can is what it's all about ;)

Glad your problem is solved.


Form is loading...