Recent Topics

1 Aug 19, 2010 18:27    

My b2evolution Version: 3.3.3

I have created a new group called "students" allowing full access to a new blog and a dummy user assigned to the student group called "Tester." Tester has level "8" permission and and email and a password to try out my blog before I put it into production. When the dummy "Tester" user signs on, however, the "write" button is grayed out and the user cannot post. What gives?

2 Aug 20, 2010 09:34

i have read it ,but i have no idea to repy it .sorry.

3 Aug 20, 2010 16:28

Happyday123, make relevant posts or get binned as a spammer :|

Sweaty, you need to allow user posting rights :
admin > blog settings > [blog] > users/groups > add user/group.

Note : you'll need to enable "use advanced perms" stuff on admin > blog settings > [blog] > features before you see that option


4 Aug 20, 2010 19:46

Finally found the advanced settings. experimenting...

Also I made the student "Tester" a "member" of the above group.

Still, no go... >:-<

Also, does it make any difference that I made the blog private. I'm assuming that people who log into a private blog can post material that non-users can't see publicly?

5 Aug 21, 2010 17:34

Check that the users group has "access to admin" (visible link or not ), and you may wish to play with user level, the numbers do stuff but I can never remember what, > 3 often works


6 Aug 22, 2010 18:43

Still no go. And I set the user level to 9. But if they use the "back office" login button instead of just plain log in, they can post and edit. Does that help explain my issue? I'd like go get this fixed before Tuesday 8/24. Can I send you screen shots of the relevant config screens?

7 Sep 08, 2010 14:47

I am having the same problem, so sorry for tagging onto your post! I am running 3.3.3 and if this post goes through (spamming issue>.<) I'll post my settings to see if anyone has any ideas.

8 Sep 08, 2010 15:08

ooh! it went through!

My site is

So, I am trying to set my permissions to allow users to post to this blog only (not just comment) but its not working for my test user. The only tabs that show on the grey bar are "Admin" and "Logout". I don't even get the "see", "Write", etc. tabs. Here's my settings so far:

Blog settings>features>multiple authors - checked both use advance permissions and use workflow; in this same area I also have subscriptions and list of public blogs checked.

Blog settings>user perms (advanced layout) - test user (lvl 5) checked "Is member", can post/edit "publ" and "drft", edit post user lvl "own posts", "delete posts", and Media directory "upload", "read", and "write".

Blog settings>group perms (advanced layout) - bloggers group checked "Is member", can post/edit "publ" and "draft", edit post user lvl "own posts", "delete posts", and Media directory "upload", "read", and "write". (Same as test user)

Users>Bloggers - General section Access to Admin Area set to "No access", Blogging permissions "Blogs" section set to "Depending on each blog's permissions", everything else should be default.

Thanks for taking a look...

9 Sep 13, 2010 20:20

One solution I haven't tried to control access, is to password protect the blog folder from Control Panel on your webhosting site. Maybe that will work. I went back to Wordpress.

10 Sep 16, 2010 03:17

I worked so hard to create this blog to match the rest of my site, I don't really WANT to start over again...but I'm a one-woman show when it comes to my website, and I just can't spend all my time fighting with my blog.

I'm sorry that the creator(s) can't log on to troubleshoot anymore, if I were a techie I'd help out but as it is, I'm the noob stabbing blindly at the multitude of code trying to make stuff work. I understand this is a free software, and I don't mind having to do the grunt work myself, just so long as there is someone available to walk me through any problems!

My webhost also suggested Wordpress, so maybe I'll check them out...

11 Sep 16, 2010 19:55


well, your only problem is not being able to write posts, it seems. I have signed up to see what was going on but i did not get an activation should check with your host that first

12 Sep 17, 2010 01:43

Thanks for trying to help. Could it be something I did during setup? I didn't know there was supposed to be an activation - I figured it was set up to alert me when a user registered and I would change the settings depending on the user. I'll check with my host and see where that goes...

Form is loading...