Recent Topics

[4.1.1] Upgrade from 2.4.7 hanging

Started by on Oct 17, 2011 – Contents updated: Oct 17, 2011

Oct 17, 2011 03:44    

My b2evolution Version: 4.1.1

I am trying to update from 2.4.7 to 4.1.1, and the upgrade script hangs in

Updating keyphrases in hitlog table... 

I tried to locate this, and got as far as Hit::extract_params_from_referer.
In particular, the call to is_search_referer seems to go into neverland.

extract_params_from_referer( $ref )
                global $search_engine_params, $evo_charset;

                @list( $ref_host, $ref_path, $query, $fragment ) = $this->is_search_referer( $ref, true );

Can anybody help with that?

Oct 17, 2011 06:54

If you see a lot of dots on the screen during hitlog update, it's normal. Just wait until it finishes.

If you don't want to wait or if the script really hangs (no dots appear) you may need to empty evo_sessions & evo_hitlog tables before upgrade.

Oct 17, 2011 07:08

No dots showed up.
I found a way around the problem, though.
I ran the 3.3.3 install first, and then the 4.1.1 install goes through with the long row of dots.
So, there clearly is a problem with upgrading directly from 2.4.

Oct 17, 2011 08:38

I will check it. Thanks for the info on v3.3.3 installer

Form is loading...

Forums software – This forum is powered by b2evolution CMS, a complete engine for your website.