Recent Topics

Problem: twitter

Started by on Sep 03, 2012 – Contents updated: Sep 03, 2012

Sep 03, 2012 23:13    


I have a problem with the twitter plugin.
I have b2e Vers. 4.1.5
I signed in the user to twitter (User, edit user, adv. settings)
I alo have enabled the b2evolution tweet plugin in twitter
but when I write and send a new blog I get no twitter tweet.

What make I wrong?

Sep 04, 2012 02:22

See if twitter is also enabled for your blog: Blog settings > Advanced > Ping

Sep 05, 2012 14:21

Hello sam2kb,

yes it is enabled.


Sep 05, 2012 14:30

Can you post here the exact messages you get when you create a new post?

Sep 05, 2012 14:45

I get:

Could not authenticate with OAuth.
Eintrag wurde erstellt.

Sep 06, 2012 10:27

Well, after I searched for "O-Auth" i found some threads ind this forum.
If I understand correctly the hosting provider has to enable O-Auth in his system/server. I this is not the solution, please let me know.
I wrote a mail to the hoster to activate O-Auth but I still have no answer.Thanks,

Sep 06, 2012 19:59

Let's see what they say.

Sep 11, 2012 13:33


well the hoster say that it is not possible for him ti install the O-Auth as PECL Modul. They recommend to use oauth-php as option. Does anybody have any experience with oauth-php?


Sep 11, 2012 20:44

Well the plugin is already using oauth PHP. There must be some other reason why you get that error.

Sep 13, 2012 09:40

Hi Sam,

thanks für your answer.

Well, the b2e system status is ok.
There is only a red sign at "PHP post_max_size = 8M". The system says: "post_max_size should be larger than upload_max_filesize"
If this should be the problem, I know the hoster will be also uncooperative.
"PHP opcode cache" is non. All other lines are green.

Are there any other logs to find the fault? Any other suggestions?

Thanks a lot!

Sep 13, 2012 11:55

Nope that info is unrelated.Did you try disconnecting your twitter account and reconnecting

Sep 13, 2012 15:35

Hi tilqicom,

yes, I did it 2 or 3 times in the past and now again.

On twitter/apps there is the "b2evolution tweet plugin" enabled.
There is also no problem to link the twitter account by b2e - every steps are working/running.
But when I now write an article in b2e and I publis it, I get still the message: "Could not authenticate with OAuth."

Global settings, twitter plugin is active.
Blog options, plugin settings, twitter plugin is linked to the twitter account.

Are there any other settings?

Sep 13, 2012 18:43

Did you also try removing the permission from your twitter account and re-allow the app ?

Sep 14, 2012 10:39

Yes I did - several times.

Am I the only person with this problem? Seems so :-(

Where is O-Auth located? Is it a component of B2e or is it something at twitter? When I always get the message "Could not authenticate with OAuth" is this a plugin login problem from b2e to twitter or has twitter modified anything during the past weeks?

Thanks a lot!!!

Sep 17, 2012 14:11

Very curious!!

Today I installed b2e on an "own" webserver. Before I pleased the technician to install / enable O-Auth. They did it.
I installed the original b2e with a blank database. Loged in the backend, I attached the twitter account, wrote a new artikel, send it and:

"Could not authenticate with OAuth."

Well, after this last test I am sure anyway that the fauld could not be the hoster(s).
Had there some changes at the twitter api?
Is it a bug in the b2e files?
Are there any other settings (to do) I forgot? I only enabled the twitter plugin and link to the twitter profile. The b2e app is enabled in twitter.

I would be very glad to get some information to handle this problem.
Thanks a lot!


Oct 01, 2012 21:52

Sorry, but I still have the problem with "Could not authenticate with OAuth."

Are there any special setting neccessary? Any special CMD-settings in the twitterauth? Any special entries in the auth-files? Or has twitter changed the settings maybe?

Can't believe that only I have this problem ...
Hope for any kind of help! :-)

Oct 01, 2012 21:54

Can you PM me FTP and b2evo login/pass to your blog?

Oct 01, 2012 23:28

send you an IM
Thanks a lot!

Oct 02, 2012 01:48

I'll check it later tonight.

Oct 02, 2012 10:04

Hi Sam,

thank you very much! I'm curious about it.

Oct 04, 2012 15:17

Hi Sam,

Did you find out anything, or is it too complicated?
Thanks a lot,

Oct 04, 2012 17:32

I'm sorry for delay, I didn't have time to look at your website yet. I will.

Oct 07, 2012 01:42

All settings seem to be OK, requests get sent to Twitter.
Here's the response I received trying to tweet from your website


'http_header' =>
  array (
    'date' => 'Sat, 06 Oct 2012 23:31:10 GMT',
    'status' => '401 Unauthorized',
    'content_length' => '85',
    'www_authenticate' => 'OAuth realm=""',
    'cache_control' => 'no-cache, max-age=300',
    'content_type' => 'application/json; charset=utf-8',
    'x_runtime' => '0.00959',
    'set_cookie' => '_twitter_sess=BAh7CCIKZmxhc2hJQzonQWN0aW9uQ29udHJvbGxlcjo6Rmxhc2g6OkZsYXNo%250ASGFzaHsABjoKQHVzZWR7ADoPY3JlYXRlZF9hdGwrCDoKazg6AToHaWQiJTZh%250AYTZjN2YyNTc1NGNkMDVmNzdjODFkOTc1NTM4YzMw--21fe58fab51bd2d94414295ffd8cf0910c7465bb;; path=/; HttpOnly',
    'expires' => 'Sat, 06 Oct 2012 23:36:09 GMT',
    'vary' => 'Accept-Encoding',
    'server' => 'tfe',

So the message is "401 Unauthorized"

Try to tweet from my demo blog
user: test
pass: test-test

or from b2evo demo

Oct 07, 2012 01:45

Is this your server? Try to sync server time, it might help.

Oct 07, 2012 01:54

Also no need to install any Pear or PECL oAuth extensions, remove them if they are present.

Oct 07, 2012 17:13

Hello sam2kb,

thanks for your help!

No, it is not my server. It is a usual webhosting account at the hoster

I asked the support if they cam install oAuth extention but they anwered that this is not possible. So there are no oAtuth extentions present.

So what effects the "'status' => '401 Unauthorized', "? Is it a connecting error between webserver to twitter?
What do you mean with: "Try to sync server time, it might help."


Oct 07, 2012 17:27

401 Unauthorized means twitter didn't authorize that API call i.e. Wrong username/pass, bad signature, etc.

It looks like if server time is out of sync, twitter rejects requests from it. Let's say GMT time is 9:00 and your server shows 9:12, in that case API signature is "old" and twitter rejects it.

Oct 07, 2012 17:29

Anyway, try to tweet from either my or b2evo server. That way we can be sure it's not a limitation on your account.

Oct 07, 2012 17:40

OK, now I understand. Sorry I am not an api-professional...

You meand I should login in the demo b2evo and make a connection to my twitter accound in the b2evo settings and post an article then. Just to see if it works with twitter?

Oct 07, 2012 17:48

OK, well it works... :-/

I loged in at:;user_ID=4

then I set up my twitter account at the test pofile, I post an artikel and I could find it on twitter.
Damn :-/

I now send a ticket to the hoster support with your statements. Hope they can fix the problem.

Oct 07, 2012 18:52

gerald wrote:

OK, well it works... :-/

I loged in at:;user_ID=4

then I set up my twitter account at the test pofile, I post an artikel and I could find it on twitter.
Damn :-/

I now send a ticket to the hoster support with your statements. Hope they can fix the problem.

have you tried with another twitter account ?

Oct 07, 2012 22:45

Hi tiquicom,

do you mean a test with a second twitter account with my blog?
Yes I did. Same error: "Could not authenticate with OAuth."

If you mean a test at sam2kb test-blog - no, should I do it?

Thanks a lot!!!

Oct 08, 2012 00:06

It's definitely a problem on your server. If you can successfully tweet from my server you twitter account is fine.
I would have contacted both twitter and your server support.

Oct 08, 2012 08:40

Hello sam,

I'm going crazy. I got the answer from the hoster. I'll translate it:

... We ask for your understanding that we can not provide support for scripts or web applications from third parties. Many of our clients use Twitter plugin in Joomla, Wordpress and other CMS and shop systems.

The error message also indicates that it has not been properly authenticated (on Twitter). Therefore, we can not see why the problem is to be with our server. Moreover, it is not possible to align the server time on the server are abroad. Since you are on a shared hosting product like the WebPack share the server with multiple clients, no customer has the opportunity to meet server-wide settings...

You wrote that I should also contact twitter. Do you have an support email address? I am not able to find one on the twitter website.

I just saw on the twitter account, that there are time settings at the settings page. Actual I have the setting (GMT +1 Berlin). May this be the fault because twitter is in the USA?
If not, may there be any possibility to adapt the time in the oauth files?

Thank you very much!

Oct 08, 2012 17:58

Any reason why you can't switch to a better hosting? The time zone difference is ok, what I meant is if server time is out of sync in the same timezone.

Anyway, all this time thing was just an idea.

I don't know any Twitter contacts, you should be able to find them on developer's website.

Oct 09, 2012 10:19

Hi sam,

ok, as I understand your answer, the time-sync thing was an idea not the problem definatelly?

Of course could I change to an better hoster. You won't believe it but I already tested the website/blog with 1+1 (europear largest hoster) and also with an very good hoster for professionals. In all three cases I have the same problem.
Meantime I tried to contact twitter by @hilfe, but got no response until now.

When I read your code again I can see:

'date' => 'Sat, 06 Oct 2012 23:31:10 GMT', and
'expires' => 'Sat, 06 Oct 2012 23:36:09 GMT',

so there is a time window of 5 minutes to place the tweet.
(I think that your posted code is a log of b2evo?)
I there any possibility to get the time of twitter when I place a articel, so I can match the two timestamps?

How did you activate the log showing after publishing an article. So I may get the log also at the other installations?

Thanks a lot!

Form is loading...

Advanced CMS – This forum is powered by b2evolution CMS, a complete engine for your website.