Recent Topics

1 Jan 18, 2006 18:20    

Ive been messing around with this for a couple af hours.

Ive got FCKeditor working with version 0.9, but cant seem to get it working in Phoenix.

Instead of installing it in edit_form.php it seems it must be in _item_form.php

I have included the basic script before the long javascript
Line 46
<script type="text/javascript" src="../fckeditor/fckeditor.js"></script>

Then before ----START EDIT FORM----
Line 117

<script type="text/javascript" language="javascript">
window.onload = function()
var oFCKeditor = new FCKeditor( 'content' ) ;
oFCKeditor.BasePath = '/blog/fckeditor/ ' ;
oFCKeditor.ReplaceTextarea() ;

When i i try to write a new entry then

Parse error: parse error, unexpected '<' in /var/www/nyhed/blog/admin/_item.form.php on line 117

Ive tried to place it several places but nothing happened. The textarea seems still to be called content in Phoenix, so it must be right.

I tried it in // This is for toolbar plugins
without the start javascript, but then it just shows the textarea and results in a small javascript error.

Has anybody migrated to Phonix with FCKEditor, if so how did you do it :-)

Hope someone has a great answer.

2 Jan 18, 2006 19:44

"Parse error:".. this seems to be caused because where you inserted the JS there is a PHP section (enclosed by "<?php" and "?>").

Just try closing the PHP tag before ("?>") and open ("<?php") it again after your <script>-block.

The best way to do this though would be to make it a plugin.

I'll try looking into it later today or this week hopefully.

4 Jan 18, 2006 21:20

Ahh dammit now I am home. I dont have access to my server from here.

Ill get back on the plugin. Havent got any experience with plugins, but it seems I only have to place the file + the php file in the plugins directory, and then somehow enable it.

Thanks for the fast reply :-)


5 Jan 18, 2006 21:37

Yes, you'll have to enable it in "Settings / Plugins".

6 Jan 20, 2006 14:28

Sweeet. That was almost to easy :-)

Thanks for the help.

Had a wirkgroup meeting in another city, therefore this is the first chance i had of installing it.

7 Jul 17, 2006 17:05

Blueyed: Is there any chance to get your fckeditor plugin 1.8 compliant? It worked like a charm on 1.6, but 1.8 doesn't like it :(

Thank you in advance,


8 Jul 17, 2006 19:49

Please redownload the linked file from above, which I've updated to be v1.8 and v1.6 compatible.

I hope it works.. ;)

9 Jul 18, 2006 02:31

blueyed wrote:

I hope it works.. ;)

Now it works for me like a charm under 1.8.
Thank you Blueyed!!!

10 Jul 20, 2006 17:29

Hi, blueyed!

Thanks for this great work! I just set up a fresh installation of 1.8beta after using b2evolution 0.9 for a long time with fckeditor.

But I have problems configurating the toolbarset in fckconfig.js. When using fckeditor with b2evolution 0.9, I just deleted the toolbars I didn't need from the default toolbarset. But that doesn't work anymore.

fckconfig.js looks like this:

FCKConfig.ToolbarSets["Default"] = [
	] ;

I uploaded the file without any problems, and usually fckeditor now should show me a reduced version of the toolbar. But it obviously ignores my changes, and the complete toolbarset is loaded.

I cannot say if fckeditor.plugin.php causes this problems, but I'm quite sure that editing fckconfig.js worked fine in the past.

I already wondered whether fckeditor.plugin.php loads a toolbarset different from default. So, I modified fckeditor.plugin.php to

	<script type="text/javascript" language="javascript">
			window.onload = function()
				var oFCKeditor = new FCKeditor( ) ; // b2evoCanvas gets set by b2evo
				oFCKeditor.ToolbarSet = 'Default' ;
				oFCKeditor.BasePath = '<?php echo $this->url_fckeditor ?>';
				oFCKeditor.ReplaceTextarea() ;

But with no effect.

May anybody help me?



11 Jul 20, 2006 19:09

Are you sure that the right fckconfig.js file gets loaded?

Try adding an


message therein.

Also, look in the generated HTML, what oFCKeditor.BasePath is getting set to from the plugin.

12 Jul 21, 2006 07:53

Thanks, that was a good hint. :)

I don't know what went wrong: The old file could not be overwritten. It was still the same, although date and time of the file shown in my ftp client were changed as if it was the new one. The only way I could replace the old file was to rename the old one and then upload the new one.

Strange. :roll:

13 Aug 25, 2006 14:47

Got the editor working but I don't seem to be able to upload images when clicking the image button on the FCKEditor toolbar. Working locally with file structure webroot//blogs/plugins/fckeditor. I have edited the FCKeditor/editor/filemanager/browser/default/connectors/php/config.php file and the FCKeditor/editor/filemanager/upload/php/config.php to

$Config['UserFilesPath'] = '/blogs/media/fckeditor/'; that corrent.

I have also enabled $Config['Enabled'] = true ; in both of these files.

I have tried a lot of variation without success. Also I thought that

include("FCKeditor/fckeditor.php") ;

need to be included somewhere, but I couldn't see where it is included in Blueye's plugin?

AND (sorry) - is there anyway to use the to use the "Files" button (the b2evo button) at the bottom of the TextArea to insert images rather than the images button on the FCKEditor toolbar. At least then images would go into the correct Blog Directory....and it is much easier to use.

Sorry for all the questions but I am a dunce!

14 Sep 11, 2006 01:59

I have very similiar questions to Feathery. (but I don't expect the "files" button to work for fckeditor).

I'm just trying to figure out the config changes to get the images to upload.

15 Nov 13, 2006 20:49

o.k. i am a newbie, where exactly am i supposed to add the code to replace the default editor with fckeditor??? i have it installed and activated but i still see the default editor... any help would be appreciated 8|

16 Nov 13, 2006 21:56

I've marked the above file as OBSOLETE. It's not guaranteed to work and you would have to manually download the FCKEditor of course..

I'll update the tinymce_plugin I've already done, because it's easier to integrate smoothly, and then release this as a file download.

I've started with a more advanced FCKeditor plugin, but want to concentrate on one RTE, because, at least, I'm not using it myself.

If someone wants to maintain a FCKeditor plugin, I could finish what I have and pass it on, of course.

17 Nov 14, 2006 03:12

o.k. are there instructions on how to get the tinyMCE running??

19 Jan 31, 2008 00:29

I've always liked FCKEditor and was hoping that it might work with 2.4.0 but every time I try, it says that it Toolbar Set 0 cannot be found.

I have no idea how to fix that.

Form is loading...